A few issues and questions

Discussion in 'ISPConfig 3 Priority Support' started by jhewit, Nov 26, 2013.

  1. jhewit

    jhewit New Member

    Recently decided to setup a server with ISPConfig, installation went pretty smooth only had a few issues to iron out. Now we are faced a dilemma.

    We did not setup our server from scratch our datacenter loaded CentOS we picked up from there, so let me say that first and foremost.*

    We used the following guide:http://www.howtoforge.com/perfect-se...ot-ispconfig-3

    And followed the comments to work out the issues with Dovecot which now works fine for receiving e-mails. But we cannot send mails at all.

    We have verified with our datacenter that no ports are blocks.

    The other issue is we cannot access our ispconfig cp at our hostname, only be IP. Any ideas on what may cause this.*

    Thank you all for any help you can provide.
  2. jhewit

    jhewit New Member

    Not a big issue. But i also paid for subscription but not showing as a supporter.
  3. jhewit

    jhewit New Member

    Found and resolve the issue with postfix. It was a commented line in postfix, that was not noted in the guide or comments section.


    Ultimately: smtps and submission need to be uncommented, restarted server and issue resolved.


    The only remaining issue now is the hostname:

    being unable to access control panel at

    but can access it at
  4. jhewit

    jhewit New Member

    New issue discovered mail receieved is going into outside e-mail accounts spam folder... does anyone have any idea why this would happen?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Not evrrybody wants to get highlighted as supporter, so this is optional.Please see here for instructions to activate it:

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that your hostname exists in DNS. There should ba a A-Record for the hostname that points to the IP address of your server.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    First, fix the issue with your hostname as a non existing hostname will cause emails to be listed as spam. Then check that your IP address has a reverse dns record that points back to your hostname.
  8. jhewit

    jhewit New Member

    The hostname issue is resolved thanks for that and the other helpful post on how to set my group to supporter. How would I go about setting a reverse dns record, when I was using a VPS I just set it in the VPS control panel not Cpanel/WHM itself.

    Now running a dedicated box, out of a datacenter. With a dedicated 100Mbit connection. Would reverse PTR be accomplishable given I have full control of my IP range, either through SSH or a ISPCONFIG DNS entry for that domain?

    Thanks again.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats most likely correct. But you might have to ask you hosting provider for details of his setup.

    This depends on your hosting provider. Most providers offer the ability to set the reverse records for the IP addresses in their vps controlpanel. Some offer options that you run your own reverse zone, in that case, you can setup the ptr zone in ispconfig. In any case, you need 2 dns servers to run a zone, so it might be easier for you when you just set the reverse records in the controlpanel of your vps hoster.
  10. jhewit

    jhewit New Member

    I'm no longer on that VPS host, but will contact the datacenter this morning to see if they can setup reverse PTR on the servers primary IP.

    Also noticed the website harddisk quota for the primary domain is way off. There is a full installation of wordpress on that domain, and several other programs including WHMCS. It is showing it using 80KB. Any ideas what would cause that? Also was curious what is included in that harddisk quota figure?

    Thank you again for all your help.
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The harddisk quota usage is gathered from command:

    repquota -avug

    if the files are not part of the quota, then they are either owned by the wrong user or the partition has no quota enabled.
  12. jhewit

    jhewit New Member

    How would I check to ensure it is working or setup as it should? As the owner of that domain is admin or c0. Thanks again.

    Heard back from datacenter this what they said: In order to process your rDNS request in a timely manner, please submit your rDNS in the following format: IN* PTR* test.com.

    This assumes:
    IP Address:*

    So my question is my host name for this would be servername1.domain.com not domain.com correct?
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    The hostname is the name that you see when you run:

    hostname -f

    on the shell of your server. Most likely, thats servername1.domain.com if you used the naming scheme that we use in the tutorials.
  14. jhewit

    jhewit New Member

    One other thing is popping in a DNS check on INTODNS:

    Error Recursive Queries I could use the nameservers listed below to performe recursive queries. It may be that I am wrong but the chances of that are low. You should not have nameservers that allow recursive queries as this will allow almost anyone to use your nameservers and can cause problems. Problem record(s) are:

    How would I disable that in bind?
  15. till

    till Super Moderator Staff Member ISPConfig Developer


    allow-recursion {“none”;};
    recursion no;

    in the options {

    section of the named.conf file.
  16. jhewit

    jhewit New Member

    Fixed it, thanks again for all the help.

    Final question, I have a UCC SSL certificate from GoDaddy it has already been keyed and applied to the primary server. But now want to apply it to all the other services.

    To-do so I have a few questions:
    1. Do pop3, imap, and smtp use mail.domain.com ? The reason this is important is because the UCC can only be binded to a sub-domain.

    2. Where are the certificate files for pop3, imap, and smtp located or should be placed?

    3. What sub-domain does the FTP server use? (ie. ftp.domain.com)

    4. Where are the certificate files for the FTP server located or should be placed?

    Thank you again Till for all the help, it is greatly appreciated.
  17. till

    till Super Moderator Staff Member ISPConfig Developer

  18. jhewit

    jhewit New Member

  19. till

    till Super Moderator Staff Member ISPConfig Developer

    The intermediate cert is the bundle certificate, so just use that one.
  20. jhewit

    jhewit New Member

    Nov 26 12:05:01 hansel postfix/smtpd[28626]: fatal: /etc/postfix/main.cf, line 30: missing '=' after attribute name: "postconf -e 'smtpd_tls_CAfile = /usr/local/ispconfig/interface/ssl/ispserver.bundle'"

    One of the codes is causing postfix to error out as instructed in the guide. Looking at the format of the main.conf it looks nothing like that presented in the guide changed it to:

    smtpd_tls_CAfile = '/usr/local/ispconfig/interface/ssl/ispserver.bundle'

    Not sure what the postconf -e is supposed to-do but it appears to have accepted the way I modified it as ok. Will post if I run into anymore errors.

Share This Page