A couple of DNS queries with ISPConfig

Discussion in 'General' started by mphayesuk, Oct 24, 2007.

  1. mphayesuk

    mphayesuk New Member

    Ok the situation is:

    2 full public nameserver names that point to 2 of my public ip addresses (ie ns1... and ns2....)

    Running a Debian 4.0 server as per the setup guide. Server set with 2 local ip addresses and using a Juniper netscreen I have mip the same 2 public ips to the local ips of my server and forwarded all the ports needed.

    This is working because I can ssh and port 80/81 to my server using the public addresses.

    I have a bunch of domains that I have pointed directly to my nameservers (ie my servers will handle all DNS for those domains)

    So I added the site into ISPConfig and assigned it to the local ip address.

    And that doesnt work.... if you do a nslookup to on www.chesterfieldathletics.org.uk it resolves to the local ip address of my server not the public one.

    Contents of ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0C:29:66:55:71
    inet addr:192.168.8.5 Bcast:192.168.8.255 Mask:255.255.255.0
    inet6 addr: fe80::20c:29ff:fe66:5571/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:16934 errors:0 dropped:0 overruns:0 frame:0
    TX packets:11119 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2073444 (1.9 MiB) TX bytes:5296023 (5.0 MiB)
    Interrupt:177 Base address:0x1400

    eth1 Link encap:Ethernet HWaddr 00:0C:29:66:55:7B
    inet addr:192.168.8.6 Bcast:192.168.8.255 Mask:255.255.255.0
    inet6 addr: fe80::20c:29ff:fe66:557b/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:10068 errors:0 dropped:0 overruns:0 frame:0
    TX packets:6125 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1012340 (988.6 KiB) TX bytes:2417739 (2.3 MiB)
    Interrupt:185 Base address:0x1480

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2357 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2357 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:251332 (245.4 KiB) TX bytes:251332 (245.4 KiB)

    Contents of resolv.conf

    search touchone.co.uk
    nameserver 192.168.8.1
    nameserver 212.159.6.10
    nameserver 212.159.6.9

    ** 192.168.8.1 = Juniper netscreen 5tg
    ** 212.159.6.10 .9 = ISP DNS servers

    If anyone needs anything else let me know

    Thanks
    Martin
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The ISP-Manager part and DNS-manager aprt are independant in ISPConfig. You will have to create the DNS-Records with the external IP addresses in the DNS-Manager or modify the existing ones to use the external IP address.
     
  3. mphayesuk

    mphayesuk New Member

    Not sure I know what you mean....

    So you would create the new site with the local IP and then go to the DNS-Manager and then change the IP to the public one in the tab "Domain" and "Records".

    Thanks
    Martin
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes.

    Or you create the site, do not enable the create DNS checkboxes and the create DNS records for the external IP in the DNS-Manager.
     
  5. mphayesuk

    mphayesuk New Member

    ok so now I get the shared IP error.

    What causes this and how can I correct it
     
  6. mphayesuk

    mphayesuk New Member

    Ok scrap that last comment it looks like its working again.

    Thanks
     

Share This Page