$_SERVER['DOCUMENTROOT'] gives /srv/...

Discussion in 'General' started by giftsnake, Jan 1, 2012.

  1. giftsnake

    giftsnake New Member

    i get a strange warning with an installation of owncloud:

    Warning: is_executable() [function.is-executable]: open_basedir restriction in effect. File(/srv/www/domain.com/web/file) is not within the allowed path(s): (/var/www/clients/client1/web60/web:/var/www/clients/client1/web60/tmp:/var/www/domain.com/web:/srv/www/domain.com/web:/usr/share/php5:/tmp:/usr/lib/cgi-bin/mailman:/var/www/clients/client1/web60/cloud/data) in /var/www/clients/client1/web60/web/cloud/lib/helper.php on line 325

    where is the /srv set? the path for all webs is within /var/www/...
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This must be set somwhere in the owncloud softare.
  3. giftsnake

    giftsnake New Member

    grep srv -R /path/of/owncloudinstallation gives no such indication
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    According to the error message the script you called executed the command is_executable('/srv/www/domain.com/web/file); which was blocked by the open_basedir restriction. What you could try is that you add /srv/www to the open basedir path and try again.
  5. giftsnake

    giftsnake New Member

    /srv/www/domain.com/web is already in the open_basedir

    but i do not understand, where the /srv/www/... path comes from. there is no such directory or setting to find anywhere!?
  6. cbj4074

    cbj4074 Member

    Look, the fact that /srv/www/ does not exist on your system is evidence of a bug or a misconfiguration in the PHP script in question.

    The reason that /srv/www/... is included in ISPConfig's open_basedir list by default is because nginx uses that path as its document root (please correct me if I'm wrong here, Till).

    This isn't a PHP debugging forum, but humor us and post the relevant contents of the file and the issue may be obvious.
    Last edited: Jan 3, 2012
  7. giftsnake

    giftsnake New Member

    i thought that since there is no such string as 'srv' in the whole directory of the php-script in question, the information has to come somewhere from the configuration of php/ispconfig.

    anyways, i now found out that the script gets the open_basedir-paths and checks for stuff there. thats why the /srv/... warning is displayed.

    can be closed then, thanks for your help :)

Share This Page