$_POST always empty on Debian 9 static IP Address

Discussion in 'Programming/Scripts' started by paranoico, Feb 8, 2018.

  1. paranoico

    paranoico New Member HowtoForge Supporter

    Hello,
    We have found a problem, pretty serious to us, on a new Debian 9 ISPConfig 3.1.11 (current last version) new install using Perfect Server guide:
    https://www.howtoforge.com/tutorial...-9-stretch-apache-bind-dovecot-ispconfig-3-1/

    After searching for several options we have finally discovered that the problem seems to be on Debian itself, here is the scenario:
    • When server is configured dynamic IP (DHCP) everything works fine and we can log in successfully on new ISPConfig instance.
    • But when changing to static public IP we cannot log in anymore.
      • After digging a bit we found the problem is in log in script: /usr/local/ispconfig/interface/web/login/index.php
      • Problem code line is: if(count($_POST) > 0)
      • When using static IP the $_POST variable is Always empty. So the post data is never recognized.
    • We have tried several things before debugging code, as checking all network settings more than twice, changing Mysql passwords and even reinstalling the whole ISPConfig instance, nothing solved the problem.
    • We have also tried to find if PHP has a known issue but found nothing and only researched that a possible variable named enable_post_data_reading could cause such issue, but it is turned on already.
    So I want to ask about some other thing we can check out from you the experts.
    Thanks a lot in advance.
     
    Last edited: Feb 8, 2018

Share This Page