_netdev in fstab

Discussion in 'Installation/Configuration' started by gilas, Mar 22, 2015.

  1. gilas

    gilas Member

    yesterday I spent many hour to solve this problem:
    * stats was not generated for about 1/3 of my websistes
    * the folder /var/www/site.tld/log was empty for the sites with no stats
    * some log folders (of the 1/3) was partially empty with the writing stopped some time ago, this happened in vairious date and without an apparent reason
    * one site that I remember surely I had renamed, was not listed within /etc/fstab
    I inspected folders, etc. looking for access (user/group), ecc. then discovered that, in a different way respect the previous version of ispconfing 3, your CP uses /etc/fstab to create an extent file. Ok this is not bad; looking your php:

    server/plugins-enabled/apache2_plugin.inc.php: $fstab_line = '/var/log/ispconfig/httpd/'.$data['new']['domain'].' '.$data['new']['document_root'].'/'.$log_folder.' none bind,nobootwait,_netdev 0 0';

    as above, you use _netdev for each new site added.
    Howevere on my case I have modified /etc/fstab and removed _nedev
    then run
    mount -a
    immediately the log files was visible and nightly the stastistic was geneate correctly.
    There is a misconfiguration error or your ispconfig has a bug?!?
    O.s. CentOS 5.x / 6.x (two VPS, same behaviour)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The _netdev option is required to ensure that the mount is not blocking the boot process, especially if the server uses network based file systems. I dont have any issues with that option on my servers, so maybe it affects only old centos versions. You can enabke / disable the use of _netdev under System > server config > web.
  3. gilas

    gilas Member

    hi Till, great work as usual.
    I have a doubt becase the Centos 6 is almost recent....
    Thank you for your answer, next days I will try what you suggest, the return here to say what is happened,
  4. gilas

    gilas Member

    Hi Till
    you wrote enable/disable this option under:
    >enable / disable the use of _netdev under System > server config > web
    do you mean this option:
    Network Filesystem
    on my case this is not enabled (not checked). Maybe should I do enable it?
    Thank you again...
    Last edited: Mar 23, 2015

Share This Page