8080 port does not accept LE cert

Discussion in 'Installation/Configuration' started by George Girgolas, Jan 22, 2021.

  1. George Girgolas

    George Girgolas New Member


    I followed the guide for the perfect server on debian 10. Everything was ok
    I then followed the guide for securing ispconfig with the LE cert (https://www.howtoforge.com/tutorial/securing-ispconfig-3-with-a-free-lets-encrypt-ssl-certificate/)

    1. Although when calling server1.mydomain.com, LE works just fine, when calling https://server1.mydomain.com:8080 I get that my certificate is not correct, because it is using the self signed, although I followe the guide step by step
    2. There is no /etc/letsencrypt folder in my server, althoygh my cert works fine in https://server1.mydomain.com!
    3. dovecot cannot start, the error is
    doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 7: ssl_cert: Can't open file /etc/postfix/smtpd.cert: No such file or directory

    although this file exists!!!!

    Any ideas?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 3.2 has Let's encrypt support builtin, so don't use that ISPConfig 3.1 guide to configure it. I'll recommend that you undo all steps from that guide.

    ISPConfig uses acme.sh now and not certbot, so certs are not stored in /etc/letsencrypt folder anymore. the tutorial you used is not compatible with the new setup, so the best thing is that you undo it to fix your server. In case it was not possible to obtain a le cert during the initial install, then run an update with --force option to do an ispconfig update and let the updater create a new le cert for you.
    ahrasis likes this.
  3. George Girgolas

    George Girgolas New Member

    Your suggestion worked very well,

    thnks again!

Share This Page