8080 goes to /var/www

Discussion in 'Installation/Configuration' started by walkero, Jun 7, 2010.

  1. walkero

    walkero New Member

    Hello to all.
    I created an installation o ISPConfig 3.0.2.1 on a debian 5, based on the perfect server guide.

    The problem is that the http://my_domain_name.com:8080 goes to /var/www show the index.html with "It works!" message.

    If I use the http://my_domain_name.com:8080/ispconfig/ it works great. I need some help on that.

    netstat -tap


    /etc/apache2/sites-available/ispconfig.vhost
    contains:


    Code:
     Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost _default_:8080>
      ServerAdmin [email protected]
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
      </IfModule>
    
      <IfModule mod_php5.c>
        DocumentRoot /usr/local/ispconfig/interface/web/
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      # ErrorLog /var/log/apache2/ispconfig-error.log
      # CustomLog /var/log/apache2/ispconfig-access.log combined
      ServerSignature Off
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    If you need more information please let me know.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The ispconfig setup is ok.

    There must be some other website configured on your server for port 8080 beside ispconfig. Please remove this other website or change the port to another port then 8080 for this other website and restart apache.
     
  3. walkero

    walkero New Member

    Thanks for your faaaast reply.
    I tried to find which other website might use the port 8080. So I did a grep in the apache2 folder

    webserv:/etc/apache2# grep 8080 * -R

    So it seems that there is no other website at this port....

    Any idea? Thanks for your time...
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you post sites-available/ispconfig.vhost? What's the output of
    Code:
    ls -la /var/www/
    ? Any errors in Apache's error log?
    Have you tried to restart Apache?
     

Share This Page