:8080 500 mysqli_init undefined

Discussion in 'General' started by HellMind, Aug 20, 2020.

  1. HellMind

    HellMind Member

    Damn I really need to know how ispconfig creates those files,
    As no error is displayed, maybe the problem is the missing of the call to the script to update it.
    Maybe it doesnt detect the changes I made, or maybe it detect the change its already done.
    I see the pending jobs on every modification
     
    Last edited: Aug 22, 2020
  2. HellMind

    HellMind Member

    I found it.
    I don't know why but the nginx plugin symblink was missing on:
    Code:
    /usr/local/ispconfig/server/plugins-enabled
    I wonder why the update script doesnt check that.
    Also how it got deleted, maybe I uninstalled some nginx package?
     
  3. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    I believe, and a quick search of the source confirms, it can create plugs-enabled symlinks, but there is no code to remove them. That also wouldn't be done by removing an nginx package. I have no idea what happened, but not those things. :)
     
  4. HellMind

    HellMind Member

    Did you find how it detect that nginx is installed or active?
     
  5. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    I actually walked through finding that this morning when replying here, it is simply if the nginx binary is in the path.

    https://git.ispconfig.org/ispconfig...e-3.1/install/lib/installer_base.lib.php#L184

    https://git.ispconfig.org/ispconfig/ispconfig3/-/blob/stable-3.1/install/lib/install.lib.php#L811

    That is if the web service is enabled, and apache is not installed:

    https://git.ispconfig.org/ispconfig/ispconfig3/-/blob/stable-3.1/install/update.php#L344
     
    Last edited: Aug 25, 2020
  6. HellMind

    HellMind Member

    Code:
    [email protected]:~# which nginx
    /usr/sbin/nginx
    I found my service apache2 was enabled
    Code:
    [email protected]:~# systemctl status apache2
    ‚óŹ apache2.service - The Apache HTTP Server
       Loaded: loaded (/lib/systemd/system/apache2.service; disabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Sat 2020-08-22 11:11:07 -03; 2 days ago
         Docs: https://httpd.apache.org/docs/2.4/
    
    Aug 22 11:11:07 ispconfig systemd[1]: Starting The Apache HTTP Server...
    Aug 22 11:11:07 ispconfig apachectl[26118]: apache2: Syntax error on line 146 of /etc/apache2/apache2.conf: Syntax error on line 3 of /etc/apache2/mods-enabled/php7.2.load: Cannot load /usr/l
    Aug 22 11:11:07 ispconfig apachectl[26118]: Action 'start' failed.
    Aug 22 11:11:07 ispconfig apachectl[26118]: The Apache error log may have more information.
    Aug 22 11:11:07 ispconfig systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
    Aug 22 11:11:07 ispconfig systemd[1]: apache2.service: Failed with result 'exit-code'.
    Aug 22 11:11:07 ispconfig systemd[1]: Failed to start The Apache HTTP Server.
    [email protected]:~# systemctl disable apache2
    Synchronizing state of apache2.service with SysV service script with /lib/systemd/systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install disable apache2
    insserv: warning: current start runlevel(s) (empty) of script `apache2' overrides LSB defaults (2 3 4 5).
    insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `apache2' overrides LSB defaults (0 1 6).
    insserv: warning: current start runlevel(s) (empty) of script `apache2' overrides LSB defaults (2 3 4 5).
    insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `apache2' overrides LSB defaults (0 1 6).
    After that I removed the nginx symlink and re run update.php ,
    But I found that the symlink wasn't created.
    *also it shows "PHP Warning: Error while sending QUERY packet. PID=16918 in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 190"


    Do I need it ? should I remove apache2 dpkg?, it seems got activated alone.

    Still I wonder why it doesn't create the plugin symlink.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Jesse explained that in #23, plugin symlinks get neither removed nor added on update, they get just set once at install time, so an update can not change this and the ISPConfig update did not cause this issue. So whoever removed that symlink, it was not the ispconfig update.
     
  8. HellMind

    HellMind Member

    Then we never gonna know.
    Thank you all!
     

Share This Page