70007 Timeout

Discussion in 'Installation/Configuration' started by buttman, Mar 10, 2012.

  1. buttman

    buttman New Member


    I've got a problem that just keeps bugging me. I set up my server on Debian, using the perfect server guide. Everything was OK until I uploaded newewst version of Joomla (2.5.2) with rather complex template. Now from time to time when I change something in CMS and try to save changes, I got 500 server error (after 5-6 seconds) and my error log says:

    (70007)The timeout specified has expired: mod_fcgid: can't get data from http client, referrer...

    I changed all timeouts in all php.ini(s) to at least 60 s, also did the same with my_site.vhost - <IfModule mod_fcgid.c> stanza. Still I get this error. What's wrong? Help!...

    EDIT: What I also noticed - when a small chunk of data is being sent, everything goes smooth. But when I deal with more than like... 10KB, server seems to hang for a few seconds, then proceeds. I guess these few seconds cause the 500 error. But what makes the server 'think' before it decides to proceed? Better yet - the same situation is with FTP. When I try to upload anything bigger than 10KB, server seems to wait for some time and then proceeds with normal speed. I'm stuck.

    EDIT 2: I found out that server pauses after 9216 B. Every file smaller than 9216 gets through easily.
    Last edited: Mar 10, 2012
  2. Ovidiu

    Ovidiu Active Member

    similar problem here: using wordpress on a lot of websites on this server but I just noticed right now that I can't save anymore posts, on none of the sites. times out eventually :-( and the log file only says:

    (70007)The timeout specified has expired: mod_fcgid: can't get data from http client

    nothing else in my logs that I can find. where would suhosing output its logs?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats most likely a fastcgi timeout and not a php timeout. Check:


    and you might also adjust the website default settings for fcgi in /usr/local/ispconfig/server/conf/vhost.conf.master. The master template gets applied to a website when you change a value in that site in ispconfig and then click on save. Please note that it takes a minute until the configuration is written to disk.
  4. Ovidiu

    Ovidiu Active Member

    what if I have different values in /etc/apache2/mods-enabled/fcgid.conf then in /usr/local/ispconfig/server/conf/vhost.conf.master which one has precedence?

    ***offtopic p.s. is there an easy way to list the last updates/isntalls performed via apt-get ? Just wanted to check what was installed during the last few days... ***offtopic
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Settings that were made in a vhost take precedense over gloabl settings.
  6. Ovidiu

    Ovidiu Active Member

    any more help?
    there are plenty of timeout variables, I would have thought this one the most promising:
    FcgidConnectTimeout but the description: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html says:
    so I am not sure which one to increase...

    Any more log files I could consult?
    This must have been something that I did, since all of a sudden this problem appears on all sites on my server.

    All I did was set up apf-firewall and DDos-deflate but even if I stop those two, the problem still persists.
  7. Ovidiu

    Ovidiu Active Member

    and additionally, in my access log i find this:

    that is a error 500, right? and the error.log again only says:

  8. Ovidiu

    Ovidiu Active Member

    ok, my problem seems to have solved itself: there must have been some routing problems, which we experience every now and then between my current place.

    I just tried saving posts again from a different internet access and it is working just fine again.
  9. buttman

    buttman New Member

    Yup, the problem is solved. Indeed - it was my router's fault. I had to decrease MTU from 1500 to 1400.

Share This Page