553 Relay request rejected. [SOLVED]

Discussion in 'Installation/Configuration' started by Craig, Dec 28, 2006.

  1. Craig

    Craig New Member

    This one took me a while to figure out and I was micrometers from posting a question here to try to find an answer but all the answers given to similar questions lead me to believe the problem was NOT inside of ISPConfig or postifx and it's settings.

    The situation was that I could send and receive email from my mail client using an ISPConfig hosted mail address but any attempt to send mail to that ISPConfig hosted mail address, from another mail server failed, with the error listed in the title.

    Checking all related threads here on the topic, the answer generally seemed to stem from checking /var/log/maillog and finding some evidence there but in my case, there were never any errors shown during attempts to send mail into the ISPConfig hosted mail server from an outside mail server.

    Of course the error messages I received from the external mail servers, of which I tried many, were pretty much worthless, other than the error listed in the subject, for which a googling turns up hundreds of possible causes.

    But, there not being any errors in the maillog file suggested that the external mail servers were never even reaching the ISPConfig hosted mail server so it seemed likely a network addressing problem.

    What turned out to be the problem, as likely most of you reading this already know, is that the DNS MX was not set up correctly. My knowing less than nothing to begin with and the domain registrar from whom I registered the relative domain names having little more info as to what to do other than, "Set the MX record to that needed by your mail server." didn't help at all! ;)

    But, to cut what is ending up to be a long story short, the solution was setting the domain registrar's MX record to point to the ip address of the ISPConfig installation.

    After that, sending and receiving all the way around is working perfectly! :)

    I post this not to ask any questions but instead, to add the error message to the forum with a solution so that anyone in the future knowing as little as I do might find a solution using the forum search feature without having to ask.

    Even while I was having problems, I could see that ISPConfig is one great system but now that everything is actually working 100%, I've had time to dig into it and find even more things I absolutely love about it!! :)
     
  2. edge

    edge Active Member Moderator

    Welcome to the team!

    Now when some user got a (mail) problem you can help also :)

    Well done!
     
  3. Craig

    Craig New Member

    Are you sure??

    Ever hear the phrase, "Only knows enough to be dangerous!"

    If you look that up in a dictionary, don't be surprised if you see a picture of me shown in the definition. :D :D
     
  4. coolen

    coolen New Member

    Mhh,

    I have exactly this problem.

    but as far as I can tell i did set up mx records. I'm using afraid as dnsserver and in the tables it says:

    adviesbureau-beateam.nl [ add ]
    3158473 adviesbureau-beateam.nl (G) A 77.161.236.229
    3194912 adviesbureau-beateam.nl (G) MX 10:mail.adviesbureau-beateam.nl
    2924669 ftp.adviesbureau-beateam.nl (G) A 77.161.236.229
    2924668 mail.adviesbureau-beateam.nl (G) A 77.161.236.229
    3110682 pop3.adviesbureau-beateam.nl (G) A 77.161.236.229
    3149644 smtp.adviesbureau-beateam.nl (G) A 77.161.236.229
    2924667 www.adviesbureau-beateam.nl (G) A 77.161.236.229


    so mx points to mail.adviesbureau-beateam.nl

    and mail.adviesbureau-beateam.nl points to my ip.

    I can send inside out from that box,
    I can also send inbetween the users from the box
    I can send outside user that has the same ISP as my main ISP(planet.nl) inside the box:
    Nov 20 16:28:23 server1 postfix/smtpd[29839]: connect from cpsmtpo-eml03.KPNXCHANGE.COM[213.75.38.152]
    Nov 20 16:28:23 server1 postfix/smtpd[29839]: B9226A549: client=cpsmtpo-eml03.KPNXCHANGE.COM[213.75.38.152]
    Nov 20 16:28:23 server1 postfix/cleanup[29843]: B9226A549: message-id=<[email protected]>
    Nov 20 16:28:23 server1 postfix/qmgr[27461]: B9226A549: from=<[email protected]>, size=1176, nrcpt=1 (queue active)
    Nov 20 16:28:23 server1 postfix/smtpd[29839]: disconnect from cpsmtpo-eml03.KPNXCHANGE.COM[213.75.38.152]
    Nov 20 16:28:23 server1 postfix/pickup[27459]: EB6ECA567: uid=10003 from=<web2_arthur>
    Nov 20 16:28:23 server1 postfix/cleanup[29843]: EB6ECA567: message-id=<[email protected]>
    Nov 20 16:28:23 server1 postfix/local[29844]: B9226A549: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.25, delays=0.12/0.03/0/0.1, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 20 16:28:23 server1 postfix/qmgr[27461]: B9226A549: removed
    Nov 20 16:28:24 server1 postfix/qmgr[27461]: EB6ECA567: from=<[email protected]>, size=428, nrcpt=1 (queue active)
    Nov 20 16:28:24 server1 postfix/local[29844]: EB6ECA567: to=<[email protected]>, relay=local, delay=0.15, delays=0.11/0/0/0.03, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 20 16:28:24 server1 postfix/qmgr[27461]: EB6ECA567: removed


    But any mail from another provider is just not reaching my box even.

    anybody any ideas?
     
  5. coolen

    coolen New Member

    solved, had to do with the fact that my mainISP suddenly decided to close down ports 25 and install a special relay server, without notifying his clients properly :(
     
  6. edge

    edge Active Member Moderator

    Tja.. planet.nl he!
     
  7. Craig

    Craig New Member

    It's been a while...

    ... since I posted the opening thread but guess what, I just now ran into the same problem!

    Having the memory span of a goldfish, of course I forgot what the solution was.

    Thank the powers that be for a place like HowToForge where I can keep notes. :)

    By the way, due to some foulups with Paypal, my subscription here got canceled.

    That will get fixed soon though. :)
     

Share This Page