550 Sender verify failed

Discussion in 'Installation/Configuration' started by Allen15, Feb 7, 2009.

  1. Allen15

    Allen15 New Member

    On a new setup, I get this as part of a bounce message when trying to send mail from the webmail, does anyone know what I'd need to do or where I'd need to start to fix this?

    Thanx

    Allen

    (error message follows:)

    <[email protected]>: host oncall-pc.com[174.132.150.226] said:
    550-Verification failed for <[email protected]> 550-The
    mail server could not deliver mail to [email protected].
    The account or domain may not exist, they may be blacklisted, or missing
    the proper dns entries. 550 Sender verify failed (in reply to RCPT TO
    command)
     
    Last edited: Feb 7, 2009
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please set the correct sender address under options in the webmail program.
     
  3. Allen15

    Allen15 New Member

    Thanks, and I've tried setting my options in webmail prior to sending, but I am still getting errors when I send to some, but not all domains:

    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822;[email protected]
    Action: failed
    Status: 5.0.0
    Remote-MTA: dns; oncall-pc.com
    Diagnostic-Code: smtp; 550-Verification failed for
    <[email protected]> 550-The mail server could not deliver mail
    to [email protected]. The account or domain may not exist,
    they may be blacklisted, or missing the proper dns entries. 550 Sender
    verify failed

    How do I allow a distant mail server to verify sender's validity? I get the feeling that this is some anti-spam measure that I'm up against...

    Thanx

    Allen
     
  4. Allen15

    Allen15 New Member

    Trying to dissect that error message:
    Diagnostic-Code: smtp; 550-Verification failed for
    <[email protected]> 550-The mail server could not deliver mail
    to [email protected]. The account or domain may not exist,
    they may be blacklisted, or missing the proper dns entries. 550 Sender
    verify failed

    I know that the domain exists, I can ping it, and I can browse it, and I can dig it.

    How do I tell if that domain has been blacklisted, and more importantly, how do I change that? If this is a dns issue, then I can only guess that it is a reverse DNS lookup that may be failing, since I can ping/browse/dig by name, but how do I check and/or fix that too?

    Thanks,

    Allen
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess the others erver tries to verify your sender address and that fails. Are you able to send an email to yourself from outside?
     
  6. Allen15

    Allen15 New Member

    I cannot receive any mail from outside the domain, but I can send mail <from my ISPConfig-created site & webmail> to any domain that doesn't try to verify the sender.

    For whatever reason, the user I created is not allowed to receive email? (I sense another wipe and reload session coming on, but I've gotten fast enough doing it that I no longer dread it *as much* ...)
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    ok, then thats the problem waht you have to fix. send yourself an email and check the mail log for errors.
     
  8. Allen15

    Allen15 New Member

    I guess I really don't know where to start looking for such a "mail log" -- which mail (server?) or client should I be looking at, the sender or the recipient, and if it is somewhere on my ISPConfig installation, where and/or which file should I be trying to read?

    I am running Ubuntu 8.10 from the perfect server install and ISPConfig 2.2.29, if that helps?

    Thanx,

    Allen

    (To clarify, should I be looking for some log in ISPConfig, or in my host Ubuntu server logs, or at a log of whichever mail client or server that I am externally trying to send from and failing? (I don't have complete access to many of the external server logs, as they are managed from various ISPs or otherwise, like Yahoo!, etc.)
     
    Last edited: Feb 11, 2009
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    The sender and recipient server are normally the same if you send yourself an email. the log files of a linux system are in /var/log
     
  10. Allen15

    Allen15 New Member

    I was afraid someone would say that...

    If I log into the control panel for ISPConfig and then go to the webmail interface, I can send myself an email and get it with no problems.

    It is only when I try to send an email to an external domain that I am getting that sender verification error, and further more, if I try to send email from an external domain, I am unable to receive it on the ISPConfig-based system, even if sent as a reply to a message I was able to get externally.

    No external domain is able to send email to me at the ISPConfig box, and any external domain mail server which does sender verification will refuse all further connections after that fails, so I cannot send mail to them from ISPConfig system.

    I really had higher hopes and plans for this system than a glorified intra-net IM system, but that is currently all it will reliably do (email-wise).

    Code:
    root@www:/var/www/www.solutionsforcare.org# ls -l /var/log/mail*
    -rw-r----- 1 syslog adm      0 2009-02-05 22:41 /var/log/mail.err
    -rw-r----- 1 syslog adm 215328 2009-02-12 09:20 /var/log/mail.info
    -rw-r----- 1 syslog adm  27420 2009-02-08 04:44 /var/log/mail.info.0
    -rw-r----- 1 syslog adm 276547 2009-02-12 09:20 /var/log/mail.log
    -rw-r----- 1 syslog adm  28711 2009-02-08 04:44 /var/log/mail.log.0
    -rw-r----- 1 syslog adm   1268 2009-02-11 04:44 /var/log/mail.warn
    -rw-r----- 1 syslog adm   1220 2009-02-07 23:55 /var/log/mail.warn.0
    
    (Part of the output of a recent tail -100 /var/log/mail.log)
    
    Feb 12 09:15:46 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:15:46 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[46931], protocol=IMAP
    Feb 12 09:15:47 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=77, sent=418, time=1
    Feb 12 09:15:50 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:15:50 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[46932], protocol=IMAP
    Feb 12 09:15:50 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=61, sent=166, time=0
    Feb 12 09:15:50 www postfix/local[4569]: 7D8CD21A3A0: to=<[email protected]>, orig_to=<[email protected]>, rela
    y=local, delay=9.3, delays=0.07/0.05/0/9.2, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Feb 12 09:15:50 www postfix/local[4567]: 7D8CD21A3A0: to=<[email protected]>, orig_to=<[email protected]>, relay=loc
    al, delay=9.4, delays=0.07/0.03/0/9.3, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Feb 12 09:15:50 www postfix/qmgr[22983]: 7D8CD21A3A0: removed
    Feb 12 09:15:53 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:15:53 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[46933], protocol=IMAP
    Feb 12 09:15:53 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=61, sent=166, time=0
    Feb 12 09:15:56 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:15:56 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[46934], protocol=IMAP
    Feb 12 09:15:56 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=760, body=0, rcvd=227, sent=2166, time=0
    Feb 12 09:15:59 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:15:59 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[46935], protocol=IMAP
    Feb 12 09:15:59 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=0, body=1173, rcvd=174, sent=1919, time=0
    
    Feb 12 09:16:17 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:16:17 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[46939], protocol=IMAP
    Feb 12 09:16:17 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=61, sent=166, time=0
    Feb 12 09:16:20 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:16:20 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[46940], protocol=IMAP
    Feb 12 09:16:20 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=77, sent=418, time=0
    Feb 12 09:16:34 www postfix/smtpd[4561]: connect from mail8.sea5.speakeasy.net[69.17.117.10]
    Feb 12 09:16:34 www postfix/smtpd[4661]: connect from mail8.sea5.speakeasy.net[69.17.117.10]
    Feb 12 09:16:35 www postfix/smtpd[4561]: setting up TLS connection from mail8.sea5.speakeasy.net[69.17.117.10]
    Feb 12 09:16:35 www postfix/smtpd[4661]: setting up TLS connection from mail8.sea5.speakeasy.net[69.17.117.10]
    Feb 12 09:16:35 www postfix/smtpd[4561]: Anonymous TLS connection established from mail8.sea5.speakeasy.net[69.17.117.10]: TLSv1 with cipher DHE-RSA-
    AES256-SHA (256/256 bits)
    Feb 12 09:16:35 www postfix/smtpd[4661]: Anonymous TLS connection established from mail8.sea5.speakeasy.net[69.17.117.10]: TLSv1 with cipher DHE-RSA-
    AES256-SHA (256/256 bits)
    Feb 12 09:16:35 www postfix/smtpd[4561]: 8D7B521A3A0: client=mail8.sea5.speakeasy.net[69.17.117.10]
    Feb 12 09:16:35 www postfix/smtpd[4661]: 9653621A3C7: client=mail8.sea5.speakeasy.net[69.17.117.10]
    Feb 12 09:16:35 www postfix/cleanup[4564]: 8D7B521A3A0: message-id=<[email protected]>
    Feb 12 09:16:35 www postfix/qmgr[22983]: 8D7B521A3A0: from=<[email protected]>, size=1161, nrcpt=1 (queue active)
    Feb 12 09:16:35 www postfix/cleanup[4665]: 9653621A3C7: message-id=<[email protected]>
    Feb 12 09:16:35 www postfix/pickup[3136]: D01D721A3CD: uid=10001 from=<web1_ajackson>
    Feb 12 09:16:35 www postfix/cleanup[4564]: D01D721A3CD: message-id=<[email protected]>
    Feb 12 09:16:35 www postfix/qmgr[22983]: 9653621A3C7: from=<[email protected]>, size=1166, nrcpt=1 (queue active)
    Feb 12 09:16:35 www postfix/qmgr[22983]: D01D721A3CD: from=<[email protected]>, size=443, nrcpt=1 (queue active)
    Feb 12 09:16:35 www postfix/smtpd[4561]: disconnect from mail8.sea5.speakeasy.net[69.17.117.10]
    Feb 12 09:16:35 www postfix/smtpd[4661]: disconnect from mail8.sea5.speakeasy.net[69.17.117.10]
    Feb 12 09:16:35 www postfix/local[4607]: D01D721A3CD: to=<[email protected]>, relay=local, delay=0.16, delays=0.03/0.03/0/0.1, dsn=2
    .0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Feb 12 09:16:35 www postfix/qmgr[22983]: D01D721A3CD: removed
    Feb 12 09:16:36 www postfix/pickup[3136]: 02B9821A3CD: uid=10001 from=<web1_ajackson>
    Feb 12 09:16:36 www postfix/cleanup[4665]: 02B9821A3CD: message-id=<[email protected]>
    Feb 12 09:16:36 www postfix/qmgr[22983]: 02B9821A3CD: from=<[email protected]>, size=443, nrcpt=1 (queue active)
    Feb 12 09:16:36 www postfix/local[4569]: 02B9821A3CD: to=<[email protected]>, relay=local, delay=0.3, delays=0.12/0/0/0.18, dsn=2.0.
    0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Feb 12 09:16:36 www postfix/qmgr[22983]: 02B9821A3CD: removed
    Feb 12 09:16:44 www postfix/local[4602]: 8D7B521A3A0: to=<[email protected]>, orig_to=<[email protected]>, relay=loc
    al, delay=9, delays=0.29/0/0/8.7, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Feb 12 09:16:44 www postfix/qmgr[22983]: 8D7B521A3A0: removed
    Feb 12 09:16:44 www postfix/local[4567]: 9653621A3C7: to=<[email protected]>, orig_to=<[email protected]>, rela
    y=local, delay=9.1, delays=0.33/0.03/0/8.8, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Feb 12 09:16:44 www postfix/qmgr[22983]: 9653621A3C7: removed
    Feb 12 09:17:08 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:17:08 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[46941], protocol=IMAP
    Feb 12 09:17:08 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=61, sent=166, time=0
    Feb 12 09:17:10 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:17:10 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[46942], protocol=IMAP
    Feb 12 09:17:10 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=1026, body=0, rcvd=227, sent=2800, time=0
    
    Feb 12 09:17:34 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:17:34 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[46947], protocol=IMAP
    Feb 12 09:17:34 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=61, sent=166, time=0
    Feb 12 09:17:37 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:17:37 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[46948], protocol=IMAP
    Feb 12 09:17:37 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=77, sent=418, time=0
    Feb 12 09:19:55 www postfix/anvil[4663]: statistics: max connection rate 2/60s for (smtp:69.17.117.10) at Feb 12 09:16:34
    Feb 12 09:19:55 www postfix/anvil[4663]: statistics: max connection count 2 for (smtp:69.17.117.10) at Feb 12 09:16:34
    Feb 12 09:19:55 www postfix/anvil[4663]: statistics: max cache size 1 at Feb 12 09:16:34
    Feb 12 09:20:29 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 12 09:20:29 www imapd: LOGIN, user=web1_ajackson, ip=[::ffff:127.0.0.1], port=[42713], protocol=IMAP
    Feb 12 09:20:29 www imapd: LOGOUT, user=web1_ajackson, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=77, sent=418, time=0
    I get no hits in the mail log when sending from an external domain that does sender verification to indicate that anything has happened at all.
     
    Last edited: Feb 12, 2009
  11. Allen15

    Allen15 New Member

    (Update)

    BTW, I am now able to receive email from external domains that don't verify sender, but that is still not good enough to put into production, since I can't communicate at all to any domains that do?
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Do you have PTR and SPF records? Also, check your MX records.
     

Share This Page