504 Bad gateway, Fedoracore 5 ISPconfig

Discussion in 'Installation/Configuration' started by main3, Aug 9, 2006.

  1. main3

    main3 New Member

    504 Bad gateway,

    I would need some help for this bad gateway error 504.

    It has been up to 4 installs following the http://www.howtoforge.com/perfect_setup_fedora_core_5 Fedora core 5 ISP install. Last night I finally got every thing to work even ISPConfig. How ever I am having some errors with error 504 Bad Gateway.

    If I Ping ns1.qcrev.com I get a connection
    If I Ping qcrev.com I get a time out.
    I could access the ISPConfig and html with the ip but not with the Domain.

    I am not sure where I SCR&& up but any guidance would be appreciated.

    Server Settings.

    Dell PowerEdge 750

    Intel Hypertread PIV 3.2
    4GB ram ECC
    80 GB SATA HD 10000RPM

    Ethr0 Static IP
    Ethr1 Private IP

    Running Fedora Core 5

    All these have been installed and seem to work fine.

    • Httpd (virtual hosts, domain and IP based)
    • FTP
    • Bind (A, CNAME, MX and SPF Records)
    • POP3 Auto-Responder
    • MySQL client-databases
    • Webalizer statistics
    • Harddisk quota
    • Mail-Quota
    • Traffic limits
    • IP-addresses
    • SSL
    • SSI
    • Shell-access
    • Mailscanner (Antivirus)
    • Firewall
    I also followed the GoDaddy Guide to create ns1.qcrev.co and ns2.qcrev.com
    http://www.howtoforge.com/ispconfig_dns_godaddy
    Also when I do this
    Code:
    dig ns1.qcrev.com
    Mabe this is my trouble.
     
  2. falko

    falko Super Moderator

    Where do you get this 504 error?

    I get this:

    Code:
    dig qcrev.com
    
    ; <<>> DiG 9.2.1 <<>> qcrev.com
    ;; global options:  printcmd
    ;; connection timed out; no servers could be reached
    but
    Code:
    dig ns1.qcrev.com
    is ok. Create an A record for qcrev.com.

    What's in /etc/resolv.conf?
     
  3. main3

    main3 New Member

    resolv.cfrg

    Code:
    serache qcrev.com
    domain qcrev.com
    nameserver 24.200.241.37
    nameserver 24.201.245.77
    Still not working for me can't get this domain relest to the world. IP works fine, dig command also. I just need A reccord and MX are created in ISPconfig. Just ne a little bit of guidance or even a sample resolv.conf.

    Thank you
     
  4. falko

    falko Super Moderator

    You can use
    Code:
    nameserver 145.253.2.75
    nameserver 193.174.32.18
    nameserver 194.25.0.60
    in /etc/resolv.conf.
    dig qcrev.com is working now:

    Code:
    dig qcrev.com
    
    ; <<>> DiG 9.2.1 <<>> qcrev.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33752
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;qcrev.com.                     IN      A
    
    ;; ANSWER SECTION:
    qcrev.com.              86400   IN      A       69.70.7.186
    
    ;; Query time: 261 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Thu Aug 17 17:11:49 2006
    ;; MSG SIZE  rcvd: 43
    but
    dig ns1.qcrev.com
    and
    dig ns2.qcrev.com
    aren't...
     
  5. main3

    main3 New Member

    Not sure what going on IE troubles

    Domain http://www.qcrev.com


    This seems to work fine with Mozila. how ever with IE we get a blank page. I think for my other question works now
     
  6. falko

    falko Super Moderator

  7. main3

    main3 New Member

    Network Setup Help

    Ok,

    Here we go I think I figured out.

    1-This is my setup.

    Cable Modem connects to Cisco SOHO 91 router.

    Cisco socket 1 is connected to the Dell Poweredge 750 running Ubuntu distro. IP 69.70.7.186
    Cisco socket 2 is connected to D-LINK router PI-704 sharing with 4 other PC.IP 69.70.7.187

    If you Ping 69.70.7.187 you should get a response no problem.
    If you ping 69.70.7.186 No response.

    This definitely confirms that Cisco router is not the trouble.

    2- Internal Connection:

    From all my PC on the Network I can view the web site doing this.

    http://www.qcrev.com
    http://localhost
    http://69.70.7.186

    I can also manage ISPCONFIG with port 81.
    I also do these commands and get successful DNS information from all PC.

    On my Lunix BOX
    Dig @qcrev.com works
    Dig ns1.qcrev.com
    Dig ns2.qcrev.com

    On a Windows XP
    Ping www.qcrev.com
    Ping ns1.qcrev.com
    Ping ns2.qcrev.com
    Ping 69.70.7.186

    This now confirms that the DNS portion is working fine internally.

    Can some one confirm the following?

    Where could I have gone wrong with the external signal for others to connect to my box?

    I assume it’s in the /etc/hosts.conf

    Internal IP 127.0.0.1
    Static IP 69.70.7.186
    Gateway IP 69.70.7.185
    Subnet Mark 255.255.255.248 as per my provider
    I have inserted 255.255.255.0 or I could not connect to the internet.

    Could some one be kind enough to guide me in to where I should do the modifications?
     
  8. main3

    main3 New Member

    Here is the DIG command from the server.

    Code:
    dido@Poweredge750:~$ dig ns1.qcrev.com
    
    ; <<>> DiG 9.3.2 <<>> ns1.qcrev.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 43332
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;ns1.qcrev.com.                 IN      A
    
    ;; AUTHORITY SECTION:
    qcrev.com.              3600    IN      SOA     ns1.qcrev.com. web.qcrev.com 2006081504 28800 7200 604800 86400
    
    ;; Query time: 26 msec
    ;; SERVER: 24.200.241.37#53(24.200.241.37)
    ;; WHEN: Thu Aug 17 23:50:38 2006
    ;; MSG SIZE  rcvd: 77
    
    dido@Poweredge750:~$ dig ns2.qcrev.com
    
    ; <<>> DiG 9.3.2 <<>> ns2.qcrev.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38883
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;ns2.qcrev.com.                 IN      A
    
    ;; ANSWER SECTION:
    ns2.qcrev.com.          5998    IN      A       69.70.7.186
    
    ;; AUTHORITY SECTION:
    qcrev.com.              9937    IN      NS      ns2.qcrev.com.
    qcrev.com.              9937    IN      NS      ns1.qcrev.com.
    
    ;; Query time: 11 msec
    ;; SERVER: 24.200.241.37#53(24.200.241.37)
    ;; WHEN: Thu Aug 17 23:50:54 2006
    ;; MSG SIZE  rcvd: 79
    
    dido@Poweredge750:~$ dig @qcrev.com
    
    ; <<>> DiG 9.3.2 <<>> @qcrev.com
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14215
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 13, AUTHORITY: 0, ADDITIONAL: 13
    
    ;; QUESTION SECTION:
    ;.                              IN      NS
    
    ;; ANSWER SECTION:
    .                       518400  IN      NS      A.ROOT-SERVERS.NET.
    .                       518400  IN      NS      B.ROOT-SERVERS.NET.
    .                       518400  IN      NS      C.ROOT-SERVERS.NET.
    .                       518400  IN      NS      D.ROOT-SERVERS.NET.
    .                       518400  IN      NS      E.ROOT-SERVERS.NET.
    .                       518400  IN      NS      F.ROOT-SERVERS.NET.
    .                       518400  IN      NS      G.ROOT-SERVERS.NET.
    .                       518400  IN      NS      H.ROOT-SERVERS.NET.
    .                       518400  IN      NS      I.ROOT-SERVERS.NET.
    .                       518400  IN      NS      J.ROOT-SERVERS.NET.
    .                       518400  IN      NS      K.ROOT-SERVERS.NET.
    .                       518400  IN      NS      L.ROOT-SERVERS.NET.
    .                       518400  IN      NS      M.ROOT-SERVERS.NET.
    
    ;; ADDITIONAL SECTION:
    A.ROOT-SERVERS.NET.     604800  IN      A       198.41.0.4[code]
     
  9. main3

    main3 New Member

    More Info to help any one out that can help me

    Interfaces config.

    Code:
    # The file describes the network interfaces available on your system
    #and how to activate them. for more information, see interface (5)
    
    # The Primary looback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    auto eth0
    iface eth0 inet static
    	address 69.70.7.186
    	netmask 255.255.255.0
    	network 127.0.0.1
    	broadcast 69.70.7.186
    	gateway 69.70.7.186
    
    iface eth1 inet dhcp5
    My resolv.cfrg

    Code:
    search qcrev.com
    domain qcrev.com
    nameserver 24.200.241.37
    nameserver 24.201.245.77
    nameserver 69.70.7.186
    nameserver ns1.qcrev.com
    nameserver ns2.qcrev.com
    
    My resolv.conf

    Code:
    search qcrev.com
    domain qcrev.com
    nameserver 24.200.241.37
    nameserver 24.201.245.77
    
    My hosts.conf

    Code:
    127.0.0.1 localhost Poweredge750
    69.70.7.186 www.qcrev.com
    
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    67.70.7.186 ns1.qcrev.com
    
    Here is netstat -tap

    Code:
     netstat -tap
    (Not all processes could be identified, non-owned process info
     will not be shown, you would have to be root to see it all.)
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State PID/Program name
    tcp        0      0 localhost:38821         *:*                     LISTEN     - 
    tcp        0      0 localhost:45385         *:*                     LISTEN     - 
    tcp        0      0 *:mysql                 *:*                     LISTEN     - 
    tcp        0      0 *:81                    *:*                     LISTEN     - 
    tcp        0      0 *:ftp                   *:*                     LISTEN     - 
    tcp        0      0 www.qcrev.com:domain    *:*                     LISTEN     - 
    tcp        0      0 localhost:domain        *:*                     LISTEN     - 
    tcp        0      0 localhost:953           *:*                     LISTEN     - 
    tcp        0      0 *:smtp                  *:*                     LISTEN     - 
    tcp        0      0 localhost:39425         localhost:38821         ESTABLISHED- 
    tcp        0      0 localhost:38821         localhost:39425         ESTABLISHED- 
    tcp6       0      0 *:imaps                 *:*                     LISTEN     - 
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     - 
    tcp6       0      0 *:pop3                  *:*                     LISTEN     - 
    tcp6       0      0 *:imap2                 *:*                     LISTEN     - 
    tcp6       0      0 *:www                   *:*                     LISTEN     - 
    tcp6       0      0 *:ssh                   *:*                     LISTEN     - 
    tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     - 
    tcp6       0      0 *:smtp                  *:*                     LISTEN     - 
    tcp6       0      0 *:https                 *:*                     LISTEN     - 
    tcp6       0      0 www.qcrev.com:www       telhai.ac.il:52764      TIME_WAIT  - 
    tcp6       0      0 www.qcrev.com:www       telhai.ac.il:52772      TIME_WAIT  - 
    
    By the way thanks Falko
     
  10. main3

    main3 New Member

    Videotron provider info

    Info from my cable provider.

    My IP: 69.70.7.186 and 69.70.7.187
    subnet mask 69.70.7.185 and I asume that this is and error I think it should be called Gateway
    Gateway (router IP) 255.255.255.248 I guess this should be the subnet mask

    DNS 24.200.241.37
    DNS 24.201.245.77
    DNS 24.200.243
     
  11. main3

    main3 New Member

    Seems to be working fine

    I did not do any thing special. I just unpluged my secong Ethernet cable evere thing seem to run. Weird
     
  12. falko

    falko Super Moderator

    Change /etc/resolv.conf to

    Code:
    nameserver 24.200.241.37
    nameserver 24.201.245.77
    nameserver 24.200.243
    and do the dig stuff again.

    Yes, I think 255.255.255.248 is the subnet mask and 69.70.7.185 the gateway. Check out www.subnetmask.info to calculate the correct settings.
     
  13. main3

    main3 New Member

    Thanks

    Thanks Falco:)
     

Share This Page