500 Internal Server Error

Discussion in 'Installation/Configuration' started by captnops, Jan 17, 2008.

  1. captnops

    captnops New Member

    I have just completed the Perfect Ubuntu 7.10 server install and the ISPConfig install.

    Once the install was completed, I installed a web applicaton/site to the single site that I created and was able to access it.


    Once I was able to access it, I deleted all data in the folder and copied the original site (same app/site w/customizations) to the newly created folder. Now I get a 500 internal server error when attempting to access the site.


    To make matters worse, if I enter the public IP address associated with this domain, I get the shared IP page.

    I would greatly appreciate any help.
  2. edge

    edge Active Member Moderator

    I'm not seeing a 500 error on your site.
    A 500 error is normally caused by a .htaccess file
    Please post the .htaccess file here, and we will have a look at it.
    You could also commented out (with a #) line by line from the .htaccess and see what line is causing the error.
    (my guess is that it's an "Options +FollowSymLinks" that is causing the 500 error)

    This is normal. The only way you will be able to access the domain is by using the domain :)
  3. captnops

    captnops New Member

    I am not that bright! :D

    Immediately after posting this, I checked the error log at the site level and saw the .htaccess errors.

    Thank you for the confirmation.
  4. captnops

    captnops New Member

    You were correct about the Options + FollowSymLinks line in the .htaccess (that is to say i have one in there, not that i tested to see if that caused the error) :D

    Out of necessity (because my app needs the .htaccess file with Options + FollowSymlinks)

    I ask why the .htaccess file would throw an error with these options? And, what could I do to solve this problem?

    Thanks again
  5. edge

    edge Active Member Moderator

    You can add it to the sites "Apache Directives"
    ISPconfig > ISP manager > select the site in question > [tab] Basis > at the bottom you will see a box "Apache Directives"

    Add Options + FollowSymlinks and click save

    With a bit of luck it should work :)
  6. captnops

    captnops New Member

    Should I add just "Options + FollowSymLinks", or the entire .htaccess file for this site?

  7. Hans

    Hans Moderator ISPConfig Developer

    If you have added AllowOverride All within your apache2.conf or httpd.conf, .htaccess files are allowed on your server in any website.
    I think that the internal 500 error occured because you did not have AllowOverride All within your Apache configuration yet.

    Personally, i think it is more safe to set AllowOverride None instead of AllowOverride All. AllowOverride None means that .htaccess files are not allowed, but if you use ISPConfig, you can add the following to the Apache directive field for your site within ISPConfig:

    <Directory "/var/www/webX/web">
    Options FollowSymLinks
    AllowOverride All

    webX is the number of your web as defined ny ISPConfig.

    I think you can make it now...

Share This Page