500 Internal Server Error ispconfig 3

Discussion in 'Installation/Configuration' started by med0101, Aug 31, 2016.

  1. med0101

    med0101 New Member

    j'ai un serveur dédies chez ovh, j'ai installé avec debian + ispconfig 3
    j'ai au début cette erreur :: WordPress a besoin d’accéder à votre serveur web
    j'ai suivre ce toto ::
    Code:
        Créez un script de testuser.php et y insérez cette ligne de code :
        Code source Seo Rank
        <!--?php echo(exec("whoami")); ?-->
        Exécuter le script testuser.php et récupérer l’utilisateur affiché (en général sous linux c’est « www-data »)
        Connectez-vous en ssh sur votre serveur (en mode root) et changez le groupe ainsi que l’utilisateur de votre répertoire root en tapant les commandes suivantes :
        Code source Seo Rank
        2    chgrp -R utilisateurFTP /var/www
        chown -R www-data /var/www
        Ajouter l’utilisateur www-data au groupe Ftp via la commande suivante :
        Code source Seo Rank
        1       adduser www-data utilisateurFTP
        Donnez les droits nécessaires au groupe  » utilisateurFTP » pour qu’il puisse lire et écrire les fichiers du site. Au besoin, donnez un accès total au groupe auquel appartiennent les fichier de votre site, comme ceci :
        Code source Seo Rank
        1  chmod -R g+rw /var/www
    NB:
        « utilisateurFTP« ==> Le nom d’utilisateur Ftp que vous avez créé pour la gestion du site via FTP
        « /var/www » ==> ici représente votre répertoire racine
    
    j'ai résolue le pb mais j'aurai un autre lorsque je ouvre ispconfig "erreur 500 Internal Server Error"
    s'il vous plait aidez-moi très urgent
     
  2. med0101

    med0101 New Member

    i fixed with : /usr/local/ispconfig/server/scripts/update_from_tgz.sh
    but now in my website (wordpress) i can't add any plugin or picture = pb of chmod
    please help
     
  3. med0101

    med0101 New Member

    how can use this
    1. chgrp -R userFTP /var/www
    2. chown -R www-data /var/www
    3. adduser www-data userFTP
    4. chmod -R g+rw /var/www
     
  4. med0101

    med0101 New Member

    userFTP how can found it
     
  5. med0101

    med0101 New Member

    when i add a plugin ::
    upload_2016-8-31_14-23-26.png
    and when i add a picture in my website (wordpress)
    upload_2016-8-31_14-24-50.png
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This would simply destroy your setup, so dont do that.

    The correct steos are:

    1) Use php mode php-fpm or php-fcgi in ispconfig.
    2) Enable suexec in ispconfig for the website.
    3) Upload all wordpress files with ftp into the web folder of the website by using an ftp user of that site, this ensures that all permissions are correctly automatically and that wordpress can write to its plugin folders.
     
  7. med0101

    med0101 New Member

    i change chmod :( = i can't open my ispconfig and my website
    i got this error :: 500 Internal Server Error
    :'(
     
  8. med0101

    med0101 New Member

    for my ispconfig ::
    upload_2016-8-31_16-26-2.png
    for my website ::
    upload_2016-8-31_16-26-20.png
     
  9. Jesse Norell

    Jesse Norell Well-Known Member

    Check your webserver error log and you should have more info on what's wrong. Obviously if the problem was caused by a chmod, you should undo the change you made (if you can give more info on what that was, probably someone could help reset permissions correctly if you need it).
     
  10. Joey Devs

    Joey Devs Member

    This same issue to me I tried to use this command
    chown -R www-data:www-data /var/www
    find /var/www/ -type d -exec chmod 755 {} \;
    find /var/www/ -type f -exec chmod 644 {} \;

    Help me how to fix it all my website is internal server error
     
  11. Taleman

    Taleman Active Member HowtoForge Supporter

    Does the ISPConfig panel work?
    I would restore from backups /var/www to repair damage done by chown and chmod.
    Then examine logs to see what is wrong and fix the real problem.
     
  12. Joey Devs

    Joey Devs Member

    Ispconfig can't access and internal server error. Please help me how to repair or fix it? Thanks a lot
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    If you don't have backups from /var/www, then run:

    chown -R ispconfig:ispconfig /usr/local/ispconfig/interface/web

    then restart apache (or nginx) and try if you can access ISPConfig then. If that works, enable the option to update permissions on update under system > server config > web in ISPconfig and run Tools > resync in ispconfig.
     
  14. Joey Devs

    Joey Devs Member

    doesn't work still Internal Server Error. help please
     
  15. Joey Devs

    Joey Devs Member

    4 website internal server error
    can't access ISPCONFIG
    but phpmyadmin can access and I already backup
     
  16. Taleman

    Taleman Active Member HowtoForge Supporter

  17. Joey Devs

    Joey Devs Member

    I',m using ubuntu 16.04 64
    Yes this my output in
    cat htf_report.txt | more

     
  18. Taleman

    Taleman Active Member HowtoForge Supporter

    You are running old version of ISPConfig, that should not break it but since version 3.1.9 fixes serious security issues try upgrading ISPConfig. With luck it fixes the non working Panel and you get one step in the right direction.
    https://www.faqforge.com/linux/controlpanels/ispconfig3/how-to-update-ispconfig-3/
    Answer yes to reconfigure services.
    Then read the logs for the not-working websites, they are in
    Code:
    /var/www/<website url>/log/
    -directory.
    You can also try
    Code:
    apachectl -S
    to see what Apache thinks of the websites.
    The htf_report.txt shows issues with IP-number. Check outputs of commands
    Code:
    hostname
    and
    Code:
    hostname -f
    . Then check what is in file /etc/hosts, there should be correct IP number for ISPConfig hosts.
     
  19. Joey Devs

    Joey Devs Member

    Thanks I will try that.
    Everything is work properly before I can login my ISPconfig and website work smoothly then after I ran this command
    All in the /var/www change owner to www-data
    affecting all my website result to internal server error and can't access Ispconfig
    [​IMG]
    [​IMG]
     
  20. Taleman

    Taleman Active Member HowtoForge Supporter

    Did the fix proposed in #13 not repair anything? Did you do those proposed corrections?
     

Share This Page