500 error on PHP files

Discussion in 'Installation/Configuration' started by Rapid2214, Aug 19, 2010.

  1. Rapid2214

    Rapid2214 New Member

    I seem to be having a bit of trouble with one of my servers, it cannot process PHP files on all websites returning a 500 error. This problem started at 18:04 yesterday, but my other server (also on the ispconfig configuration) is working fine.
    Here is the relivent errors in the apache error log.
    [Thu Aug 19 09:53:20 2010] [notice] mod_fcgid: call /var/www/***.com/web/index.php with wrapper /var/www/php-fcgi-scripts/web25/.php-fcgi-starter
    suexec policy violation: see suexec log for more details
    Also i noted this, in the same log:
    [Thu Aug 19 09:53:23 2010] [notice] mod_fcgid: process /var/www/***.com/web/index.php(13677) exit(communication error), terminated by calling exit(), return code: 116
    Note: This page has no php scripting in it.

    The suphp log folder is empty
    root@roy:~# ls /var/log/suphp
    Also my in my php.ini file '/etc/php5/apache2/php.ini' the engine is switch on for apache
    engine = On
    Any ideas?

    Thanks in advance,

    Last edited: Aug 19, 2010
  2. Rapid2214

    Rapid2214 New Member

    I think i may have fixed it.
    I followed these instruction:
    # ls -all /usr/lib/apache2/suexec
    -rwsr-xr-- 1 root www-data 13392 Nov 14 22:09 /usr/lib/apache2/suexec
    # chown www-data.www-data /usr/lib/apache2/suexec
    # chmod 4755 /usr/lib/apache2/suexec
    Found here: http://howtoforge.net/forums/showthread.php?t=44351

    And all is good :)

    How can i check if PHP files are being excuted by Fast_CGI instead of Suexec?
    Answer:Look in 'top' when you are excuting the page, if its php-cgi, it will say it COMMAND.

    Sorry for a waste of a tread, but i hope this helps other people who may experience the same problems. ;)


    Last edited: Aug 19, 2010

Share This Page