5.4.4 Relay access denied

Discussion in 'Installation/Configuration' started by mrmagoo, Nov 24, 2006.

  1. mrmagoo

    mrmagoo New Member

    I take this sending an e-mail with evolution smtp/pop3
    The server is a Ubuntu 6.10 with the http://www.howtoforge.com/perfect_setup_ubuntu_6.10 and ISPConfig 2.2.8 installed
    This is my /etc/postfix/main.cf file
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname = nodo1.globamarket.com.ar
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = nodo1.globamarket.com.ar, localhost.globamarket.com.ar, , localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtp_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names

    Need help please thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please enable SMTP authentication in evolution. Username and password are identical with your pop3 password.
     
  3. mrmagoo

    mrmagoo New Member

    Its enabled

    The only way i can send to external mail addres is adding my local public ip to the mynetworks parameter in main.cf
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you configured your server according to one of the perfect setup howtos, smtp-auth is enabled on your server. If you enable now smtp authentication in your mailclient too as i described aboye, you are able to send mail trough your server. Do not add your external address to the mynetworks parameter.
     
  5. Hans

    Hans Moderator ISPConfig Developer

    Maybe it is not the case, but when your server at home, it is possible that your Internet Service Provider do not allow you to send mail with another smtp server then the one provided by your ISP.
     

Share This Page