404 Not Found or why don't ISPConfig create web site "infrastructure"

Discussion in 'Installation/Configuration' started by MON@H Rasta, Jun 16, 2017.

  1. MON@H Rasta

    MON@H Rasta New Member

    The problem is, after a fresh install of ISP config I have an errors:
    Code:
    404 Not Found
    Code:
    500 Internal Server Error
    1. Login to ISPConfig
    2. GoTo "System"->"Firewall"->"Add Firewall record"->Create default rule with activated common ports
      upload_2017-6-16_11-12-53.png
    3. Added a Client
      upload_2017-6-16_11-14-25.png
    4. Added 2 sites
      upload_2017-6-16_11-15-7.png
    5. Added an FTP account
      upload_2017-6-16_11-16-8.png
    6. Logged in new FTP account and uploaded index.html (empty file with "TEST" text in it)
    Afterwards I'm not able to see "TEST" in my browser, only 404 error.
    Also, now, I have 1 more problem:
    From time to time I'm not able to connect to server wia SSH (port 22) neither wia FTP (port 21). Connecting wia FileZilla FTP Client and see this:​
    Code:
    Status:    Connecting to 192.168.1.11:21...
    Status:    Connection established, waiting for welcome message...
    Status:    Initializing TLS...
    Status:    Verifying certificate...
    Status:    TLS connection established.
    Status:    Logged in
    Status:    Retrieving directory listing...
    Command:    PWD
    Response:    257 "/" is your current location
    Command:    TYPE I
    Response:    200 TYPE is now 8-bit binary
    Command:    PASV
    Response:    227 Entering Passive Mode (192,168,1,11,220,190)
    Command:    MLSD
    Error:    Connection timed out after 20 seconds of inactivity
    Error:    Failed to retrieve directory listing
    Status:    Disconnected from server
    Code:
    
    Jun 16 11:20:02 m-server dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<8Miwcw9Ses0AAAAAAAAAAAAAAAAAAAAB>
    Jun 16 11:20:02 m-server dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<jAmxcw9SiLsAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 11:24:08 m-server pure-ftpd: (?@192.168.1.7) [INFO] New connection from 192.168.1.7
    Jun 16 11:24:08 m-server pure-ftpd: (?@192.168.1.7) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with AES256-GCM-SHA384, 256 secret bits cipher
    Jun 16 11:24:08 m-server pure-ftpd: (?@192.168.1.7) [INFO] mM is now logged in
    Jun 16 11:24:08 m-server kernel: [45009.379415] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=52 TOS=0x00 PREC=0x00 TTL=128 ID=21838 DF PROTO=TCP SPT=50968 DPT=56510 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:24:11 m-server kernel: [45012.384446] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=52 TOS=0x00 PREC=0x00 TTL=128 ID=21932 DF PROTO=TCP SPT=50968 DPT=56510 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:24:17 m-server kernel: [45018.388266] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=48 TOS=0x00 PREC=0x00 TTL=128 ID=22115 DF PROTO=TCP SPT=50968 DPT=56510 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:24:28 m-server pure-ftpd: (?@192.168.1.7) [INFO] New connection from 192.168.1.7
    Jun 16 11:24:28 m-server pure-ftpd: (?@192.168.1.7) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with AES256-GCM-SHA384, 256 secret bits cipher
    Jun 16 11:24:28 m-server pure-ftpd: (?@192.168.1.7) [INFO] mM is now logged in
    Jun 16 11:24:28 m-server kernel: [45029.553739] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=52 TOS=0x00 PREC=0x00 TTL=128 ID=22466 DF PROTO=TCP SPT=50999 DPT=2209 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:24:31 m-server kernel: [45032.553420] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=52 TOS=0x00 PREC=0x00 TTL=128 ID=22559 DF PROTO=TCP SPT=50999 DPT=2209 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:24:37 m-server kernel: [45038.554092] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=48 TOS=0x00 PREC=0x00 TTL=128 ID=22742 DF PROTO=TCP SPT=50999 DPT=2209 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:25:01 m-server CRON[144344]: (getmail) CMD (/usr/local/bin/run-getmail.sh > /dev/null 2>> /dev/null)
    Jun 16 11:25:02 m-server dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<pYOXhQ9SiM0AAAAAAAAAAAAAAAAAAAAB>
    Jun 16 11:25:02 m-server postfix/smtpd[144406]: connect from localhost[::1]
    Jun 16 11:25:02 m-server dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<OJ+XhQ9SlrsAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 11:25:02 m-server postfix/smtpd[144406]: lost connection after CONNECT from localhost[::1]
    Jun 16 11:25:02 m-server postfix/smtpd[144406]: disconnect from localhost[::1] commands=0/0
    Jun 16 11:29:36 m-server pure-ftpd: (?@192.168.1.7) [INFO] New connection from 192.168.1.7
    Jun 16 11:29:36 m-server pure-ftpd: (?@192.168.1.7) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with AES256-GCM-SHA384, 256 secret bits cipher
    Jun 16 11:29:36 m-server pure-ftpd: (?@192.168.1.7) [INFO] mM is now logged in
    Jun 16 11:29:36 m-server kernel: [45337.711699] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=52 TOS=0x00 PREC=0x00 TTL=128 ID=32539 DF PROTO=TCP SPT=51523 DPT=48090 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:29:39 m-server kernel: [45340.712002] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=52 TOS=0x00 PREC=0x00 TTL=128 ID=32630 DF PROTO=TCP SPT=51523 DPT=48090 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:29:45 m-server kernel: [45346.712042] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=48 TOS=0x00 PREC=0x00 TTL=128 ID=48 DF PROTO=TCP SPT=51523 DPT=48090 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:29:56 m-server pure-ftpd: (?@192.168.1.7) [INFO] New connection from 192.168.1.7
    Jun 16 11:29:56 m-server pure-ftpd: (?@192.168.1.7) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with AES256-GCM-SHA384, 256 secret bits cipher
    Jun 16 11:29:56 m-server pure-ftpd: (?@192.168.1.7) [INFO] mM is now logged in
    Jun 16 11:29:56 m-server kernel: [45357.860861] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=52 TOS=0x00 PREC=0x00 TTL=128 ID=399 DF PROTO=TCP SPT=51555 DPT=61302 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:29:59 m-server kernel: [45360.876018] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=52 TOS=0x00 PREC=0x00 TTL=128 ID=493 DF PROTO=TCP SPT=51555 DPT=61302 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:30:01 m-server pure-ftpd: (?@192.168.1.7) [INFO] New connection from 192.168.1.7
    Jun 16 11:30:02 m-server dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<+X5slw9Sls0AAAAAAAAAAAAAAAAAAAAB>
    Jun 16 11:30:02 m-server dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<E7Bslw9SpLsAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 11:30:05 m-server kernel: [45366.876361] [UFW BLOCK] IN=eth0 OUT= MAC=00:15:5d:01:0a:02:90:2b:34:1b:5d:77:08:00 SRC=192.168.1.7 DST=192.168.1.11 LEN=48 TOS=0x00 PREC=0x00 TTL=128 ID=681 DF PROTO=TCP SPT=51555 DPT=61302 WINDOW=65535 RES=0x00 SYN URGP=0
    Jun 16 11:32:41 m-server pure-ftpd: (mM@192.168.1.7) [INFO] Timeout
    Jun 16 11:33:01 m-server pure-ftpd: (mM@192.168.1.7) [INFO] Timeout
    
    My questions as follows:
    1. Why I am not able to connect to my own server after installin ISPConfig following the HowTo 0_o? Have I done something wrong, or there is a problem with how-to?..
    2. Why ISPConfig doesn't create a folders infrastructure with error docs, webalizer etc? Is it becouse of symlinks I've created?
     
    Last edited: Jun 16, 2017
  2. MON@H Rasta

    MON@H Rasta New Member

    I have a "little server" (AMD Phenom II X4 940 Black Edition + 8GB RAM) with Windows Server 2016 (Nano Server) with Hyper-V role connected to the internet wia router. One of virtual mashines is for ISPConfig. It has dynamic RAM from 512 Mb to 6144 Mb with default (startup) value 1024 Mb.
    • ubuntu-16.04.2-server-amd64
    • Current version: 3.1.3
    ISPConfig test script results.txt
    I've installed ISPConfig according to this manual, with
    Code:
    #   As I using /data for all data (mysql, web, etc) let's create directories and symbolic links
    #   If the folder exist - moving to /data, if not - creating it
    mv /data/mysql /var/lib/mysql; mkdir /data/mysql; ln -s /data/mysql /var/lib/mysql
    mv /opt /data/opt; mkdir /data/opt; ln -s /data/opt /opt
    mv /var/www /data/www; mkdir /data/www; ln -s /data/www /var/www
    
    Code:
    nano /etc/nginx/nginx.conf
    [...]
    http {
    [...]
    server_tokens off;
    [...]
    Others steps to install ISPConfig were made according to manual.
    1. I don't have enough Linux and Web-Server administrating skills to safely install and configurate my mint web-server, using only OS and it's repos
    2. Administrating (creating site folders, adding ftp-users, managing MariaDB database) from command line is boring, I want userfriendly GUI without need to connect wia SSH.
    I want to have a Web-Server for my experiments, but it should be public. Something like "half-production" server for me and another couple people to practice in web-development.
     

    Attached Files:

    Last edited: Jun 16, 2017
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The reason for your FTP error is the firewall record that you added. You closed the passive ports of the Ftp daemon and therefore you can not connect anymore. The firewall is not needed if you don't run any additional software beside the one described in the perfect server guide as all services have to be reachable from outside to use your server, so closing their ports will disable the service and there are no services installed that shall not be reachable, so closing ports for not installed software makes not much sense. But if you want to keep the firewall nontheless then you have to configure the FTP passive port range:

    https://www.faqforge.com/linux/cont...ange-in-pure-ftpd-on-denian-and-ubuntu-linux/

    If you created symlinks for e.g. /var/www, then that's the cause. ISPConfig detects the security risk that you imposed by this and rejects to create any folders. The install tutorials do not instruct you to create any symlinks. Just follow the install tutorials to the letter. and if you want to relocate the /var/www or /var/vmail folder, then use bind mounts but not symlinks: https://www.howtoforge.com/use_moun...ctory_of_a_ispconfig_server_to_a_new_location
     
    MON@H Rasta likes this.
  4. MON@H Rasta

    MON@H Rasta New Member

    Thanks for the fast answer!
    Got it with symlinks.
    If I understood you correctly, I just need to skip this step in the guide:
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    No. You should just not have made:

    "GoTo "System"->"Firewall"->"Add Firewall record"->Create default rule with activated common ports"

    or when you do that and want to use FTP, then open the passive port range as outlined in the link I posted.
     
    MON@H Rasta likes this.

Share This Page