404 error if wget unzip instead of FTP

Discussion in 'General' started by Toucan, Mar 18, 2010.

  1. Toucan

    Toucan New Member

    I install quite a few joomla installations. I normally do this by downloading the zip, inflating it and then using filezilla to FTP all the files into a new domain directory on my ispconfig3 server.

    Because I regularly work away from my server using a remote shell I'd like to be able to do this without using FTP client to save bAndwidth etc.

    I've been using

    wget to get the zip

    then using the command unzip to extract the files

    the directory looks like this:

    Code:
    web33@badbuntu:/var/www/snugglesstore.com/web$*ls*-l
    total*6888
    drwxr-xr-x*11*web33*client1****4096*2009-11-04*17:45*administrator
    drwxr-xr-x**2*web33*client1****4096*2009-11-04*17:46*cache
    -rw-r--r--**1*web33*client1***97981*2009-11-04*17:44*CHANGELOG.php
    drwxr-xr-x*13*web33*client1****4096*2009-11-04*17:46*components
    -rw-r--r--**1*web33*client1****3409*2009-11-04*17:44*configuration.php-dist
    -rw-r--r--**1*web33*client1****1175*2009-11-04*17:44*COPYRIGHT.php
    -rw-r--r--**1*web33*client1***14894*2009-11-04*17:44*CREDITS.php
    -rw-r--r--**1*web33*client1****2771*2009-11-04*17:44*htaccess.txt
    drwxr-xr-x**6*web33*client1****4096*2009-11-04*17:46*images
    drwxr-xr-x**8*web33*client1****4096*2009-11-04*17:46*includes
    -rw-r--r--**1*web33*client1*****591*2009-11-04*17:44*index2.php
    -rw-r--r--**1*web33*client1****2052*2009-11-04*17:44*index.php
    drwxr-xr-x**7*web33*client1****4096*2009-11-04*17:46*installation
    -rw-r--r--**1*web33*client1****4344*2009-11-04*17:44*INSTALL.php
    -rw-r--r--**1*web33*client1*6778161*2009-11-04*19:51*Joomla_1.5.15-Stable-Full_Package.zip
    drwxr-xr-x**4*web33*client1****4096*2009-11-04*17:45*language
    drwxr-xr-x*16*web33*client1****4096*2009-11-04*17:46*libraries
    -rw-r--r--**1*web33*client1***17816*2009-11-04*17:45*LICENSE.php
    -rw-r--r--**1*web33*client1***27984*2009-11-04*17:45*LICENSES.php
    drwxr-xr-x**2*web33*client1****4096*2009-11-04*17:45*logs
    drwxr-xr-x**3*web33*client1****4096*2009-11-04*17:46*media
    drwxr-xr-x*22*web33*client1****4096*2009-11-04*17:46*modules
    drwxr-xr-x*11*web33*client1****4096*2009-11-04*17:46*plugins
    -rw-r--r--**1*web33*client1*****304*2009-11-04*17:45*robots.txt
    drwxr-xr-x**6*web33*client1****4096*2009-11-04*17:46*templates
    drwxr-xr-x**2*web33*client1****4096*2009-11-04*17:46*tmp
    drwxr-xr-x**4*web33*client1****4096*2009-11-04*17:46*xm
    the permissions appear to be as if they were there by FTP method.

    However, when I come to run it through a browser I get :
    I'd really appreciate any help with this thanks.
     
  2. damir

    damir New Member

    This is how i do it:

    Code:
    - ssh to server
    - cd /var/www/client3/web
    - wget http://www.joomla.com/joomla.tar.gz
    - tar -zxvf joomla.tar.gz
    - chown -R client3:web3 joomla
    - cd joomla
    - mv * ../
     
  3. Toucan

    Toucan New Member

    I'm Still not quite there I'm afraid

    I used

    cd /var/www/clients/client1/web
    wget http://joomlacode.com/lateststable.tar.gz
    tar -zxvf lateststable.tar.gz
    cd ..
    chown -R web33:client1 web

    I think this did the same as what you were doing and I got the resesults I thought I wanted :

    Code:
    drwxrwxrwx*11*web33*client1****4096*2009-11-04*17:45*administrator
    drwxrwxrwx**2*web33*client1****4096*2009-11-04*17:46*cache
    -rwxrwxrwx**1*web33*client1***97981*2009-11-04*17:44*CHANGELOG.php
    drwxrwxrwx*13*web33*client1****4096*2009-11-04*17:46*components
    -rwxrwxrwx**1*web33*client1****3409*2009-11-04*17:44*configuration.php-dist
    -rwxrwxrwx**1*web33*client1****1175*2009-11-04*17:44*COPYRIGHT.php
    -rwxrwxrwx**1*web33*client1***14894*2009-11-04*17:44*CREDITS.php
    -rwxrwxrwx**1*web33*client1****2771*2009-11-04*17:44*htaccess.txt
    drwxrwxrwx**6*web33*client1****4096*2009-11-04*17:46*images
    drwxrwxrwx**8*web33*client1****4096*2009-11-04*17:46*includes
    -rwxrwxrwx**1*web33*client1*****591*2009-11-04*17:44*index2.php
    -rwxrwxrwx**1*web33*client1****2052*2009-11-04*17:44*index.php
    drwxrwxrwx**7*web33*client1****4096*2009-11-04*17:46*installation
    -rwxrwxrwx**1*web33*client1****4344*2009-11-04*17:44*INSTALL.php
    -rwxrwxrwx**1*web33*client1*4808762*2009-11-04*19:51*Joomla_1.5.15-Stable-Full_Package.tar.gz
    drwxrwxrwx**4*web33*client1****4096*2009-11-04*17:45*language
    drwxrwxrwx*16*web33*client1****4096*2009-11-04*17:46*libraries
    -rwxrwxrwx**1*web33*client1***17816*2009-11-04*17:45*LICENSE.php
    -rwxrwxrwx**1*web33*client1***27984*2009-11-04*17:45*LICENSES.php
    drwxrwxrwx**2*web33*client1****4096*2009-11-04*17:45*logs
    drwxrwxrwx**3*web33*client1****4096*2009-11-04*17:46*media
    drwxrwxrwx*22*web33*client1****4096*2009-11-04*17:46*modules
    drwxrwxrwx*11*web33*client1****4096*2009-11-04*17:46*plugins
    -rwxrwxrwx**1*web33*client1*****304*2009-11-04*17:45*robots.txt
    drwxrwxrwx**6*web33*client1****4096*2009-11-04*17:46*templates
    drwxrwxrwx**2*web33*client1****4096*2009-11-04*17:46*tmp
    drwxrwxrwx**4*web33*client1****4096*2009-11-04*17:46*xmlrpc
    web33@badbuntu:~/web$*
    but I'm still getting the same error from the browser.

    If I unpack the file locally then upload in via FTP it all works fine so I don't understand. I'd really like to get my understanding of this sorted.
     
  4. Toucan

    Toucan New Member

    hmmm, after a lot of reading i'm starting to get my head around it although not completely. I switched SuPHP to PHPmod which seemed to do the trick.
     

Share This Page