403- Forbidden

Discussion in 'Installation/Configuration' started by ispconfig_error, Feb 22, 2014.

  1. ispconfig_error

    ispconfig_error New Member

    Hello and Good Day to everyone,

    Today, i been trying to setup my ISPconfig but unfortunately faced some problems during the setup.

    While i am trying to visit ISPconfig from my browser : IP:8080 an error appear:

    Code:
    Forbidden
    
    You don't have permission to access / on this server. 
    Checking the error.log in apache directory the follow message appear:

    Code:
    [Sat Feb 22 22:48:02 2014] [error] [client IP] client denied by server configuration: /var/www/
    
    Permissions :

    Code:
    drwxr-xr-x 2 5002 5003 4096 Feb 22 16:27 apps
    -rw-r--r-- 1    0    0  177 Feb 22 15:39 index.html
    lrwxrwxrwx 1    0    0   34 Feb 22 16:27 ispconfig -> /usr/local/ispconfig/interface/web
    drwxr-xr-x 4    0    0 4096 Feb 22 16:27 php-fcgi-scripts
    drwxr-xr-x 2    0    0 4096 Feb 22 16:08 webalizer
    Information about 000-default :

    Code:
    <VirtualHost *:80>
            ServerAdmin [email protected]
    
            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
            ErrorLog ${APACHE_LOG_DIR}/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>
    000-ispconfig.vhost

    Code:
    Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost _default_:8080>
      ServerAdmin [email protected]
    
      <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
      </FilesMatch>
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options -Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
        IPCCommTimeout  7200
            MaxRequestLen 15728640
      </IfModule>
    
    I tried to enable fcgid mod the error stop appear but still not working , the error that appear in error.log of apache is ;

    Code:
    [Sat Feb 22 23:27:32 2014] [warn] [client IP] mod_fcgid: stderr: PHP Fatal error:  require_once(): Failed opening required '../lib/config.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/index.php on line 31
    
    Any help will be appreciate.

    Regard's

    John
     
    Last edited: Feb 23, 2014
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if the apache fastcgi module is not installed or not activated. which tutorial did you use to install your server and which linux distribution do you use?
     
  3. ispconfig_error

    ispconfig_error New Member

    Well i am using Debian 7. Now as soon as i enabled : fastcgi the error stop appear but new error appear :

    [Sat Feb 22 23:27:32 2014] [warn] [client IP] mod_fcgid: stderr: PHP Fatal error: require_once(): Failed opening required '../lib/config.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/index.php on line 3

    I used a tutorial provided by a community.

    Thanks
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Which exact tutorial did you use? There are some incomplete guides out there that lead to broken setups. If you use debian 7, then the official and tested guide is this one:

    http://www.howtoforge.com/perfect-server-debian-wheezy-apache2-bind-dovecot-ispconfig-3

    as you had not enabled mod_fcgi, you must have followed a different guide. Please go trough each step from the guide above, starting with step 7 to ensure that oyu installed all necessary packages and that you did the nescessary config file modifications.

    download ispconfig again and instead of running install.php, run update.php and let the updater reconfiguer your server.
     

Share This Page