403 Forbidden web sites

Discussion in 'Installation/Configuration' started by joemateer, Apr 6, 2009.

  1. joemateer

    joemateer New Member

    Hi,

    ive just installed The perfect server on Debian 5.0 with ISPConfig 3

    Everything went great until I started creating websites. I get the following error on every website I create!! How annoying.

    Can anyone help please its driving me NUTS.


    Forbidden
    You don't have permission to access /ljsellerslisburn.co.uk on this server.


    --------------------------------------------------------------------------------

    Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny2 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g Server at server.pcinclusive.game-host.org Port 80
     
  2. zosorock

    zosorock New Member

    I am getting the same kind of error for everything, including the admin interface. I enabled logs file for it and this is what comes up in the error.log

    client denied by server configuration: /usr/local/ispconfig/interface/web/

    I am trying to run it on Debian 5 (Lenny) and Apache 2.2

    Any help much appreciated :) Thanks in advance!

    Fabiano
     
  3. joemateer

    joemateer New Member

    Im nearly sure its got something to do with the router! have you told your router to port forward 80 to the IP address of your server!

    I did a complete re-install from scratch with the debian install and ISPConfig 3 'The perfect server' and I still get the same error.

    lol
     
  4. zosorock

    zosorock New Member

    No, I doubt that is the problem. My server is in a datacenter and was running ISPcontrol just fine until I decided to give ISPconfig a try and now it doesn't work anymore. It was able to serve pages in PHP, Ruby on Rails and Python without any problems.

    I think it is an Apache setting somewhere. Or perhaps user permissions on files. Or something along these lines. That's where I would bet my money :)

    I hope someone can perhaps shed some light on our problem.

    Good luck!
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Did you check the web site's error log?
     
  6. joemateer

    joemateer New Member

    RECENT access.log


    90.240.213.70 - - [06/Apr/2009:13:11:30 +0100] "GET /work.com HTTP/1.1" 403 299 "-" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NE$

    RECENT error.log

    [Mon Apr 06 13:11:30 2009] [error] [client 90.240.213.70] client denied by server configuration: /var/www/work.com

    any help would be appreciated.
    Joe.
     
  7. joemateer

    joemateer New Member

    This is driving me crazy!!

    Its a clean, new installation. Im sure it has something to do with permissions but I cant put my finger on it!!

    Ive removed quota and quotatool to see if this helped and it never. I also tried changing permissions on the /var/www files and directories and this never helped either apacheclt says syntax ok.......

    Im baffled.. when i do create a new web page i get access to it for 30secs, when i refresh, then its blocks me out with the dreaded ERROR 403 Permission denied.

    Surely someone has came accross this before!!

    Joe.
     
  8. zosorock

    zosorock New Member

    yes, that's where I got this message from:
    client denied by server configuration: /usr/local/ispconfig/interface/web/
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Which ISPConfig 3 version do you have installed?
     
  10. zosorock

    zosorock New Member

    Here is 3.0.1.1, downloaded on Sunday. Please let me know if you need any other information. Also, if any of you developers would like access to the server where the issues are happening, contact me in private and I will send you access information.

    Thank you!
     
  11. falko

    falko Super Moderator ISPConfig Developer

  12. zosorock

    zosorock New Member

    problem solved here!

    I fixed the problem on my server by manually disabling the fcgid_ispcp module that was still sitting in the mods-enabled folder in /etc/apache2.

    Joe: do a ls -la /etc/apache2/mods-enabled and paste the results in here. We may be able to figure out which one is giving you problems.
     
  13. joemateer

    joemateer New Member

    Guys & Girls,

    I uninstalled ISPConfig 3 and installed ISPConfig 2... it's working like a dream!

    The problem was so annoying because it was a new install of Debian 5.0 lenny and a new install of ISPConfig 3 (following the 'Perfect Server' tutorial) and everything went as per tutorial, no errors etc etc.... I did this 3 times and it still gave me the error on ISPConfig 3. (ERROR 403 Access denied)

    Cheers
    Joe
     

Share This Page