403 Forbidden in Serveralias

Discussion in 'General' started by binover, Feb 22, 2010.

  1. binover

    binover New Member

    Hi guys, just a quick question, Im testing ispconfig 3 for the fist time, I installed it in advanced mode with zimbra as mail server.
    I like it very very much but I can't solve 1 problem, I created a website and chose autoalias www and all seems to be allright but when I go to www.domine.com.ar I get 403 forbidden all the time. but only in www alias.
    I get forbidden if I go to the IP address directly also.

    this is the vhost file:
    ----
    main:/var/www/ceotech.com.ar/web# cat /etc/apache2/sites-enabled/ceotech.com.ar.vhost
    <Directory /var/www/ceotech.com.ar>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/ceotech.com.ar/web

    ServerName ceotech.com.ar
    ServerAlias www.ceotech.com.ar
    ServerAdmin webmaster@ceotech.com.ar

    ErrorLog /var/log/ispconfig/httpd/ceotech.com.ar/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/ceotech.com.ar/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>
    <Directory /var/www/clients/client1/web1/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>

    # cgi enabled
    <Directory /var/www/clients/client1/web1/cgi-bin>
    Order allow,deny
    Allow from all
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/clients/client1/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # suexec enabled
    SuexecUserGroup web1 client1
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@ceotech.com.ar"
    php_admin_value upload_tmp_dir /var/www/clients/client1/web1/tmp
    php_admin_value session.save_path /var/www/clients/client1/web1/tmp
    php_admin_value open_basedir /var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/usr/share/php5


    </VirtualHost>
    --------

    if I replace <VirtualHost *:80> to <VirtualHost www.ceotech.com.ar:80> all seems be ok but that is not the case.

    And this is the apache2 error log (the XXX is just for hide the IP address):
    ---
    [Sun Feb 21 22:55:05 2010] [error] [client XXX.XXX.XXX.XXX] client denied by server configuration: /var/www/
    [Sun Feb 21 22:55:16 2010] [error] [client XXX.XXX.XXX.XXX] client denied by server configuration: /htdocs
    [Mon Feb 22 09:11:14 2010] [error] [client XXX.XXX.XXX.XXX] client denied by server configuration: /var/www/favicon.ico
    ---

    Thank you guys for all.
     
  2. till

    till Super Moderator

    Looks as if the website domain conflicts with the hostname of the server. To solve this, select the IP instead of * in the website settings. If the IP is not listed, add it in the server settings first.
     
  3. binover

    binover New Member

    works like a champ! Thanks Till! you're the best!
     

Share This Page