403 Forbidden at Admin Panel

Discussion in 'Installation/Configuration' started by arto0, Jun 28, 2013.

  1. arto0

    arto0 New Member

    Hi there,

    I am completely new to ISPConfig and after searching the forum for hours I am still clueless.

    I followed this great HowTo: http://www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3 on my Ubuntu 12.04 server.
    I already had some websites running on it when trying to install it.

    The installation went flawless until i tried to access the admin panel at https://mydomain:8080
    I then gives me a 403 Forbidden - You don't have permission to access / on this server.

    /var/log/apache2/error.log gives me the following:
    Code:
    [Fri Jun 28 12:53:42 2013] [error] [client 8x.1xx.1xx.1xx] client denied by server configuration: /etc/apache2/htdocs
    
    This is my 000-ispconfig.vhost
    Code:
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################
    
     Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost _default_:8080>
      ServerAdmin webmaster@localhost
    ..
      <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
      </FilesMatch>
    ..
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
        IPCCommTimeout  7200
    <------>MaxRequestLen 15728640
      </IfModule>
    ..
      <IfModule mpm_itk_module>
        DocumentRoot /usr/local/ispconfig/interface/web/
    <------>AssignUserId ispconfig ispconfig
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
    <------>  php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    ..
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    ..
      <IfModule mod_security2.c>
        SecRuleEngine Off
      </IfModule>
    
      # SSL Configuration
      SSLEngine On
      SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
      SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
      #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    Any help would be much appreciated!

    Cheers,
    arto0
     
  2. arto0

    arto0 New Member

    Nevermind!

    I solved it myself by enabling fcgid for apache2 :)
     
  3. dgeho1

    dgeho1 Member HowtoForge Supporter

    Looks like I have the exact same problem, how did you fix it? where and how does one enable fcgid for apache2?

    Thanx

    Dave
     
  4. arto0

    arto0 New Member

Share This Page