403 errors & freezing in ispconfig3, roundcube webmail

Discussion in 'Server Operation' started by cvgeeks, Jun 24, 2011.

  1. cvgeeks

    cvgeeks New Member

    I recently changed over from ISPConfig2 to ISPConfig3 and here is how my new setup looks.

    host1 = ISPConfig3, Apache
    db1 = MySql
    mail1 = postfix,dovcot
    host2 = Apache - not a mirror
    ns1 = Bind
    ns2 = Bind - mirroring ns1
    snort = snort

    I setup this configuration based on the tutorial in the ISPConfig3 manual. This is the multi server setup with a snort server and a second web server added in.
    I installed RoundCube on the vhosts each with their own roundcube installation like so; /var/www/domain.com/web/webmail.
    My setup works great I can't believe how great :) no problems except this one issue. Heres what happend I was adding some plugins to roundcube on one of the vhosts and a remote user for the soap calls and when I was testing it I started to receive 403 error's access denied to /webmail/. So I checked my remote users permissions and all was the way it was supposed to be according to the manul so after about a day of messing with it I figured I would removed what I had done and start over.
    I removed what I did and now I have this new problem.
    My strange problem comes in when I am in ISPConfig3 or RoundCube. In ISPConfig3 when I am clicking on a menu item the webpage will freeze and then after about 15 to 20 seconds I can click again. In RoundCube same thing except I'm still getting the 403 error if I click too fast! If I click with a 5 to 10 second delay between clicks no problems but click too fast and 403 Error access denied to /webmail/.

    The system was just fine until I started messing with those plugins :( but I don't see how this would affect ISPConfig and cause it too freeze if I click too fast on the menu items.

    Has anyone else had this problem with freezing or does anyone know what this might be cause by. The websites and email everything still works great it's just in the GUI of ispconfig or roundcube when I have these issues. Mail sends correctly etc.

    One more thing I forgot to mention is the 403 error only happens when I'm in the "Settings" of RoundCube and when I'm clicking between the 3 tabs. "Preferencs" Folders " Identities ". If I click between these three with a 1 second delay I get the 403 forbidden /webmail..
    Last edited: Jun 24, 2011
  2. cvgeeks

    cvgeeks New Member

    2nd server and same issue in roundcube

    Ok, I figured I would try to reproduce the same results with a second webserver by installing roundcube in a vhost. So here is a seperate server never having email, no plugins etc. RoundCube freezes when your in the "Settings" and you click between the three tabs too quickly.

    Now I'm starting to think that this is a bug of some sort in the roundcube app because I've checked all my webmail clients on all webservers and their all doing the same thing in roundcube.

    However I only have one ISPConfig3 server and it does not have the 403 error it just freezes period and after a minute or so it will let you click again.

    I know some one is thinking "this guy must be a clicker :) " but seriously it's weird I was just jamin through my setups adding domains and email and bam my panel froze on me and it's very reproduceable it's not hard to make it freeze. So I don't know if it's somthing with just my setup or what. Come to think about it my old roundcube setup froze allot as well even when trying to compose an email it would just freeze so I'm really leaning tword bug here. :confused:
  3. cvgeeks

    cvgeeks New Member

    Just for Giggles

    Today I'm going to install ISPConfig3 on a whole seperate server that is not tied into my domain and see if I can reproduce the freezing problem with it. I'm pretty sure it will happen again but I'll let you know none the less. ;) If it turns out to be true then I'll just slow way down on my power user clicking :D
  4. cvgeeks

    cvgeeks New Member


    Ok, so I reinstalled ISPConfig3 and the issue is not there! So I went back to check the rest of my website and database to see if it was a file system permission issue or a mysql issue. i dont see any issues with the filesystem however I did notice today that I'm getting kicked out of phpmyadmin with the same 403 forbidden /phpmyadmin/ error.

    Weird! It was all running fine :(

    If someone can point me in the right direction that would be great. Is there somthing with mysql and my remote calls to it that are not right? Again my setup is the multi server setup in the ISPConfig3 manual. All seperate servers pointing back to the main ISPConfig3 server.
  5. cvgeeks

    cvgeeks New Member


    Worked on this freezing problem all night!

    So I added the "Allow from all" statement in the Apache Directives to no avaial it still 403's me but the funny thing is it takes longer now before I get the 403. I know weird.

    I did a new installation of RoundCube using all the default values except those to connect to the database and same problems.

    What I don't get is if www-data has rwx-r x-r x to both temp and logs and the "Allow from all" is in the directives and the email all works and everyone can send and receive with no problem, why do we get this 403 once in a great CLICK? Strange I cant figure this one out.

    I was reading about an error like this with apache where the .htaccess file was issuing a Deny from all statement and this was blocking people out thats why I put the Allow from all in the directives but heres the weird thing my email was fine for months and then all the sudden this 403 started happening so what changed? All I was doing was adding databases and users to the databases hosting the email account for the vhost. I even went into the vhost file for the vhost to add the directives there thinking that would be different and it was not.

    Any help would be greatly appreciated :confused:
  6. cvgeeks

    cvgeeks New Member

    Soved :)

    SOLVED! Problem was with my calls to the database I was using localhost and not the remote servers ip. Funny!

Share This Page