403 errors after install

Discussion in 'Installation/Configuration' started by isp_mike, Nov 24, 2013.

  1. isp_mike

    isp_mike New Member

    This was a new centos 6.4 server I built just for testing ispconfig so no previous configurations.

    I followed this document to build the server;
    http://www.howtoforge.com/perfect-server-centos-6.4-x86_64-apache2-dovecot-ispconfig-3

    I had a number of problems which the doc didn't cover but I fixed all of them but now at the final stage, time to log into the web internet, I get the following.

    >Forbidden
    >You don't have permission to access / on this server.
    >Additionally, a 403 Forbidden error was encountered while trying to use an >ErrorDocument to handle the request.

    I tried loosening up the permissions in httpd.conf which didn't make any difference. I tried the same thing in some of the ispconfig config files with no difference.

    Here is a snip from the log.

    # tail -f /var/log/httpd/error_log
    [Sat Nov 23 16:52:10 2013] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Sat Nov 23 16:52:10 2013] [notice] Digest: generating secret for digest authentication ...
    [Sat Nov 23 16:52:10 2013] [notice] Digest: done
    [Sat Nov 23 16:52:10 2013] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Sat Nov 23 16:52:10 2013] [notice] mod_python: using mutex_directory /tmp
    [Sat Nov 23 16:52:10 2013] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Sat Nov 23 16:52:10 2013] [notice] Apache/2.2.15 (Unix) DAV/2 PHP/5.3.3 mod_python/3.3.1 Python/2.6.6 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.15 OpenSSL/1.0.0-fips configured -- resuming normal operations
    [Sat Nov 23 18:53:21 2013] [error] [client 192.168.1.205] Directory index forbidden by Options directive: /var/www/html/
    [Sat Nov 23 18:53:21 2013] [error] [client 192.168.1.205] client denied by server configuration: /var/www/error
    [Sat Nov 23 18:53:21 2013] [error] [client 192.168.1.205] File does not exist: /var/www/html/favicon.ico

    Looking for some leads on where to go next. Thanks kindly.
     
  2. Quaxth

    Quaxth New Member

  3. isp_mike

    isp_mike New Member

    Using http and the port, I get; (which makes sense of course)

    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>400 Bad Request</title>
    </head><body>
    <h1>Bad Request</h1>
    <p>Your browser sent a request that this server could not understand.<br />
    Reason: You're speaking plain HTTP to an SSL-enabled server port.<br />
    Instead use the HTTPS scheme to access this URL, please.<br />
    <blockquote>Hint: <a href="https://isp.mydomain.com:8080/"><b>https://isp.mydomain.com:8080/</b></a></blockquote></p>
    </body></html>

    Using http or https without the port, I get;

    Forbidden
    You don't have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
     
  4. Quaxth

    Quaxth New Member

    Please put the Code in Code Tags like [ code ]code[ / code ] (remove the spaces) for to see correctly what's posted, it will look so:
    Code:
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>400 Bad Request</title>
    </head><body>
    <h1>Bad Request</h1>
    <p>Your browser sent a request that this server could not understand.<br />
    Reason: You're speaking plain HTTP to an SSL-enabled server port.<br />
    Instead use the HTTPS scheme to access this URL, please.<br />
    <blockquote>Hint: <a href="https://isp.mydomain.com:8080/"><b>https://isp.mydomain.com:8080/</b></a></blockquote></p>
    </body></html>
    Now a question: your sever is located at your Office/Home or an Data Center? If at your Office/Home, check your Router has Port 8080 enabled for Remote Administration. If that is the case, change the Port 8080 in your Router if possible to let 18080 or change the Port in ISPConfig to let say 8090, not use 8081 or 8082, they're maybe used by other apps.

    First you've to get ISPConfig CP to run. so try to logon with https://server.mydomain.com:8080 or the port you changed to in ISPConfig.
     
  5. isp_mike

    isp_mike New Member

    The server is local so there is no firewall problem. Besides, as I posted, I am reaching the server, it's just not responding properly. The logs show that there is a permissions problem but I'm not sure where.

    Thanks.
     

Share This Page