403 Error with ISPConfig3

Discussion in 'Server Operation' started by timefalls, Jun 2, 2010.

  1. timefalls

    timefalls New Member

    hey guys!


    I just finished following the ISPConfig3 and SquirrelMail setup on Ubuntu 10.04LTS.

    I have my domains setup correctly, so they forward nicely to my server. Unfortunately, when I was trying to install Wordpress to my domain, It suddenly switched to ERROR 403 Forbidden.

    Naturally I was browsing this website for possible fixes, one suggested changing the permissions of /var/mydomain/web to 755, but this has absolutely no effect.

    Can anybody help?
     
  2. bernholdt

    bernholdt Member

    Look in your apache error.log should give you a hint on what to look for
     
  3. timefalls

    timefalls New Member

    thanks for your reply! :)

    the lines of my error log are as follows:

    Code:
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imagick.ini on line 1 in Unkno$
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imap.ini on line 1 in Unknown $
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/mcrypt.ini on line 1 in Unknow$
    [Sun May 30 06:39:16 2010] [notice] Apache/2.2.14 (Ubuntu) mod_fcgid/2.3.4 PHP/5.3.2-1ubuntu4.1 with Suhosin-Patch mo$
    [Sun May 30 06:39:16 2010] [warn] long lost child came home! (pid 9830)
    [Sun May 30 06:44:14 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 07:00:12 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 07:17:58 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 07:33:32 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 07:49:20 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 08:05:18 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 08:21:51 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 08:40:58 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 09:00:50 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 09:21:09 2010] [error] [client 89.163.146.43] client sent HTTP/1.1 request without hostname (see RFC2616 $
    [Sun May 30 09:21:16 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 10:07:05 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 10:18:48 2010] [error] [client 151.8.62.90] client sent HTTP/1.1 request without hostname (see RFC2616 se$
    [Sun May 30 10:32:06 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 10:57:48 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 11:24:49 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 11:36:00 2010] [error] [client 216.145.11.94] File does not exist: /var/www/robots.txt
    [Sun May 30 11:51:25 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 12:10:43 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 12:29:50 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 12:47:28 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 13:04:43 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 13:22:28 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 13:26:13 2010] [error] [client 91.212.12.60] client denied by server configuration: /htdocs
    [Sun May 30 13:31:34 2010] [error] [client 89.16.175.101] File does not exist: /var/www/phpmyadmin
    [Sun May 30 13:31:34 2010] [error] [client 89.16.175.101] File does not exist: /var/www/phpMyAdmin
    [Sun May 30 13:39:59 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    [Sun May 30 13:56:27 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
    
    i am unsure how to resolve these, any input would be greatly appreciated!
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you use mod_php, suPHP, or FastCGI?
     
  5. timefalls

    timefalls New Member

    hi there falko, I actually followed your guide here:

    http://www.howtoforge.com/perfect-server-ubuntu-10.04-lucid-lynx-ispconfig-3

    to the letter! I'm not sure if i have those installed, is there a command i can invoke to check if these plugins are active?

    your guide worked perfectly for me, but when i added web content to my domain's folder it suddenly switched to a 403 :(
     
  6. CSsab

    CSsab New Member

    Try putting this in the apache directives field of your site:

    <Directory /var/www/yourwebsite.com/web>
    AllowOverride All
    </Directory>


    Then restart apache
     
  7. BorderAmigos

    BorderAmigos New Member

    Did Wordpress install or change your .htaccess file? Look in there to see if a deny is affecting you.
     
  8. timefalls

    timefalls New Member

    thanks for your reply! i modified my sites-available file with the changes you suggested, and when i restarted apache i got this:

    Code:
     * Restarting web server apache2                                                [Thu Jun 03 18:55:49 2010] [warn] NameVirtualHost [my ip here]:80 has no VirtualHosts
    [Thu Jun 03 18:55:49 2010] [warn] NameVirtualHost [my ip here]:443 has no VirtualHosts
     ... waiting [Thu Jun 03 18:55:50 2010] [warn] NameVirtualHost  [my ip here]:80 has no VirtualHosts
    [Thu Jun 03 18:55:50 2010] [warn] NameVirtualHost  [my ip here]:443 has no VirtualHosts
    
    still getting a 403 forbidden error :(
     
  9. timefalls

    timefalls New Member

    my .htcaccess file is empty.
     
  10. timefalls

    timefalls New Member

    I made the changes as you directed, by as i restarted apache I got these errors:

    * Restarting web server apache2 [Thu Jun 03 18:55:49 2010] [warn] NameVirtualHost [my IP here]:80 has no VirtualHosts
    [Thu Jun 03 18:55:49 2010] [warn] NameVirtualHost [my IP here]:443 has no VirtualHosts
    ... waiting [Thu Jun 03 18:55:50 2010] [warn] NameVirtualHost [my IP here]:80 has no VirtualHosts
    [Thu Jun 03 18:55:50 2010] [warn] NameVirtualHost [my IP here]:443 has no VirtualHosts
    [ OK ]

    not too sure what's going on here! should i change it back?
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  12. KZeeSoft

    KZeeSoft New Member

    Timefalls:

    What Falko is trying to tell you to do is go into the ISP Config control panel, and navigate to your website in question. You do this by clicking on the upper tab called "Sites", then click the "Domain" tab at the top of that screen. Now look at the bottom of that page and you should see a field called "PHP" right above the "Active" field checkbox. This should be a dropdown menu that has options such as "Disabled, Fast-CGI, CGI, Mod-PHP, SuPHP".

    This is the value we are looking for to help you troubleshoot your issue.

    Let us know =)

    Thanks
     
  13. timefalls

    timefalls New Member

    thanks for your reply! the value for the PHP field is set to disabled.
     
  14. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please enable PHP and select mod_php. Wordpress is written in PHP, so that must be enabled.
     
  15. timefalls

    timefalls New Member

    It works perfectly! I cannot believe it was something so simple :p

    thanks will be sent to all in the thread!
     
  16. abys

    abys New Member

    i just do
    chown www-data:www-data /usr/local/ispconfig
    and
    chown root:root /var/www/apps

    it work fine for me !

     

Share This Page