403 error Forbidden - ubuntu 810 and ispc 3

Discussion in 'Installation/Configuration' started by jamesls, Apr 14, 2009.

  1. jamesls

    jamesls New Member

    Hi

    I've just installed ispconfig 3 by following the perfect server how to. I did it for ispc 3 this time :)
    Everything installed well and it appears to work, I'm guessing I'm doing something wrong or else I've missed something in the configuring web sites from within ispc3.

    I set up a client - victim6, and went through the setup, I didn't do anything in the dns section as I'm not sure about dns, I'll figure it out or ask later. I did the cllient ticked all the boxes and left the quotas page all set to defaults, setup the email, and the web server I gave the domain as "victim6.co.co" just to test it and see what happened.

    when I try to view the page I receive the 403 error.
    I typed http://127.0.0.1/victim6.co.co
    if I type http://127.0.0.1 I get "It works!" from the default apache install

    I can see a client folder off /var/www/.... /web1/web/, and that contains the index file so I figure isp3 is working.

    Any help much apreciated

    james
     
  2. jamesls

    jamesls New Member

    Solved [part of the problem

    I read the bit about adding
    your ip address to the apache available sites conf file

    I did that and the 403 forbidden msg has gone, and I get the web page, then I set up another web site using the same client, now it seems to default to the second site and I can't view the first.

    I was under the impression Apache sorted out the names, I played around with ispconfig 2 a while back and don't remeber having to enter DNS records like A records and name servers ???

    At the moment the only way I can access the web site is by typing in the ip address 127.0.0.1, or 192.168.0.100 if I add the domain name to the end 192.168.0.100/goof.tet it just give me a 404 error.

    If I'm on the web server machine what do I type to see the domain page?
     
  3. jamesls

    jamesls New Member

    I think I need to set up the DNS parts

    I found the following threads about dns setup
    DNS Thread
    http://www.howtoforge.com/forums/showthread.php?t=27030
    http://www.howtoforge.com/forums/showthread.php?t=32011
    http://www.howtoforge.com/forums/showthread.php?t=31881
    http://www.howtoforge.com/forums/showthread.php?t=26958

    points to 1st site
    http://www.howtoforge.com/forums/showthread.php?t=32213

    I'm now thinking I need to sort out the DNS parts to be able to access the web sites, its late here so I'll play tommorow.

    If I'm doing it wrong someone let me know please
     
  4. falko

    falko Super Moderator

  5. jamesls

    jamesls New Member

    We have a winner :)

    Well it works for web browsing YESSSS!

    And suprisingly simple.

    From what I've read ISPConfig 3 sorts its own names and stores them, you don't do anything to your hosting systems dns files.

    Here what I did after installing the software
    create cleint the web site I called victim7.vx

    email - just added client, and entered the domain name "victim7.vx"
    Add site selected client, then added domain "victim7.vx"
    DNS .. select client, zone "victim7.vx", NS "ns1" and gave it an email "admin.victim7.vx
    Records select A, hostname "victim7.vx.", ip "10.0.0.10" (the ip of my host pc)
    Select A, hostname "mail", ip "10.0.0.10"
    Select A Hostname "ns1" ip "10.0.0.10"
    Select MX hostname "victim7.vx.", mailserver "mail.victim7.vx"
    Select NS zone "victim7.vx", hostname "ns1.victim7.vx."

    I did this with 3 different sites vitim6 7 & 8 and they are resolved by their names in a browser, I'm not sure about the email side yet LOL

    A couple of things to note
    1. you have to put a full stop (period) at the end of the site names when entering the records.
    2. I did this on my home network hence the ".vx" extension, as there is no dns server on my network to resolve the names I had to point my other windows machines to my web hosting pc by altering the hosts files on each of them.

    my hosts file - c:\winnt\system32\drivers\etc\HOSTS has the following lines added.

    10.0.0.10 victim6.vx
    10.0.0.10 victim7.vx
    10.0.0.10 victim8.vx

    Normaly if the domain is on the internet then a dns machine gives you the ip address to look at

    my web server, is ubuntu 8.10, and the only thing I altered was the ip address for my wired network and thats 10.0.0.10, the only place I had to enter the host pc's details was in the server config I think, and thats showing
    ip address 127.0.0.1
    netmask 255.255.255.0
    gateway 192.168.0.1 (I have 2 network cards, 192 = wireless internet, 10. = wired home network
    hostname dell.glaceb.com
    nameservers 192.168.0.1 & 192.168.0.2 (not sure about these .1 is my router and .2 doesn't exist.

    This works ok for me and resolves the web sites, next job for me will be the email....hope it helps someone. use the dns links in a previous msg

    Anyway time for a coffee

    james
     

Share This Page