403 Error- Forbidden! on certain folder

Discussion in 'Installation/Configuration' started by lschafroth, Oct 28, 2008.

  1. lschafroth

    lschafroth New Member

    I have a website running under ISPConfig and it works fine.

    I installed cacti under a subfolder called monitor. It worked fine.

    Now when I try to access that folder I get 403 Error- Forbidden!.

    All other folders on the site work. I have included the Vhosts_ispconfig.onf portion for the site in question.


    I changed the domain and ip. not sure if I even needed to for posting.

    VirtualHost xxx.xxx.xxx.xxx:80>
    ServerName www.domainxxx.net:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web11/web
    ServerAlias domainxxx.net
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    Alias /cgi-bin/ /var/www/web11/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web11/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode Off
    <IfModule mod_ruby.c>
    <Directory /var/www/web11/web>
    Options +ExecCGI
    RubyRequire apache/ruby-run
    #RubySafeLevel 0
    <Files *.rb>
    SetHandler ruby-object
    RubyHandler Apache::RubyRun.instance
    <Files *.rbx>
    SetHandler ruby-object
    RubyHandler Apache::RubyRun.instance
    <IfModule mod_python.c>
    <Directory /var/www/web11/web>
    Options +Indexes +FollowSymLinks +MultiViews
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    allow from all
    AddHandler mod_python .py
    PythonHandler mod_python.publisher
    PythonDebug On
    AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
    AddType text/vnd.wap.wml .wml
    AddType text/vnd.wap.wmlscript .ws .wmlscript
    AddType image/vnd.wap.wbmp .wbmp
    Alias /error/ "/var/www/web11/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    rrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web11/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web11/user/$1/web/$3
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule .* - [F]
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the permissions of the folder that does not work.
  3. lschafroth

    lschafroth New Member

    I've tried CHMOD 777. I've given ful ownership to the owner of the site, which is how the rest of the site is. I've tried giving ownership to apache.

    Here are the permissions:

    drwxr-xr-x 12 doug.adlsolutions.net web11 4096 Oct 24 20:52 monitor

  4. falko

    falko Super Moderator ISPConfig Developer

    Is there an index file in the monitor directory (like index.html, index.php, etc.)?

Share This Page