403 error accessing subdirectory after upgrade to current ISPCONFIG 3

Discussion in 'Installation/Configuration' started by vestport, Sep 8, 2021.

  1. vestport

    vestport Member

    Hello group,

    My home directory is fine and responds as per normal when I go to mysite.com. I have a subdirectory "mysite.com/files" where I store tons of stuff and other subdirectories off that one. Everything is still owned by the same user (root) but after upgrade I get a 403 when trying to go to the subdirectory "mysite.com/files".

    Any advice appreciated as there is a mountain of stuff here in the "/files" subdirectory" and I can no longer get to it via a browser. I did back it all up and was going to attempt to delete the entire site, create it again and move forward but I'm confident the issue is more simple than that. I do have SSL activated but the "files" directory is normal with no .htaccess or .htpassword. Some other directories beyond "/files" are SSL directories and in fact still ask for passwords so I don't know what the heck is going on. That and I'm a bit rusty these days.

    Thanks in advance for any replies!

  2. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    is there an index.html or index.php file in that folder.
    i know if you have file/directory listing disabled in apache, you'll get a 403 error if you trying looking at an empty folder.
    could be the same if there's just no index.html or index.php (or whatever file DirectoryIndex might point to) in the folder.
    vestport likes this.
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Should it be owned and group owned by the website user and group? You could try creating a new website and check what owners and permissions the files and directories get, and repair the website based on that.
  4. vestport

    vestport Member

    I just rebuilt the website and reinstalled all my files, SSL cert and all that and the same thing is happening. This problem is still not fixed. I also did a "chown -R user:group directory/*" to change all the permissions once I copied all the files back. Same thing, the root directory works fine and none of my subdirectories come up. Most just have files in them and not web pages but it all worked before. This just happened after upgrade. I'm stumped and really need this back online to get certain files when I'm away.
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If accessing the files/ directory with browser does not let you see the files, examine with adding index.html in that directory and see if you then can see the index.html. If you did, then web server is configured to not allow seeing file listing of directory.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    An ISPConfig upgrade does not alter the website vhost file at all, so it's probably just a coincidence or you did not notice it before because the change was in the website or server configuration but was applied at the time the ISPConfig upgrade restarted the web server process. What else did you do beside upgrading ISPConfig, did you install any operation system updates as well? Which exact error message do you get in the error.log of the website? Maybe you altered a .htaccess file?
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I think this thread is not about what @till answered. Wrong thread for that answer?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    In the initial post, he wrote that he can't access files after upgrading ISPConfig. I just mentioned that an ISPConfig upgrade does not change the vhost configuration (nor does it change website permissions), so the reason for this issue is most likely not related to the ISPConfig upgrade.

    Is the 'directory' maybe a symlink to a directory and not a directory itself?

Share This Page