3rd Site e-mail problem

Discussion in 'Installation/Configuration' started by BoloMarkIII, May 10, 2011.

  1. BoloMarkIII

    BoloMarkIII New Member

    Ispconfig2 on Opensuse 11.3

    I have a server running 3 sites everything works accept the 3rd sites email.
    I have the roundcube mail add on.
    The problem with the 3rd sites email is none of the accounts can receive mail.
    On the 3rd site I can login to an e-mail account /w roundcubemail using the username & password but not with e-mail address and password. I can send e-mail from account but the received e-mail states it is from [email protected] and not from the domain ([email protected]).

    Here is my local-host-names
    Code:
    ###################################
    #
    # ISPConfig local-host-names Configuration File
    #         Version 1.0
    #
    ###################################
    localhost
    vserver1.xxxx.com
    localhost.vserver1.xxxx.com
    localhost.xxxx.com
    localhost.localdomain
    www.zzz.net
    www.yyy.com
    www.xyz.com
    zzz.net
    yyy.com
    xyz.com
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    The virtusertable file seems to be in order, entries for 3rd sites users are the same format as other 2 sites that work, don't really want to post it.

    What else can I check ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which exact error message do you get in the mail.log?
     
  3. BoloMarkIII

    BoloMarkIII New Member

    I get this error.
    Code:
    Recipient address rejected: User unknown in local recipient table
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the recipient address listed in /etc/virtusertable ?
     
  5. BoloMarkIII

    BoloMarkIII New Member

    virtusertable is in /etc/postfix
    YES as stated above I did not want to post it.
    Yes recipient is listed and all seems to be in order as the listings have the same format as users listed in the other 2 sites.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Please try this:
    Code:
    postmap /etc/postfix/virtusertable
    /etc/init.d/postfix restart
     
  7. BoloMarkIII

    BoloMarkIII New Member

    Thx Falco I tried that did not work I even renamed the virtusertable.db so it would write a new one but no joy.

    Ok after staring at the virtusertable file I noticed that the first site adds 4 enties:
    [email protected] web1_name
    [email protected] web1_name
    [email protected] web1_name web1_name
    [email protected] web1_name

    Second and third site adds only 2 entries:
    [email protected] web2_name
    [email protected] web2_name

    So Ispconfig is not adding 2 entries to the virtusertable file.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess in the website www.yyy.com, the co-domain yyy.com (with empty hostname field) is missing. Or you have set this co-domain to external mailserver which disables mail for that domain.
     
  9. BoloMarkIII

    BoloMarkIII New Member

    Thx till that fixed my problem in the co-domain tab for 2nd and third site, www.xyz.com was listed instead of xyz.com changed it now all is well thank you again.
     

Share This Page