3 little post installation questions

Discussion in 'ISPConfig 3 Priority Support' started by jpcyrenne, Oct 28, 2013.

  1. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Good Day,

    Running ISPConfig 3.0.5.3 on CentOS 6.4 and I'm having 3 issues:

    1- I cant seem to change any /etc/php.ini config with success? I've restarted Apache and still no success when I run a phpinfo(). Is there another php.ini for a local account?

    2- Every time I load up a phpMyAdmin or phpinfo file, I get a Time Warning. Where and how would I set the correct config on the server?

    Warning: phpinfo() [function.phpinfo]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /var/www/clients/client3/web3/web/magento-check.php on line 2

    3- I have one account that can see all the databases in phpMyAdmin not the others? I've compared the mysql.user table and they are all the same (No everywhere)? How do we set rights in ISPConfig? Where do we GO? I only seem to be able to create a database user and attach it to the database (Sites/Databases), where do I go and grant read/write/insert rights? Specially stop the user from seeing the other databases?

    I thank you in advance. I like my ISPConfig so far!

    JP
     
  2. Quaxth

    Quaxth New Member

    There many apps which using there own php.ini file within their folders.

    The ease the check, download WinSCP to your Windows desktop and install. Connect with your root credentials like in putty by SSH to your server.

    Now you could open easy avari folder an look for the files you like to check. double click on the file to open. You could edit and save if you do some changes.

    CAUTION: All you do is on your own risk and do not change anything you're not sure it's OK!
     
  3. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Humm not sure I understand? I'm trying to run Magento for a client and he want's me to change a few php.ini configs. When I run phpinfo() I don't see the changes (made by root on server) to /etc/php.ini.
     
  4. Quaxth

    Quaxth New Member

    If you change the settings in /etc/php.ini those changes will be global for the whole server. Don'n know that's what you want?!

    Check under the clients account/domain inside the Magento folder for a php.ini file and check those setting and change if needed there.

    To change php.ini settings global, that should be taken really with care!
     
  5. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    You are right... but even if I change the global settings (/etc/php.ini) it doesn't work? It should no?
     
  6. Quaxth

    Quaxth New Member

    If done correctly, it should work!

    Check the syntax! Also may have to wait the ISPConfig staff is back online after 8m German time!! They may could tell you more.
     
  7. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    I installed Apache with yum. If I do a locate php.ini (from /) it only finds it in /etc/php.ini

    $ locate php.ini
    /etc/php.ini
    /usr/share/doc/php-common-5.3.3/php.ini-development
    /usr/share/doc/php-common-5.3.3/php.ini-production

    Is there an other place I don't know of with ISPConfig? Can I override this in the local folder? put a .htaccess or php.ini in the web folder?

    Thanks,

    JP
     
  8. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

  9. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    I fixed item 2 with this line in the /etc/php.ini:
    date.timezone = America/Montreal

    Many applications were giving time errors... Seems to be fixed in PHP 5.4 My server is running PHP 5.3.3

    ***
    This goes to show i'm reading the /etc/php.ini? Why can't I change simple parameters like: max_execution_time, max_input_time, memory_limit and post_max_size? For Magento hosting.

    JP
     
  10. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Could this have to do with the settings in ISPConfig (under sites)?

    It's set on fast-cgi.

    If I change to mod-php i still see CGI/FastCGI as the API.

    suPHP stops the info.php file from working.

    php-fpm sees the Apache 2.0 Handler and I got the Local and Master values!

    Lesson to all, if you want your customers to manage php parameters in an .htaccess file, go with PHP-FPM. Fixed my problem.

    JP
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Custom php.ini parameters in ispconfig are managed trough the php.ini directives field on the options tab of the website settings as described in the manual. So all you have to do is to set the values there.

    .htaccess files are never read by pgp fcgi processes, thats not ispconfig specific.

    then you might not have waited until the config files were written. You can see in the jobqueue of the monitor if there are any pending config file changes.
    Login to ispconfig, add a database user, then add a database and select this user in the database settings. Now this user has all permissions (read/write/insert) on that database. The user does not see any other databases except he ons that you assigned to this user by selecting him in the user settings of the databases.
     
    Last edited: Oct 30, 2013

Share This Page