3.2.1 / 3.2.2 subdomain/aliasdomain vhost additional php bug?

Discussion in 'General' started by nhybgtvfr, Jan 8, 2021.

  1. nhybgtvfr

    nhybgtvfr Active Member

    i tried adding a subdomain vhost in ispconfig 3.2.1, and it wouldn't let me select any of the additional php versions, the whole drop-down was empty. i've tried it selecting various servers, and with aliasdomain vhosts, same thing.
    i know it's not a problem with the additional php versions themselves. they are working fine on full websites, i can add a new website, select any server, and get a full list of the installed php versions on that server, just nothing for vhost sub/alias domains.

    i've updated the master server to 3.2.2, and tried again with a vhost subdomain on that server, and it still shows an empty list on the php-version drop-down, and the full list of php versions on the drop down when adding a full website.

    master/interface server is running ubuntu 18.04
     
  2. nhybgtvfr

    nhybgtvfr Active Member

    additional:

    i've just checked already existing vhost subdomains, and they have the php version drop-down fully populated.
    i've tried again with a new subdomain vhost, php version is blank, if i change the php handler from php-fpm, which is set as the default, to eg disabled, or mod-php, and then back to php-fpm it's again fully populated.
    same if i switch from the default to fastcgi the php version is fully populated, and fully populated on switching back to php-fpm.

    so it appears to be affecting only the initial population of that drop-down on adding a new vhost sub/alias.
     
    ahrasis likes this.

Share This Page