3.1 Install Problem

Discussion in 'Installation/Configuration' started by wvh, Sep 28, 2016.

  1. wvh

    wvh New Member

    I recently upgraded to Ubuntu 16.04 and today upgraded from ISPConfig 3.0x to 3.1. Now, my server is crashing like every five minutes. It seems to have to do with the PHP settings. On the Server Config page under PHP SETTINGS all of the fields have information in them for a now deleted version of PHP 5.0. I am running PHP 7.0 and have also installed a secondary install of PHP 5.06 as shown here https://www.howtoforge.com/tutorial/how-to-install-php-5-6-on-ubuntu-16-04/.

    I can't figure out why the new info did not import to ISPConfig or what info to enter into the fields of the page PHP SETTINGS. Could someone who has a similar server config please give me the proper settings to put in these fields to enable PHP 7.0 or 5.6? I would be eternally grateful, as at the moment I am having to wake-up once every 15 minutes to restart the server. Thank you.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    An update can not alter any settings. If you upgrade your OS an that new OS uses different paths for system binaries or config files, then you have to adjust these paths under system > server settings. In your case, adjust all the php fcgi and fpm settings to match the new paths on Ubuntu 16.04.

    Here are the settings (as variables). I hope you can read the matching info like this.

    $conf['apache']['php_ini_path_apache'] = '/etc/php/7.0/apache2/php.ini';
    $conf['apache']['php_ini_path_cgi'] = '/etc/php/7.0/cgi/php.ini';

    $conf['fastcgi']['fastcgi_phpini_path'] = '/etc/php/7.0/cgi/';
    $conf['fastcgi']['fastcgi_starter_path'] = '/var/www/php-fcgi-scripts/[system_user]/';
    $conf['fastcgi']['fastcgi_bin'] = '/usr/bin/php-cgi';

    $conf['nginx']['cgi_socket'] = '/var/run/fcgiwrap.socket';
    $conf['nginx']['php_fpm_init_script'] = 'php7.0-fpm';
    $conf['nginx']['php_fpm_ini_path'] = '/etc/php/7.0/fpm/php.ini';
    $conf['nginx']['php_fpm_pool_dir'] = '/etc/php/7.0/fpm/pool.d';
    $conf['nginx']['php_fpm_start_port'] = 9010;
    $conf['nginx']['php_fpm_socket_dir'] = '/var/lib/php7.0-fpm';
  3. wvh

    wvh New Member

    Thank you!!! The settings for Apache and FastCGI were exactly what I needed. I pretty much guessed on the rest of the fields, but it seems that I guessed right because I've gone two hours now without a reboot. Oddly, once I entered this info on the WEB>PHP Settings tab ISPConfig automagically filled in all of the correct information on the FastCGI settings tab as well. It's been a LONG wait for the 3.1 release, but seems to be worth it so far.

Share This Page