3.1.9 New DB User not selectable when creating DB

Discussion in 'Installation/Configuration' started by BLWedge09, Dec 19, 2017.

  1. BLWedge09

    BLWedge09 New Member

    After upgrading my Ispconfig install to 3.1.9, when I create a database user in the GUI, it does not show in the database creation GUI as a selectable user. If I go back to the user creation GUI, it is there...so it’s saving somewhere. Doesn’t create the user in Mysql/MariaDB, but I don’t think it does normally until a DB w/that user is created. DB creation with an existing user works fine. I checked my stored root password and it is fine. Using the same client for db user and db. Any ideas what could be going on here?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check again that the db user is really owned by the same client that owns the website that you create the DB for.
  3. BLWedge09

    BLWedge09 New Member

    I use this for only myself, so I don't have a bunch of clients set up. Also, this is an upgraded panel from a 3.0 install. Then it was moved via the paid migration tool.

    Just FYI, this used to work if the client field was blank across the board (Domain, website, DB user, and DB). That is no longer the case when you add a new user with a blank client. All of the old users with a blank client field still show up when creating the DB...just not the new one. I went back to the domain level and set the client field from there forward and that did make it work.

Share This Page