3.1.2 update: Metronome XMPP SSL server certificate is not renewed

Discussion in 'Installation/Configuration' started by philgardner, Jan 25, 2017.

  1. philgardner

    philgardner Member

    I have just updated my ISPConfig 3.1.1p1 installation (on Ubuntu 16.04.1) to version 3.1.2. All went well, but I got the message "Metronome XMPP SSL server certificate is not renewed."

    I ran the command specified – (cd /etc/metronome/certs && make localhost.key && make localhost.csr && make localhost.cert && chmod 0400 localhost.key && chown metronome localhost.key) – but got the messages:
    make: 'localhost.key' is up to date.
    make: 'localhost.csr' is up to date.
    make: 'localhost.cert' is up to date.

    Does this mean that the certificate files are now up to date, i.e. the update has succeeded, or were they already up to date – in which case why did I get the warning?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This was not a warning, it is just an info message about how to renew the certs in case that you want to renew them and it is no indication that the certs were not up to date. I will talk with the XMPP module developer to remove it as it is a bit confusing indeed.
  3. philgardner

    philgardner Member

    Thanks for the clarification. It definitely confused me, as it is worded as a warning.

Share This Page