changes or bug in the firewall?

Discussion in 'Developers' Forum' started by IzFazt, Jul 23, 2009.

  1. IzFazt

    IzFazt Member

    After upgrading to the beta only port 20 shows in the server internal firewall setup. When adding extra ports for FTP PASV mode server crashes, nobody and nothing can get in, controle pannel can not be reached. I renamed the database, reinstalled and swapped database back, and to my surprise the changes had not been written to the database. Only port 20 shows.
  2. popper2001

    popper2001 New Member

  3. popper2001

    popper2001 New Member


    Since I got not reply yet, I did a little research in the code and there seems to be actually a bug that causes an empty string at the TCP and UPD ports in /etc/Bastille/bastille-firewall.cfg as I already described here: http://www.howtoforge.com/forums/showthread.php?t=37637.

    To solve the problem for the actual beta I did the following:

     vi /usr/local/ispconfig/server/plugins-enabled/firewall_plugin.inc.php
    changed line 88 from
    if($p_int 0$tcp_ports .= $p_clean ' ';
    $tcp_ports .= $p_clean ' ';
    and line 103 from
    if($p_int 0$udp_ports .= $p_clean ' ';
    $udp_ports .= $p_clean ' ';
    @falko & till: Because this bug is not funny at all (since servers can get inaccessable), I suggest a quick fix for that in the distributed code!
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The distributed code is a beta version and no final. The beta version is for testing and to find bugs. The bug will be fixed in the final.
  5. popper2001

    popper2001 New Member

    Thanks, till! Perhaps "lost in translation": I really like ISPConfig and I know what betas are for ... ;) Anyhow: Thanks for your work and for the bugfixing.

Share This Page