3.0.0.8 rc1 mail relay problem

Discussion in 'General' started by booten, Jan 4, 2009.

  1. booten

    booten New Member

    Im experience a bit problem having the server send mails through the relay host.

    warning: SASL authentication failure: All-whitespace username.

    my relayhost doesnt need username/password.
    And i have those fields empty in ispconfig server setup for mail.

    But it adds this in the sasl_password file:
    smtp.myisp.net :

    I have solved this temporary by disabling the sasl_password map file in postfix conf.

    But is there a better way? to get ispconfig to not try to authenticate my relay with blank username/password on some way?
     
  2. till

    till Super Moderator

    Do not enable sasl authentication if your relay server does not need it.
     
  3. booten

    booten New Member

    yea that sounds like a correct solution, but it feels like ispconfig does this for me, and i cant find any option within ispconfig to disable just that.
     
  4. booten

    booten New Member

    How do i disable this in ISPconfig?

    Each time i remove this from postfix conf, and make changes in ispconfig, it enables sasl_authentication in postfix again.

    IMO, ISPconfig shouldnt do this if username/password is empty.
     

Share This Page