2mb limit in fcgid mode

Discussion in 'Installation/Configuration' started by renders, Nov 30, 2010.

  1. renders

    renders New Member

    Hi all.. I have a photo uploading script that works fine under mod_php but fails on fcgid ONLY on files larger than 2mb.

    I have the usual php.ini upload settings set to 64mb..

    Is there a setting related to this limit?

    Thanks

    Rob
     
  2. cbj4074

    cbj4074 Member HowtoForge Supporter

    Rob,

    There are several settings related to that limit. You may wish to modify the following to suit your needs and paste it into the "Apache directives" box for the site:

    Code:
    <Directory /var/www/domain.tld/>
    LimitRequestBody 0
    php_admin_value memory_limit 1024M
    php_admin_value max_execution_time 0
    php_admin_value max_input_time 0
    php_admin_value post_max_size 2000M
    php_admin_value file_uploads On
    php_admin_value upload_max_filesize 2000M
    php_admin_value session.cookie_lifetime 0
    php_admin_value session.gc_maxlifetime 259200
    </Directory>
    
    Give it about 5 minutes for ISPConfig to refresh the directives, and see if your script functions as expected.

    Note also that you may use the phpinfo() function in a script that resides within the same directory as the script you are testing to confirm that the directives are being applied.

    Finally, the values in the example above are quite large; you may have no need to use such large values in your particular case.

    Good luck!
     
  3. renders

    renders New Member

    Tried your suggestion.. Added the following:

    Code:
    <Directory /var/www/domain.com>
    LimitRequestBody 0
    php_admin_value memory_limit 1024M
    php_admin_value max_execution_time 0
    php_admin_value max_input_time 0
    php_admin_value post_max_size 64M
    php_admin_value file_uploads On
    php_admin_value upload_max_filesize 64M
    php_admin_value session.cookie_lifetime 0
    php_admin_value session.gc_maxlifetime 259200
    </Directory>
    Checked the vhost file after a couple of minutes and saw that it was updated. BUT, no change to the phpinfo. Not sure what the issue is??

    Finally, got it to work by adding upload_max_filesize directly to the php.ini file in the /etc/php5/cgi folder once I realized that it was the correct php.ini file for fast_cgi.

    Thanks for your help..

    Rob
     

Share This Page