2 Problems a) pop3 mail, b) no www.

Discussion in 'Installation/Configuration' started by jamesls, May 6, 2009.

  1. jamesls

    jamesls New Member

    Hi

    I'm running Ubuntu 8.10 and ispc3.

    I've set up a number of domains so that I can play around with ispc3

    1. POP3 mail problem, Outlook says the server is interupting and it fails to retrieve.

    I had a look at the pop3d set up and changed
    root directory\etc\courier\pop3d
    ##NAME: MAXPERIP:4
    #
    # Maximum number of connections to accept from the same IP address

    MAXPERIP=16

    in the mail log I see

    May 5 13:53:44 dell last message repeated 12 times
    May 5 13:58:44 dell pop3d: Maximum connection limit reached for ::ffff:216.118.146.240
    May 5 13:58:44 dell last message repeated 12 times
    May 5 14:02:44 dell pop3d: Maximum connection limit reached for ::ffff:216.118.146.240
    May 5 14:03:45 dell last message repeated 12 times
    May 5 14:03:46 dell last message repeated 11 times
    May 5 14:08:46 dell pop3d: Maximum connection limit reached for ::ffff:216.118.146.240
    May 5 14:08:46 dell last message repeated 12 times

    I then restarted the server
    IT has made no difference

    Problem 2

    For some reason I can't resolve any www. prefixes apart from my first domain. They are all registared the same way in the records.
    when I enter http://domain.xyz they work, but when I enter www.domain.xyz they default to one of the other domains.
    I 'm running as far as I know a names based setup they are all "*" not ip
    I had some problems with webmail previously and had to put a link into each web folder for it to work - Till recomended it

    My first domain works fine
     
  2. jamesls

    jamesls New Member

    apache error log and

    [Sun May 03 22:11:07 2009] [notice] Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.2 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
    [Sun May 03 22:11:07 2009] [warn] long lost child came home! (pid 20760)
    [Sun May 03 22:12:02 2009] [notice] Graceful restart requested, doing restart
    Warning: DocumentRoot [/var/www/apache2-default/] does not exist
    [Sun May 03 22:12:04 2009] [notice] Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.2 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
    [Sun May 03 22:12:04 2009] [warn] long lost child came home! (pid 20962)
    [Sun May 03 22:14:02 2009] [notice] Graceful restart requested, doing restart
    Warning: DocumentRoot [/var/www/apache2-default/] does not exist
    [Sun May 03 22:14:07 2009] [notice] Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.2 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
    [Sun May 03 22:14:07 2009] [warn] long lost child came home! (pid 21132)
    [Sun May 03 22:28:51 2009] [error] [client 10.0.0.1] File does not exist: /usr/local/ispconfig/interface/web/themes/default/css/yaml, referer: http://10.0.0.10:8080
    [Sun May 03 23:28:35 2009] [error] [client 122.160.230.131] Invalid method in request \x16\x03
    [Mon May 04 13:06:02 2009] [error] [client 10.0.0.1] File does not exist: /usr/local/ispconfig/interface/web/themes/default/css/yaml, referer: http://10.0.0.10:8080/
    [Mon May 04 13:10:55 2009] [error] [client 10.0.0.1] File does not exist: /usr/local/ispconfig/interface/web/themes/default/css/yaml, referer: http://10.0.0.10:8080/
    [Mon May 04 13:21:52 2009] [error] [client 10.0.0.1] File does not exist: /usr/local/ispconfig/interface/web/themes/default/css/yaml, referer: http://10.0.0.10:8080/
    [Mon May 04 14:01:59 2009] [error] [client 10.0.0.1] File does not exist: /usr/local/ispconfig/interface/web/themes/default/css/yaml, referer: http://10.0.0.10:8080/
    [Mon May 04 14:04:41 2009] [error] [client 10.0.0.1] File does not exist: /usr/local/ispconfig/interface/web/themes/default/css/yaml, referer: http://10.0.0.10:8080/
    [Mon May 04 14:05:26 2009] [notice] Graceful restart requested, doing restart
    Warning: DocumentRoot [/var/www/apache2-default/] does not exist
    [Mon May 04 14:05:31 2009] [notice] Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.2 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
    [Mon May 04 14:05:31 2009] [warn] long lost child came home! (pid 21414)
    [Mon May 04 17:54:15 2009] [error] [client 10.0.0.1] File does not exist: /usr/local/ispconfig/interface/web/themes/default/css/yaml, referer: http://10.0.0.10:8080/
    [Tue May 05 00:27:53 2009] [notice] caught SIGTERM, shutting down
    [Tue May 05 00:30:56 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue May 05 00:31:03 2009] [notice] Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.2 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
    [Tue May 05 14:12:23 2009] [notice] caught SIGTERM, shutting down
    [Tue May 05 14:15:39 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue May 05 14:15:47 2009] [notice] Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.2 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
     
  3. falko

    falko Super Moderator ISPConfig Developer

    You should use Courier, not pop3d. Which guide did you use to set up the system?

    Did you create a Co-Domain for these webs with www as the hostname?
     
  4. jamesls

    jamesls New Member

    Hi Falko

    Email Problem
    I followed the ubuntu 8.10 ispc3 guide.
    It was running ok for a week or so until I added a few domains.
    As far as I know I am running Courier - errr how can I be sure ?
    I'm sure I haven't changed any email settings.


    Http problem.
    I changed the auto subdomain for all the sites to www. on the "sites" panel
    All seems to work ok resolving "www" now. :)
    It may be a daft question but what is a Co Domain

    many thanks

    James
     
  5. jamesls

    jamesls New Member

    Co - Domain
    If your talking about the bits in the dns panel

    I added
    www. 192...local ip of web server A record
    mail. " "
    domainname.ext. " "
    ftp. " "
    ns1. " "
    domainname.ext mail.domanname.ext MX record
    domainname.ext ns1.domainname.ext NS "
     
  6. jamesls

    jamesls New Member

    I had a look at the monitor panel, I probably should have done that at the start.

    Its showing my pop 3 server is down DOOOH

    I tried restarting it and it came up with an error - command not found line 15

    So I had a look at the pop3d file,
    Depending on how it counts lines
    line 15 = PIDFILE=/var/run/courier/pop3d.pid

    and that file is missing

    I think its just the process id
    can I make a file called pop3d.pid and insert the process id - I don't know what number to give it

    james
     
  7. jamesls

    jamesls New Member

    creating a pop3.pid does'nt seem to have worked..
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Please try to restart Courier. you can find the init scripts in the /etc/init.d directory.
     
  9. jamesls

    jamesls New Member

    hi

    I tried /etc/init.d/courier-pop and recieved error line 15
    [email protected]:/home/jaisol# /etc/init.d/courier-pop restart
    : command not found line 15:

    I restarted the machine as well, the courier-ssl bit worked, but it still failed on courier-pop
    with the same error.

    I took a look at the script and I'm trying to figure out what is line 15 - not sure how they count lines, are comments and blanks counted or not.
    Below is the start up script courier-pop



    #! /bin/sh -e
    ### BEGIN INIT INFO
    # Short-Description: Courier POP3 server
    # Provides: courier-pop
    # Required-Start: $remote_fs $syslog
    # Required-Stop: $remote_fs $syslog
    # Default-Start: 2 3 4 5
    # Default-Stop: 0 1 6
    # Description: courier-pop is an POP3 Mail Delivery Agent.
    ### END INIT INFO

    prefix="/usr"
    exec_prefix=${prefix}
    sysconfdir="/etc/courier"
    sbindir="${exec_prefix}/sbin"
    libexecdir="${prefix}/lib/courier"
    run_dir="/var/run/courier"
    calendar_dir="/var/run/courier/calendar"
    TCPD="${sbindir}/couriertcpd"
    DAEMON=${sbindir}/pop3d
    PROGRAM="Courier POP3 server"
    PROG="pop3d"
    SSLCONFIG=

    test -f $DAEMON || exit 0

    . /lib/lsb/init-functions

    if [ ! -d ${run_dir} ]; then
    mkdir -p ${run_dir}
    chown daemon:daemon ${run_dir}
    fi

    if [ ! -d ${calendar_dir} ]; then
    mkdir -p ${calendar_dir}
    chown daemon:daemon ${calendar_dir}
    fi



    if ! [ -x $TCPD ]; then
    log_failure_msg "ERR: $TCPD missing"
    exit 1
    fi
    .......
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Please make sure that the script contains Unix linebreaks, not Windows linebreaks.
     
  11. jamesls

    jamesls New Member

    Thank You for your help

    F..ing windows.... It was the line breaks, every blank line in the etc/courier/pop3d file.

    Every time I restarted it I go another bad command error, finaly it came up OK on restart but wouldn't show up as on line on the monitor.... AHHGGG
    Came up ^M invalid ip address ^M in the logs, that turned out to be the line break at the end of the address= line...

    Just hoping thats all of them,

    Many thanks again, problem solved

    James
     

Share This Page