2.2.40 Problem After Install on SuSE 10.2

Discussion in 'Installation/Configuration' started by macguru, Oct 6, 2011.

  1. macguru

    macguru New Member

    Hi!

    I have just upgraded to ISPConfig2 2.2.40 on SuSE 10.2 (process went smoothly), and immediately run into strange problem. Please note I've made all changes in config files described in "Perfect Setup" manuals.

    Any attempt to access www.mydomain1.com, www.mydomain2.com fails with attempt to download php file instead of processing it.

    HOWEVER. This works fine.
    http://www.mydomain1.com/~web3_blahblahblah/

    AND ISPCOnfig panel www.mydomain.com:81 also function without any problem(s).

    Tail from /var/log/apache2/error.log (almost nothing)

    [Thu Oct 06 17:36:26 2011] [notice] caught SIGTERM, shutting down
    [Thu Oct 06 17:36:28 2011] [notice] Apache/2.2.13 (Linux/SUSE) mod_ssl/2.2.13 OpenSSL/0.9.8k PHP/5.3.3 configured -- resuming normal operations
    [Thu Oct 06 17:41:12 2011] [error] [client 192.168.0.144] Invalid method in request \x16\x03\x01

    Tail from /var/log/apache2/access.log
    NOTHING

    Apache starts *almost fine*, then giving status "running", with these messages:
    Starting httpd2 (prefork) [Thu Oct 06 17:51:09 2011] [warn] The Alias directive in /etc/apache2/httpd.conf at line 322 will probably never match because it overlaps an earlier Alias.
    [Thu Oct 06 17:51:09 2011] [warn] NameVirtualHost 91.135.26.204:80 has no VirtualHosts
    [Thu Oct 06 17:51:09 2011] [warn] NameVirtualHost 192.168.0.1:80 has no VirtualHosts

    Line 322:
    ### ISPC AWStats Section ###
    Alias /awstatsicons "/home/admispconfig/ispconfig/tools/awstats/wwwroot/icon/"
    ### End of ISPC AWStats Section ###

    I have checked /etc/apache2/conf.d/php5.conf

    <IfModule mod_php5.c>
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php .php4
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php .php5
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php .php
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php-source .php4s
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php-source .php5s
    AddHandler ##ISPConfig INSTALL## application/x-httpd-php-source .phps
    DirectoryIndex index.php4
    DirectoryIndex index.php5
    DirectoryIndex index.php
    </IfModule>

    Seems like OK.

    /etc/apache2/vhosts/Vhosts_ispconfig.conf
    New file identical to old one installed by previous version of ISPConfig.

    /etc/apache2/httpd.conf
    and
    /etc/apache2/httpd.conf.06-10-11_16-36-49
    also identical.

    Anyone can suggest what went wrong?

    Thanks in advance for any help.
     
    Last edited: Oct 6, 2011
  2. falko

    falko Super Moderator

    Is /etc/apache2/vhosts/Vhosts_ispconfig.conf included at the end of your httod.conf (or apache2.conf)?
     
  3. macguru

    macguru New Member

    Hi, Falko,

    Thanks for reply. Apart from software upgrade server went to another IP (we changed ISP). I updated server & DNS setting with new IP address.

    File Vhosts_ispconfig.conf seem to be included twice:

    On default SuSE apache.conf
    Include /etc/apache2/vhosts.d/*.conf
    and ISPConfig setting appended to the apache.conf
    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
    I commented out first.

    There seem to be something wrong with DNS

    $TTL 86400
    @ IN SOA ns.domain.lv. hostmaster.domain.lv. (
    2011101007 ; serial, todays date + todays serial #
    28800 ; Refresh
    7200 ; Retry
    604800 ; Expire
    86400) ; Minimum TTL
    NS ns.domain.lv.
    NS 80.232.230.242.

    I have removed 80.232.230.242 from ISPConfig -> Server -> Settings -> Default NS2, but pri.domain.lv is NOT updated. This part is updated automatically by ISPConfig, so even if I remove offending options, they will be reverted back.

    How I can correct this?

    Thanks.
     
    Last edited: Oct 11, 2011
  4. macguru

    macguru New Member

    I checked other pri.domain***.lv files, offending "Inet Address of name server 2" remained an all files, i spite of removing this option from above mentioned settings in ISPConfig2.

    Is there any way to force ISPConfig to overwrite these files with correct settings?
     
    Last edited: Oct 11, 2011
  5. till

    till Super Moderator

    The settings that you talk about are default settings for new created domains, changes there does not change any existing domain. Instead of editing any files directly, change the ns setting in the domain in ispconfig.
     
  6. macguru

    macguru New Member

    OK, thanks, tried it. Unfortunately, DNS Manager -> DNS Entry -> Nameserver 2 cannot be left empty (Nameserver 1 is OK anyway).

    What "dummy" value may be entered here?
     
  7. till

    till Super Moderator

    You can not use dummy entries in DNS. Every DNS Record needs at least two nameservers.
     
  8. macguru

    macguru New Member

    MX DNS Records

    I'm still having issues with DNS, including rejected e-mails - recipients mail server reports "no MX records".

    I checked my server with
    http://www.mxtoolbox.com
    and yes, no MX records found. Quite strange.
    This is from my pri.mydomain.com generated by ISPconfig2:
    mydomain.com. MX 10 IP.xx.xx.xx
    mail MX 10 IP.xx.xx.xx
    MX 10 MX IP.xx.xx.xx

    Is anything missing there?
     
  9. falko

    falko Super Moderator

    Is your ISPConfig server authoritative for your domain? You can check that with
    Code:
    dig ns yourdomain.com
     
  10. macguru

    macguru New Member

    It should be authoritative, please correct if I'm wrong.

    > dig +short NS domain.com
    ns.domain.com

    > dig +short SOA domain.com | cut -d' ' -f1
    ns.domain.com

    May be I should configure:
    mx A xxx.yyy.zzz.qqq

    Name and mail server running on the same PC.
     
    Last edited: Nov 1, 2011
  11. falko

    falko Super Moderator

    No - an MX record must point to an A record, not to an IP address!

    Please check your domain on www.intodns.com
     
  12. macguru

    macguru New Member

    Did it. These warnings are listed:
    --------------------
    Multiple Nameservers ERROR: Looks like you have less than 2 nameservers. According to RFC2182 section 5 you must have at least 3 nameservers, and no more than 7. Having 2 nameservers is also ok by me.
    Pass Nameservers are lame
    --------------------
    Different autonomous systems WARNING: Single point of failure
    --------------------
    MX Records Oh well, I did not detect any MX records so you probably don't have any and if you know you should have then they may be missing at your nameservers!
    --------------------

    Create DNS MX checked in every site. In DNS manager MX records also present.
     
  13. falko

    falko Super Moderator

    Are you sure that your ISPConfig server is authoritative for your domain?
     
  14. macguru

    macguru New Member

    My mistake, my ISPConfig server seems NOT authoritative.
     
  15. falko

    falko Super Moderator

Share This Page