2.2.30 not writing to Vhost_ispconfig.conf apache file

Discussion in 'Installation/Configuration' started by kextra1, Apr 2, 2009.

  1. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    Hello,

    I can create a domain in ispconfig and it shows up...however it keeps sending it to the shared ip page

    I looked at /etc/apache2/vhosts/Vhost_ispconfig.conf

    and noticed that the domains i have just created under 2.2.30 are not showing up in the vhosts file like all the others!

    Please help!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    httpd -t worked

    copied old Vhost file to new one

    httpd -t


    Syntax error on line 836 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    SSLCertificateKeyFile: file '/var/www/web48/ssl/www.domain.net.key' does not exist or is empty

    I never did change any of my apache configuration manually since the problem started though....i did change my SSL site from one domain to the other....that's about it...that shouldnt make a diff. should it?

    Thank you for your help though Till.

    Wouldnt

    I'm running:

    Debian etch 4.0
    PHP5
    etc. etc...everything seems to be all functional
     
    Last edited: Apr 4, 2009
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Are there any copies of the file Vhosts_ispconfig.conf with the date appended to the name that you changed the ssl site?
     
  5. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    Friend must've fixed it

    Hey Till!

    I just got on the vpn and tested everything and it works. I got an email from an old good friend of mine saying that he found the answer within the link Till provided but also had to modify config.inc.php and ispconfig_web.lib.php (optional) so he left me some files to diff and said to read the post u linked above more carefully. Hehe, so thanks again Till! I'll be more thorough in the future man. Plus I'll post a detailed fix once i figure out what all was changed.
     
  6. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    SSL Error Question

    The error was:

    Syntax error on line 836 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    SSLCertificateKeyFile: file '/var/www/web48/ssl/www.domain.net.key' does not exist or is empty

    This was removed, none of the sites have the SSL box checkmarked, however I still want the default ispconfig ssl cert (https://www.domain.com:81) to be valid so it doesnt show up in red.

    My provider i bought the cert from gives me options like:

    Apache + ApacheSSL
    Apache2 + OpenSSL

    Although ISPConfig runs OpenSSL Falko informed me that ApacheSSL was the best choice....however i see no choice for apache2+apachessl on the rapidssl cert table. My certificate keeps coming up as self signed? Any ideas?

    I appreciate your assistance once again Till, I'll get ya back one of these days. I'm a glutton for detail which makes me good at writing documentation :)
     

Share This Page