2.2.24 upgrade - wont' startup - libphp5.so issue

Discussion in 'Installation/Configuration' started by cryptic, Jul 11, 2008.

  1. cryptic

    cryptic Member

    Upgrading from 2.2.18 to 2.2.24. When ISPConfig restarts at the end of the upgrade, I get this:

    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    Syntax error on line 205 of /root/ispconfig/httpd/conf/httpd.conf:
    Cannot load /root/ispconfig/httpd/libexec/libphp5.so into server: /root/ispconfig/httpd/libexec/libphp5.so: undefined symbol: compress
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    ISPConfig system is now up and running!

    ISPConfig won't actually start back up. This is on a CentOS 5.1 system.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    There should be a backup of the /root/ispconfig folder in /tmp. You can try to unpack it and copy the libphp5.so from the backup to /root/ispconfig/httpd/libexec/libphp5.so. MAybe this works.

    Is SELinux disabled?
     
  3. cryptic

    cryptic Member

    Copying over that file worked. Yes, SELinux is disabled.
     

Share This Page