1st test fails - no response to ehlo localhost

Discussion in 'Server Operation' started by cejohnsonsr, Sep 28, 2010.

  1. cejohnsonsr

    cejohnsonsr New Member

    I have installed postfix & related packages per the instructions in:

    Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 10.04)

    A few things to note about this installation. I am using Ubunto desktop. Not server version. I had to install many additional packages to accomodate the required packages. No problem with any of that. Everything went smooth. Just FYI. There were 2 places where the command chmod 0= was used. It didn't work. chmod 0 did work.
    After restarting amavis I got an error that amavis-new couldn't start because /etc/mailname didn't exist. Apparently unable to set $maildir(?) I fixed that one by creating the file with my FQDN as the only entry. Now amavis doesn't start at boot, but does start from the command line. I'm sure those were the only issues encountered during installation & configuration. All of the processes are up on the proper ports & everything has responded as expected up to this point.

    At step 12, page 4, when I perform the 1st test:

    • trelnet local host 25 succeeds.
      ehlo localhost produces no output. Only a blinking cursor on the next line that never times out.

    The HowTo doesn't mention anything about what to look for if the test fails. I've performed the obvious troubleshooting steps. I've checked my work for missed steps & typos. As I mentioned previously, all the processes seem to be running.

    I'm not sure how to proceed.

    Any help will be appreciated.

  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
  3. cejohnsonsr

    cejohnsonsr New Member

    Hello falko,

    Where to begin?...

    First, thanks for answering.

    The short answer is, I don't know. I don't have the logs any more. I tried to follow some of the things I read in other posts & a couple of suggestions from people on other forums & got so far off the mark that I lost track of what all I had done. So I reinstalled the OS from scratch & started over. By following a howto for a very basic postfix install I was able to get the server & Courier POP & IMAP working, but that led me to another problem.

    Now for the longer answer. I hope you'll keep reading & possibly help me work through this.

    I started about a week or so ago trying to build a qmail server. I ran into a problem & was unable to obtain any help at all. That community is apparently all but dead. And there's been nothing new for at least a few years. So I scrapped that & decided to try Postfix. That's how I came to find your HowTo. If I can get it working, it's exactly what I need.

    The original problem was that I couldn't get any mail off of my local network. The specific error was that an SMTP connection couldn't be established. I was unable to determine why that was so. I have verified through several methods that port 25 isn't blocked inbound or outbound, I apparently have a static IP address (although I'm not paying for a static IP) & I'm not on any of the blacklists. I am using DynDNS for name resolution. I'm not entirely certain that the problem may be with DNS, My DynDNS host/A record is cuttinej.ath.cx My hostname (FQDN) is papa.cuttinej.ath.cx. The intention was/is to use the cuttinej part as a subdomain so that email addresses would be [email protected]. Ugly, I know, but it would serve my purposes for now. My MX is also cuttinej.ath.cx. (Normally I wouldn't give specific names, but frankly, after a week of struggling mostly on my own with no success, I don't care who knows. I'll change the names later if I have to.)

    So I installed according to your instructions & encountered the problem that started this thread (1st test failed), then got impatient & trashed my system. After reinstalling the OS I installed Postfix in a very basic configuration via a different howto just to see if I could get a less complex system to work & because I needed something to work on. (Like many others, I'm currently unemployed.) I got Postfix, Courier POP & Courier IMAP working via telnet, netcat, evolution & Thunderbird from within my local network. And I can receive mail from other systems. I tested that by sending some test mail to a test user account via the web interfaces of my ISP's mail service & Yahoo.com. But I'm back to the original problem of not being able to send mail to remote systems. The specific error from /var/log/mail.log is:

    Sep 29 19:45:44 papa postfix/smtp[31007]: 3AE294A1D1E: to=<[email protected]>, relay=none, delay=26020, delays=25915/0.03/105/0, dsn=4.4.1, status=deferred (connect to d.mx.mail.yahoo.com[]:25: Connection timed out)

    It's been trying for a few hours now. The connection attempts are to various servers (i.e a.mx.yahoo.com, b.mx.yahoo.com, etc...). No indication as to why the connection timed out. I've begun to suspect DNS a little less since the Yahoo servers are being resolved. Unless Yahoo is having problems trying to resolve my address. I don't know.

    I'm really kind of stumped here. I haven't had a chance to work in my field for a long time so I'm not very sharp. And it's not looking like I'm going to get that way any time soon if I can't find the answer to this problem. I know it's not the original problem, but I think if I scrapped this box again & rebuilt according to your HowTo again with everything just as it should be, I'd still have this problem. No mail to the world. I don't think I can really proceed with anything until I get this figured out. If I do, I REALLY would like to setup a system as outlined in your HowTo.

    So.... Any chance you might be willing to work with me?

    If you got this far, thanks for hearing me out. And even if you didn't.

    Ed Johnson
    [email protected]

    I seem to be chasing my own tail two ways here. I need a fully functioning system so I can work with it to bring my skills to a level of currency & proficiency that I no longer possess. But I also need a higher level of skill than I currently possess to build such a system. I also keep encountering different problems that eventually lead me back to my original problem. It ain't easy bein' me sometimes.
  4. falko

    falko Super Moderator ISPConfig Developer

  5. cejohnsonsr

    cejohnsonsr New Member

    Hello again. I did that. Saw the link on another thread you were helping with. I also tried the port scan utility. 25, 110 & 143 are open. I also did the same thing with whatismyipaddress.com/ip-lookup. This last one also says my IP is static. I'm not paying for a static IP, but who knows? Maybe cableone prefers to do it that way?

  6. cejohnsonsr

    cejohnsonsr New Member

    New developments:

    Yesterday there were no entries in the mail.err & mail.warn files. Today mail.err contains:

    Sep 29 16:02:43 papa pop3d: Maximum connection limit reached for ::ffff:
    Sep 29 16:03:14 papa pop3d: last message repeated 2676 times
    Sep 29 16:04:15 papa pop3d: last message repeated 8238 times
    Sep 29 16:05:16 papa pop3d: last message repeated 9583 times
    Sep 29 16:06:16 papa pop3d: last message repeated 1494 times

    mail.warn contains:

    Sep 29 14:04:29 papa postfix/smtpd[7981]: warning: address not listed for hostname recover.mxtoolbox.com
    Sep 29 14:07:14 papa postfix/smtpd[8120]: warning: address not listed for hostname recover.mxtoolbox.com
    Sep 29 14:07:45 papa postfix/smtpd[8120]: warning: address not listed for hostname recover.mxtoolbox.com
    Sep 29 16:02:43 papa pop3d: Maximum connection limit reached for ::ffff:
    Sep 29 16:03:44 papa pop3d: last message repeated 6353 times
    Sep 29 16:04:45 papa pop3d: last message repeated 8950 times
    Sep 29 16:05:46 papa pop3d: last message repeated 6688 times
    Sep 29 16:18:22 papa postfix/smtpd[30514]: warning: address not listed for hostname ns1.bitlocal.com
    Sep 30 14:07:59 papa postfix/smtpd[1794]: warning: address not listed for hostname 68-118-116-19.static.gwnt.ga.charter.com

    I'm not quite sure what to make of this. Am I correct in thinking that my POP server is receiving thousands of connection requests?

    Also, more on topic, I was able to send some outbound mail. What I did was make an entry for a relayhost in main.cf. I used my ISP's old mail server & rebooted. The 4 messages that were stuck in the queue went out after I ran 'postfix flush'. That gave me more questions.
    • Do I have to specify a relay host for normal operation? Isn't the MTA supposed to do a DNS lookup of the recipient & deliver to that MX?
    • I can understand that the mail to my ISP was delivered, but there was also test mail to yahoo. That shouldn't have been relayed, should it? Aren't most MTAs configured to NOT relay when the mail is not from it's own domain & NOT destined for someone on it's own domain?

    Well, enough for now. That's where I am.

  7. falko

    falko Super Moderator ISPConfig Developer

    Well, if you are on a dynamic IP or are blacklisted, you should set up relaying so that your mails get delivered.

    What was the outcome of the blacklist check?
  8. cejohnsonsr

    cejohnsonsr New Member

    I posted a reply earlier, but I don't see it. To answer your question, I used several online tools to check blacklists. I'm not blacklisted anywhere. I did find something that I think may be the answer to the problem.

    I ran the smtp test at mxtoolbox.com. One of the functions returned a warning:

    Warning - Reverse DNS does not match SMTP Banner

    The reverse lookup provided this:

    PTR 67-60-31-26.cpe.cableone.net

    I think I may be beginning to understand. My ISP isn't actively blocking port 25 or smtp traffic in general. What they've done is assign a PTR record to the static public IP address assigned to my cable modem. So any reverse lookup is going to return the DNS name of the modem which won't match the name in the original request. I'm assuming that many MTAs will see this as a possible spammer & refuse the connection. Am I on the right track finally? If so, that would explain why a relay host would be necessary. Is there any way to overcome this without a relay host?

    If I'm finally beginning to grasp what's been happening then I can only assume that the original error (1st test fails) was due to some mistake on my part. If so, I guess I'll just have to start over & be more careful this time.

    I'll wait until I hear from you before I scrap this & start over. I'm really hoping to get some confirmation of what I think may be happening.

  9. falko

    falko Super Moderator ISPConfig Developer

    Can you post the output of
    telnet localhost 25
    and then
    ehlo localhost
    so that I can see what's in your SMTP banner?
  10. cejohnsonsr

    cejohnsonsr New Member

    [email protected]:/home/papa# telnet localhost 25
    Trying ::1...
    Connected to localhost.
    Escape character is '^]'.
    220 papa.cuttinej.ath.cx ESMTP Postfix (Ubuntu)
    ehlo localhost
    250-SIZE 10240000
    250 DSN
  11. falko

    falko Super Moderator ISPConfig Developer

    I think the problem is that your server name is a CNAME record instead of an A record.

    mh1:~# dig papa.cuttinej.ath.cx
    ; <<>> DiG 9.3.4 <<>> papa.cuttinej.ath.cx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 49005
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    ;papa.cuttinej.ath.cx.          IN      A
    papa.cuttinej.ath.cx.   20      IN      CNAME   cuttinej.ath.cx.
    cuttinej.ath.cx.        20      IN      A
    ;; Query time: 152 msec
    ;; SERVER:
    ;; WHEN: Sun Oct  3 13:16:30 2010
    ;; MSG SIZE  rcvd: 68
  12. cejohnsonsr

    cejohnsonsr New Member

    Yes I saw that too. I don't know if you saw my earlier message. My ISP has a PTR record for the static IP address assigned to my cable modem. I believe the problem is that the forward & reverse lookups don't match. dig cuttinej.ath.cx returns but dig -x returns 26-31-60-67.cpe.cableone.net. As I understand it, most MTA's (SMTP servers) will refuse a connection to a host that doesn't resolve both ways (fwd & reverse).

    The best solution, in my opinion, is to register a domain so I can have a real host name, and to use a DNS provider that offers an outbound relayhost. That is what I have done. I'm using easyDNS. My new domain is cuttinej.com.

    After I discovered your comparable Virtual Postfix HowTo for Fedora I decided I might like that better since most of my past work was done on RedHat & Fedora. All further posts will be under threads refereing to:

    Virtual Postfix (Fedora 13 x86_64)-'PROBLEM_DESCRIPTION'

    Thank you for all your help thus far. This has been a bit of a slow proccess due to my current skill level. I am, however, finally beginning to make significant progress. I intend to document & post my experiences in this effort so that others may benefit.

    Thank you again,

    Ed Johnson

Share This Page