1and1 Domains for nameservers

Discussion in 'General' started by RingofFire, Oct 16, 2006.

  1. RingofFire

    RingofFire New Member

    I found one post on this earlier, but it didnt answer my questions.

    I used plesk before I decided to move to another control panel that didnt cost a ridiculous amount of money.

    1and1 has a faq here about it, though its not exactly what I did.

    I have a vps from Tektonic, and for plesk, I created two subdomains off of a domain (ns1.mysite.com, ns2.mysite.com) I made in 1and1 admin, assigned a different ip from my server to each subdomain.

    Then for all of my domains under plesk, I added an ns record for each nameserver subdomain.

    And it worked flawlessly.

    It does not work with ISPConfig. Is there any way I can make it work with a 1and1 domain?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    In ISPConfig ist works the same way. Please describe what you did so we can tell you what is wrong with your configuration.
     
  3. falko

    falko Super Moderator ISPConfig Developer

  4. RingofFire

    RingofFire New Member

    well

    I may have something wrong in my config, but let me describe it in detail.

    ns1.mydomain.info has an A record pointing to my main ip.

    ns2.mydomain.info has an A record pointing to my second ip.

    mydomain.info is set to my two name servers.

    my servers hostname is www, and the domain name I put for it was my servers ip.

    What is wrong with this?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    But the DNS entries for mydomain.info are not hosted on your ISPConfig server, right?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you post the real domain name here?
     
  7. RingofFire

    RingofFire New Member

    appalhost.info

    nslookup brings nothing up.

    I editted the dns from my registrar for the nameservers and domain. THe nameserver subdomains I created at my registrar, they do not reside on my server.

    I have it hosted on the machine. The ns records are entered at 1and1 directing to my server and the domains have the regular ns records on my machine.

    The subdomains ns1.appalhost.info and ns2.appalhost.info were created at 1and1, and the A record entry for each pointing to my servers ips are at 1and1 aswell.

    Hope that clarifies. Once again, the same thing worked with plesk 8 and 7.54.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    I tested a bit:

    Code:
    mh1:~# dig appalhost.info
    
    ; <<>> DiG 9.2.1 <<>> appalhost.info
    ;; global options:  printcmd
    ;; connection timed out; no servers could be reached
    Please make sure that your firewall allows access to port 53 TCP and UDP.
    What's the output of
    Code:
    netstat -tap
    ?
     
  9. RingofFire

    RingofFire New Member

    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 *:mysql                     *:*                         LISTEN      30586/mysqld
    tcp        0      0 *:pop3                      *:*                         LISTEN      29754/dovecot
    tcp        0      0 *:imap                      *:*                         LISTEN      29754/dovecot
    tcp        0      0 *:http                      *:*                         LISTEN      32457/httpd
    tcp        0      0 *:ftp                       *:*                         LISTEN      1406/proftpd: (acce
    tcp        0      0 svr.appalhost.info:domain   *:*                         LISTEN      32734/named
    tcp        0      0 *:ssh                       *:*                         LISTEN      28606/sshd
    tcp        0      0 *:smtp                      *:*                         LISTEN      9437/master
    tcp        0      0 svr.appalhost.info:rndc     *:*                         LISTEN      32734/named
    tcp        0      0 *:imaps                     *:*                         LISTEN      29754/dovecot
    tcp        0      0 *:pop3s                     *:*                         LISTEN      29754/dovecot
    tcp        0    668 207.210.77.119:ssh          adsl-222-162-3.clt.be:50402 ESTABLISHED 26214/0
    
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you try to host the domain appalhost.info on the server svr.appalhost.info? This will not work, its the common hen <==> egg problem. You can not have the DNS records of a domain on a server with this domain name.
     
  11. RingofFire

    RingofFire New Member

    The hostname svr.appalhost.info does not work, and has not worked. For all intensive purposes it doesnt need to work for me, I can just use my ip. The setup here worked with plesk, appalhost.info was successfully hosted.

    I can put the hostname on another domain name. Should I try that?
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Your named isn't listening on all interfaces. What's in /etc/hosts and your named.conf?
     
  13. RingofFire

    RingofFire New Member

    hosts has this:

    127.0.0.1 svr.appalhost.info svr localhost localhost.localdomain

    named.conf has this:

    options {
    pid-file "/var/named/chroot/var/run/named/named.pid";
    directory "/var/named/chroot/var/named";
    auth-nxdomain no;
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };

    //
    // a caching only nameserver config
    //
    zone "." {
    type hint;
    file "named.ca";
    };

    zone "0.0.127.in-addr.arpa" {
    type master;
    file "named.local";
    };

    zone "77.210.207.in-addr.arpa" {
    type master;
    file "pri.77.210.207.in-addr.arpa";
    };


    zone "appalhost.info" {
    type master;
    file "pri.appalhost.info";
    };
     
  14. falko

    falko Super Moderator ISPConfig Developer

    Ok, this means that named is listening only on 127.0.0.1...
    What's the output of
    Code:
    ifconfig
    ?
     
  15. RingofFire

    RingofFire New Member

    Code:
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:9621513 errors:0 dropped:0 overruns:0 frame:0
              TX packets:9621513 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:9397417068 (8.7 GiB)  TX bytes:9397417068 (8.7 GiB)
    
    venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
              inet addr:127.0.0.1  P-t-P:127.0.0.1  Bcast:0.0.0.0  Mask:255.255.255.255
              UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
              RX packets:63820 errors:0 dropped:0 overruns:0 frame:0
              TX packets:50434 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:32419736 (30.9 MiB)  TX bytes:6514454 (6.2 MiB)
    
    venet0:0  Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
              inet addr:207.210.77.119  P-t-P:207.210.77.119  Bcast:207.210.77.119  Mask:255.255.255.255
              UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
    
    venet0:1  Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
              inet addr:65.254.53.154  P-t-P:65.254.53.154  Bcast:65.254.53.154  Mask:255.255.255.255
              UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
    
     
  16. falko

    falko Super Moderator ISPConfig Developer

    And what's in /etc/hosts?
     
  17. RingofFire

    RingofFire New Member

    had it above
     
  18. falko

    falko Super Moderator ISPConfig Developer

    Change it like this:

    Code:
    127.0.0.1 localhost localhost.localdomain
    207.210.77.119 svr.appalhost.info svr
    Then restart BIND. What's the output of
    Code:
    netstat -tap
    then?
     
  19. RingofFire

    RingofFire New Member

    Done, and I added my second ip to hosts aswell.

    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 *:mysql                     *:*                         LISTEN      15854/mysqld
    tcp        0      0 *:pop3                      *:*                         LISTEN      3846/dovecot
    tcp        0      0 *:imap                      *:*                         LISTEN      3846/dovecot
    tcp        0      0 *:http                      *:*                         LISTEN      24083/httpd
    tcp        0      0 www.pookalooka.com:domain   *:*                         LISTEN      14089/named
    tcp        0      0 svr.appalhost.info:domain   *:*                         LISTEN      14089/named
    tcp        0      0 localhost:domain            *:*                         LISTEN      14089/named
    tcp        0      0 *:ftp                       *:*                         LISTEN      28354/proftpd: (acc
    tcp        0      0 *:ssh                       *:*                         LISTEN      1723/sshd
    tcp        0      0 localhost:rndc              *:*                         LISTEN      14089/named
    tcp        0      0 *:smtp                      *:*                         LISTEN      7221/master
    tcp        0      0 *:imaps                     *:*                         LISTEN      3846/dovecot
    tcp        0      0 *:pop3s                     *:*                         LISTEN      3846/dovecot
    tcp        0      0 localhost:40043             localhost:rndc              TIME_WAIT   -
    tcp        0   1524 svr.appalhost.info:ssh      adsl-222-162-3.clt.be:50148 ESTABLISHED 8051/0
    Going to test it now
     
  20. RingofFire

    RingofFire New Member

    YAY! Everything works!

    Thanks guys!
     

Share This Page