1 IP install 2 DNS and through a router

Discussion in 'Installation/Configuration' started by catalyst, Apr 4, 2007.

  1. catalyst

    catalyst New Member

    I have one static ip (ie. I connect the ADSL modem to a router.
    I setup my Ubuntu server and ISPConfig with internal IP (
    I would like to register my own primary & secondary DNS in NameCheap or GoDaddy. (ie. ns1.myserver.com, ns2.myserver.com)
    Because I don't want to use the registrant's DNS servers.

    When I setting up the server, I use as the server IP and hostname is ns1.myserver.com, how can I setup the ns1 and ns2 after I have installed the ISPConfig?

    Anyone can help me? What is the procedure for me to setup the primary & secondary DNS correctly? So that the outside world can read my zone records correctly.
    (I forward all the ports from my router to the internal IP address -

    Last edited: Apr 4, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can try to add a A-Record for ns2 pointing to your external IP address.

    But with most registries you need at least 2 external IP addresses to run a a primary and secondary nameserver, so it most likely wont work with just one IP with godaddy.
  3. catalyst

    catalyst New Member

    I will try this later. Namecheap can input just the server name instead of the ip addresses. So there is no problem for Namecheap to register 2 DNS servers with one IP address.
    Thank you!
  4. catalyst

    catalyst New Member

    Hi Till

    But how to config the ns1 (primary dns)?
    If I change the internal ip of ns1 to external ip, the bind will not up.

    I also change the ip address of ns1 from internal to external. Then I try to add the slave dns (secondary dns), the bind is down.
    Should I need to add the slave dns? I set the domain of the slave dns to the ns1's domain.
    Last edited: Apr 5, 2007
  5. catalyst

    catalyst New Member

    It's ok now. I set the slave dns's domain to ns2.ns1-domain.com.
    The bind service is up again. Is this setting correct?

    After that I use dnsstuff.com to check the dns report. It says that my dns is Open DNS server. I follow their instruction and add
    use a line "recursion no;" in the "options" clause (or in the "view" clause)
    the above line to the named.conf to close the open dns server.
    It seems work properly.
    But after I go back to ispconfig to update another zone records.
    The "recursion no" is erased by ispconfig.

    My question is how to add the above line in ispconfig?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    In your configuration, dont crete slave records or bind will fail. Delete all slave records, you need only the primary records.
  7. catalyst

    catalyst New Member

    Yes! Remove of slave dns is ok!

    But how can I add the line "recursion no" in ispconfig to close the open dns. If I modify the named.conf directly, ispconfig will overwrite it if I add a domain to zone records later.

  8. till

    till Super Moderator Staff Member ISPConfig Developer

  9. catalyst

    catalyst New Member

Share This Page