000-default.conf doesn't work

Discussion in 'ISPConfig 3 Priority Support' started by Stelios, Jan 4, 2021.

  1. Stelios

    Stelios Member HowtoForge Supporter

    Hi all,
    In a multi server setup the master server holds only the contropanel and webmail.
    When I browse with the IP of the server or its hostname it comes as default the webmail and not the Apache default web site which is what I want.

    My 000-default.conf has:
    Code:
    <VirtualHost my-ip:80>
            ServerName controlpanel.mydomain.com
            ServerAdmin [email protected]
            DocumentRoot /var/www/html
            ErrorLog ${APACHE_LOG_DIR}/error.log
            CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>
    Thanks
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    I create a 000-aa.com on every host so that is first in the list to show up, and enable SSL for it. Easiest way to do it.
     
    ahrasis likes this.
  3. Stelios

    Stelios Member HowtoForge Supporter

    Thanks Thom, that worked.
     
    Th0m likes this.

Share This Page