The Perfect Desktop - Ubuntu Studio 7.10 - Page 5

Want to support HowtoForge? Become a subscriber!
 
Submitted by o.meyer (Contact Author) (Forums) on Wed, 2007-10-31 18:36. ::

5 Additional Software

I present you a little assortment of additional software to make the agony of choice easier for you. I don't recommend to install all this software - there is no point in installing three audio-players etc... Don't forget to deinstall an already installed software if you are going to install a replacement.

How to install or deinstall software is explained at step 4.

 

5.1 Medibuntu

Some packages like the Adobe Reader are not available in the standard-repositories. The easiest way to make such packages available to your system is to add the medibuntu repository. If you want to add this repository open a terminal ...

... import the repository ...

sudo wget http://www.medibuntu.org/sources.list.d/gutsy.list -O /etc/apt/sources.list.d/medibuntu.list

... import the gpg-key and update your package-list.

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update

 

5.2 Recommended

5.2.1 Microsoft's TrueType Core Fonts

Some fonts, including Arial, Times New Roman and Verdana for example.

If you want to use these fonts, install the following package:

  • msttcorefonts

You will see this window during the setup. Simply click on "Forward".

 

5.2.2 W32codecs

Codecs needed to play MS video formats.

If you want to use these codecs, install the following package:

  • w32codecs

Note: The medibuntu repository is required for this package.

 

5.2.3 Adobe Reader

Homepage: http://www.adobe.com/products/reader/

With the Adobe Reader you can open PDF-documents.

If you want to use the Adobe Reader, install the following packages:

  • acroread
  • acroread-plugins
  • mozilla-acroread

Note: The medibuntu repository is required for this package.

The plugin for firefox will be installed automatically. If you want to check it, open firefox and enter about:plugins into the url-field. Afterwards you should see this:

 

5.2.4 Adobe Flash Player

Homepage: http://www.adobe.com/products/flashplayer/

The Adobe Flash Player enables your browser to play embedded flash content.

If you want to use the Adobe Flash Player, install the following package:

  • flashplugin-nonfree

The plugin for firefox will be installed automatically. If you want to check it, open firefox and enter about:plugins into the url-field. Afterwards you should see this:

 

5.2.5 Sun's JAVA

Homepage: http://www.java.com/en/download/manual.jsp

Sun's Java Runtime Environment adds full Java support to your system.

If you want to use Sun's Java Runtime Environment, install the following packages:

  • sun-java6-jre
  • sun-java6-bin
  • sun-java6-plugin
  • sun-java6-fonts

You will see this window during the setup. If you agree with the license terms, mark the corresponding checkbox and click on "Forward".

The plugin for firefox will be installed automatically. If you want to check it, open firefox and enter about:plugins into the url-field. Afterwards you should see this:

 

5.2.6 NTFS Configuration Tool (ntfs-config)

Homepage: http://flomertens.free.fr/ntfs-config/

With nfts-config you can enable or disable write capability for all your internal and/or external NTFS devices.

If you want to use ntfs-config, install the following package:

  • ntfs-config

 

5.3 Replacements

5.3.1 MPlayer (Replacement for Totem)

Homepage: http://www.mplayerhq.hu

MPlayer is a video player with many features - supporting nearly every known video format, e.g. MPEG/VOB, AVI, Ogg/OGM, VIVO, ASF/WMA/WMV, QT/MOV/MP4, RealMedia, Matroska, NUT, NuppelVideo, FLI, YUV4MPEG, FILM, RoQ and PVA (the w32codecs from step 5.1.2 are needed to support some of the listed formats).

If you want to use the MPlayer, deinstall Totem and afterwards install the following packages:

  • mplayer
  • mozilla-mplayer
  • mplayer-fonts
  • mplayer-skins

 

5.3.2 Digikam (Replacement for F-Spot)

Homepage: http://www.digikam.org/

Digikam is a photo management software.

If you want to use Digikam, deinstall F-Spot and afterwards install the following packages:

  • digikam
  • kipi-plugins
  • showfoto

Note: The theme on the screenshot is "dark".


Please do not use the comment function to ask for help! If you need help, please use our forum.
Comments will be published after administrator approval.