Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd October 2005, 01:01
Lil'Brudder Lil'Brudder is offline
Junior Member
 
Join Date: Oct 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Question Email sent to domain being rejected

When sending email to users on my domain, I get the following returned mail from postfix:

Code:
This is the Postfix program at host www.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

			The Postfix program

<ll_admin@www.www> (expanded from <admin@liquidlightning.com>): Host or domain name not found. 
Name service error for name=www.www type=A: Host not found
I saw another post where the domain wasn't in the local-host-names file, but here is my local-host-names file:

Code:
###################################
#
# ISPConfig local-host-names Configuration File
#         Version 1.0
#
###################################
localhost
www
localhost.www
www.liquidlightning.com
liquidlightning.com
mail.liquidlightning.com
SPConfig local-host-names Configuration File
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
Can anyone help me find the problem why my email server thinks the email address admin@liquidlightning.com is ll_admin@www.www ?

I'm sure it's a hastname problem somewhere as I seem to be struggling with this whole hostname thing (and I thought I finally understood it.)

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 22nd October 2005, 01:43
sapient sapient is offline
Junior Member
 
Join Date: Jul 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

You may want to manually check your MX records / A records ( I had a few MX problems and had to resolve them by editing the dns records by hand).

I checked for your domain's mx records and this is what I got from dnsstuff.com

Quote:
MX FAIL MX Category ERROR: I couldn't find any MX records for liquidlightning.com. If you want to receive E-mail on this domain, you should have MX record(s). Without any MX records, mailservers should attempt to deliver mail to the A record for liquidlightning.com. I can't continue in a case like this, so I'm assuming you don't receive mail on this domain.

Mail FAIL Connect to mail servers ERROR: I could not find any mailservers for liquidlightning.com.
check etc/bind/pri.liquidlightning.com to see if it is correct
Reply With Quote
  #3  
Old 22nd October 2005, 02:20
Lil'Brudder Lil'Brudder is offline
Junior Member
 
Join Date: Oct 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default There is no /etc/bind/

I guess this could be a problem?

There is no /etc/bind so I guess there wouldn't be a pri.liquidlightning.com either.

I thought Bind was running, but now I'm not sure.
Reply With Quote
  #4  
Old 22nd October 2005, 02:40
Lil'Brudder Lil'Brudder is offline
Junior Member
 
Join Date: Oct 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default A Record question

Should my liquidlightning.com A record be my external IP address, or my internal IP address?

I'm running it behind a router with all the necessary ports forwarded.... I thought I had everything configured correctly because it's all working right... I can create websites/email users/ftp/etc, and all the logins work, ftp works, sending mail works... it's just receiving email that doesn't work.

Right now my mail A records looks like this:

Code:
A Record   
----------------------------------- 
  IP-Adresse     Hostname   
  158.91.201.193     mail   
  192.168.1.125     www   


MX   
-----------------------------------
  Mailserver     Hostname   
  liquidlightning.com     mail
Should my mail A record be an internal IP?
Reply With Quote
  #5  
Old 22nd October 2005, 02:57
sapient sapient is offline
Junior Member
 
Join Date: Jul 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Should my liquidlightning.com A record be my external IP address, or my internal IP address?
My understanding is this:

whenever a computer requests a website they goto the nameserver of that site to get the A record for the host www for your site. Then your computer attempts a connection by going to that ip address that was in the A record.

Thus you would want your nameserver to tell any visitors that your www.liquidlightning.com is at your external ip (so they can actually see it!)

Same thing goes for the mail, MX records.

The only time you would want internal records on a nameserver is if that nameserver is acting solely as an internal nameserver for you lan, because your lan can see those local ip's.
Reply With Quote
  #6  
Old 22nd October 2005, 15:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by Lil'Brudder
I guess this could be a problem?

There is no /etc/bind so I guess there wouldn't be a pri.liquidlightning.com either.

I thought Bind was running, but now I'm not sure.
Which distribution do you use?

Quote:
Originally Posted by Lil'Brudder
Should my liquidlightning.com A record be my external IP address, or my internal IP address?
Your external address.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 22nd October 2005, 23:22
Lil'Brudder Lil'Brudder is offline
Junior Member
 
Join Date: Oct 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Question Fedora Core 4

Code:
Which distribution do you use?
I'm using Fedora Core 4.

Also Falko (or anyone else) as per the first post, is there another reason why I get this in the returned email I send to my domain from an outside email address?

Code:
<ll_admin@www.www> (expanded from <admin@liquidlightning.com>): Host or domain name not found. 
Name service error for name=www.www type=A: Host not found
Thanks
Reply With Quote
  #8  
Old 23rd October 2005, 13:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by Lil'Brudder
Code:
Which distribution do you use?
I'm using Fedora Core 4.
On Fedora 4 the zone files are in /var/named/chroot/var/named. There's no directory /etc/bind.

Quote:
Originally Posted by Lil'Brudder
Also Falko (or anyone else) as per the first post, is there another reason why I get this in the returned email I send to my domain from an outside email address?

Code:
<ll_admin@www.www> (expanded from <admin@liquidlightning.com>): Host or domain name not found. 
Name service error for name=www.www type=A: Host not found
Thanks
You have to create an MX record for liquidlightning.com. Currently there's no MX record, as this shows:

Code:
server1:~# dig MX liquidlightning.com

; <<>> DiG 9.2.1 <<>> MX liquidlightning.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42704
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;liquidlightning.com.           IN      MX

;; AUTHORITY SECTION:
liquidlightning.com.    7200    IN      SOA     ns5.zoneedit.com. soacontact.zoneedit.com. 1037464252 14400 7200 950400 7200

;; Query time: 286 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Sun Oct 23 12:58:26 2005
;; MSG SIZE  rcvd: 97
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 25th October 2005, 02:43
Lil'Brudder Lil'Brudder is offline
Junior Member
 
Join Date: Oct 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, I think I'm starting to understand the problem, but, any suggestions on how to resolve this?

I checked in the ../named/ folder as you said my domain name would be in, and it was, with lots of info in the file... including an MX line:

Code:
mail  MX      10 liquidlightning.com.

liquidlightning.com.      A        158.91.201.193
mail       A       158.91.201.193
www       A       192.168.1.125
ns       A       192.168.1.125
ns1       A       192.168.1.125
So, as you described in your DiG,

Code:
;; AUTHORITY SECTION:
liquidlightning.com.    7200    IN      SOA     ns5.zoneedit.com. soacontact.zoneedit.com. 1037464252 14400 7200 950400 7200

;; Query time: 286 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Sun Oct 23 12:58:26 2005
;; MSG SIZE  rcvd: 97
Before I setup this server, I had to use Zoneedit for my DNS, hence the ns5.zoneedit.com, but I thought ISPConfig was a DNS server as well. I'm using GoDaddy as my registrar, and when I tried to put in ns.liquidlightning.com and ns1.liquidlightning.com as the DNS servers, it said:

Unavailable error in field Host name1
Unavailable error in field Host name2


I'm assuming that if I can get GoDaddy to accept my DNS, my server will be able to resolve all the A/MX/etc records and everything will be fine... is this not right?

I have port 53 forwarding to the server, is this the correct port?
Also, I noticed there are 3 other ports open:

Port 5335 (tcp) is open (unknown)!
Port 32769 (tcp) is open (unknown)!
Port 55512 (tcp) is open (unknown)!

Are these used by ISPConfig? Do I need to have them forwarded in my router also? Or can they be left alone?

*Edit*
I just noticed... the IP address is wrong in that Bind file. That's the IP of where the server *will* be... it's on a temporary IP right now. Is that why Godaddy isn't resolveing ns.liquidlightning.com?

If I change that to the temp IP, would that fix it?
*Edit*

Last edited by Lil'Brudder; 25th October 2005 at 02:47.
Reply With Quote
  #10  
Old 25th October 2005, 11:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by Lil'Brudder
I'm assuming that if I can get GoDaddy to accept my DNS, my server will be able to resolve all the A/MX/etc records and everything will be fine... is this not right?
Yes, that's right. You have to make your nameservers authoritative for your domains.

Quote:
Originally Posted by Lil'Brudder
I have port 53 forwarding to the server, is this the correct port?
Yes, but it's port 53 TCP and UDP!

Quote:
Originally Posted by Lil'Brudder
Also, I noticed there are 3 other ports open:

Port 5335 (tcp) is open (unknown)!
Port 32769 (tcp) is open (unknown)!
Port 55512 (tcp) is open (unknown)!

Are these used by ISPConfig? Do I need to have them forwarded in my router also? Or can they be left alone?
No, these ports aren't used by ISPConfig. I don't know what's running on these ports, so if you don't know this either, you should better close them...

Quote:
Originally Posted by Lil'Brudder
*Edit*
I just noticed... the IP address is wrong in that Bind file. That's the IP of where the server *will* be... it's on a temporary IP right now. Is that why Godaddy isn't resolveing ns.liquidlightning.com?

If I change that to the temp IP, would that fix it?
*Edit*
Hm, I think you should contact the GoDaddy support about this... - or just try.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help forward root email to me domino Technical 10 2nd May 2006 15:01
UebiMiau webmail adding @localhostname to email address except first address. Kamran Shah Installation/Configuration 5 11th October 2005 17:01
FTP & Email access jon335 General 3 8th October 2005 03:08
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58
Bind stops and cannot be restarted after a slave domain is added jason Installation/Configuration 20 19th August 2005 08:16


All times are GMT +2. The time now is 21:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.