#1  
Old 18th January 2007, 00:58
K_meleonu K_meleonu is offline
Senior Member
 
Join Date: May 2006
Posts: 108
Thanks: 1
Thanked 5 Times in 4 Posts
Default IP Forwarding

Hi to all,
I have a small problem with ip forwarding.
I have 1 X linux server with 2 network devices. I use Fedora Core 4.
I have eth0 with the ip 89.34.xx.xx , gateway: 89.34.xx.xx and dns 89.34.xx.xx , eth1 and an IP class from 86.106.xx.0 to 86.106.xx.255.
I want to make an ip forward through eth1 and connect a swich on it and then some computers and to give them IP's between 86.106.xx.1 and 86.106.xx.255 .
Can someone tell me how to do this? I have triyed and searched on the internet but no success.
Thank you all in advance.
Alex
Reply With Quote
Sponsored Links
  #2  
Old 18th January 2007, 15:14
nayyares nayyares is offline
Junior Member
 
Join Date: Dec 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,

HTML Code:
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
Cheers
Reply With Quote
  #3  
Old 18th January 2007, 15:49
K_meleonu K_meleonu is offline
Senior Member
 
Join Date: May 2006
Posts: 108
Thanks: 1
Thanked 5 Times in 4 Posts
Default

Dones NOT work. After that i can't access my server . It only responds at ping. no http, no ssh, no nothing....
Reply With Quote
  #4  
Old 18th January 2007, 15:56
nayyares nayyares is offline
Junior Member
 
Join Date: Dec 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hello
HTML Code:
cat  /proc/sys/net/ipv4/ip_forward
and tell what you get?
__________________
Nayyar Ahmad
RHCE (ID:804006858622745)
Skype: nayyares
Reply With Quote
  #5  
Old 18th January 2007, 16:13
K_meleonu K_meleonu is offline
Senior Member
 
Join Date: May 2006
Posts: 108
Thanks: 1
Thanked 5 Times in 4 Posts
Default

HI,
Here it is...
[root@CrazyDesign ~]# cat /proc/sys/net/ipv4/ip_forward
1
I have deleted all the ipforward rules to make it work again and here is my iptables -L now

[root@CrazyDesign ~]# iptables -L
Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
Reply With Quote
  #6  
Old 18th January 2007, 21:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by K_meleonu
Can someone tell me how to do this? I have triyed and searched on the internet but no success.
Thank you all in advance.
Alex
That's a good question.
However:
Quote:
Originally Posted by nayyares
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
doesn't work. It's for NAT, and NAT works only with private IP addresses, but 86.106.xx.xx are public IP addresses.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 18th January 2007, 21:42
K_meleonu K_meleonu is offline
Senior Member
 
Join Date: May 2006
Posts: 108
Thanks: 1
Thanked 5 Times in 4 Posts
 
Default

Yes
I triyed with a firewall "Firestarter" but no effect. I have read somme recomandations on some forums to use IpCop but from what i know it work's only with internal ip's (as 192.168.1.xx)
I have made some changes in the last time.
I have eth0 with the ip: 89.xx.209.254, dns 89.xx.208.2 / 89.xx.208.3 and gateway 89.xx.209.1 and i have added , like virtual interfaces the ip's from 86.xx.86.10 to 86.xx.106.255 on eth0 , so i can run psybnc's on them and other services.
I have putted the IP 86.xx.86.1 on eth1 and leaved the IP's from 86.xx.106.2 to 86.xx.106.9 free to forward them and connect other computers on them.
The bad thing is that i don't manage to make the forward.
If is someone who has done this before or who can help me please help me.
Thank you all,
Alex.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple Segment Router Setup - Not forwarding Packets jkane1517 Server Operation 4 3rd August 2010 19:48
email forwarding locally consumes all resources rdells General 20 1st May 2006 19:43
Email Forwarding to External Mail Server nitefox General 7 1st March 2006 22:16
Where does ISPConfig store mail forwarding Zedix General 2 10th January 2006 15:20
Forwarding mail jysse Installation/Configuration 17 15th September 2005 07:40


All times are GMT +2. The time now is 04:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.