Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th January 2007, 07:43
weslkers weslkers is offline
Member
 
Join Date: Jan 2007
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Default Cant see https://lancom.co:81

i had refer the rest example posted in Howtoforge but still cant solve my problem~! so i decided to post my problem here. i cant see the https://lancom.co:81 in the web browser. This is my netstat -tap

[root@lancom ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost.localdomain:2208 *:* LISTEN 1872/hpiod
tcp 0 0 localhost.localdomain:57409 *:* LISTEN 1877/python
tcp 0 0 *:sco-inetmgr *:* LISTEN 1705/rpc.statd
tcp 0 0 *:mysql *:* LISTEN 1993/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 1686/portmap
tcp 0 0 *:hosts2-ns *:* LISTEN 3251/ispconfig_http
tcp 0 0 localhost.localdomai:domain *:* LISTEN 3389/named
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 1887/cupsd
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 3389/named
tcp 0 0 *:smtp *:* LISTEN 3347/master
tcp 0 0 localhost.localdomain:48005 localhost.localdomain:rndc TIME_WAIT -
tcp 0 0 lancom.webserver.com:48191 mask.wsisiz.edu.pl:ftp ESTABLISHED 2208/python
tcp 0 0 lancom.webserver.com:39883 mask.wsisiz.edu.pl:7844 ESTABLISHED 2208/python
tcp 0 0 lancom.webserver.com:56804 mirror3-eth0.mirrors.t:http CLOSE_WAIT 2208/python
tcp 0 0 lancom.webserver.com:50733 fpserv.fedoraproject.o:http CLOSE_WAIT 2208/python
tcp 0 0 *:imaps *:* LISTEN 2021/dovecot
tcp 0 0 *op3s *:* LISTEN 2021/dovecot
tcp 0 0 *op3 *:* LISTEN 2021/dovecot
tcp 0 0 *:imap *:* LISTEN 2021/dovecot
tcp 0 0 *:http *:* LISTEN 3277/httpd
tcp 0 0 *:ftp *:* LISTEN 3407/proftpd: (acce
tcp 0 0 lancom.webserver.com:domain *:* LISTEN 3389/named
tcp 0 0 *:ssh *:* LISTEN 1896/sshd
tcp 0 0 lancom.webserver.com:ipp *:* LISTEN 1887/cupsd
tcp 0 0 lancom.webserver.com:rndc *:* LISTEN 3389/named
tcp 0 0 *:https *:* LISTEN 3277/httpd


Some more this is my pc iptables -L and ifconfig ;

[root@lancom ~]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

[root@lancom ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:11:09:80:5A:22
inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::211:9ff:fe80:5a22/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2856 errors:0 dropped:0 overruns:0 frame:0
TX packets:2896 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3363482 (3.2 MiB) TX bytes:352097 (343.8 KiB)
Interrupt:177 Base address:0x6e00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3038 errors:0 dropped:0 overruns:0 frame:0
TX packets:3038 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3276118 (3.1 MiB) TX bytes:3276118 (3.1 MiB)

Pls tell me what should i do in order to read the https://www.lancom.co:81 thx
Reply With Quote
Sponsored Links
  #2  
Old 15th January 2007, 08:22
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

The site/domain https://www.lancom.co does not appear in the DNS and your using private IP space. Couple of options.

1. Add www.lancom.co in you local (e.g. your workstation) hosts file. Iif your using Linux that would be /etc/hosts.
2. Setup a DNS server and have lancom.co resolve to your IP
3. Use the IP number of your server https://192.168.1.10:81

I notice you probably do not own the domain lancom.co, so the best option is probably 3:
Code:
dig www.lancom.co

; <<>> DiG 9.3.2 <<>> www.lancom.co
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 26203
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;www.lancom.co.                 IN      A

;; AUTHORITY SECTION:
co.                     10800   IN      SOA     cdcnet.uniandes.edu.co. nic.uniandes.edu.co. 2007011209 21600 3600 432000 43200

;; Query time: 178 msec
;; SERVER: 172.16.3.70#53(172.16.3.70)
;; WHEN: Mon Jan 15 08:13:50 2007
;; MSG SIZE  rcvd: 91
Reply With Quote
  #3  
Old 15th January 2007, 08:42
weslkers weslkers is offline
Member
 
Join Date: Jan 2007
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Default Thx to reply martin

The problem stil cant solve~~ Just now i try https://192.168.1.10:81 and the result is this "Could not establish an encrypted connection because certificate presented by 192.168.1.10 is invalid or corrupted. Error Code: -8182

PS: Pls tell me the full command how to solve it coz i newbie and using the fedora core 6~ THX ya~!
Reply With Quote
  #4  
Old 15th January 2007, 08:51
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Not sure what this error code means, but at least your talking to your ISPConfig server.

Did you have any problems / errors during the installation? Did you answer the Certificate questions (e.g. you did not just hit return)?
Maybe you can clear the certificate in your browser cache. And restart your browser.
Reply With Quote
  #5  
Old 15th January 2007, 09:29
weslkers weslkers is offline
Member
 
Join Date: Jan 2007
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Default To Martin

I had answer all the certificate question, do you think izzit is my hosts problem? This is my hosts;

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
192.168.1.10 lancom.webserver.com lancom


::1 lancom.webserver.com lancom localhost.localdomain localhost

Any wrong setting? or port problem? my router run port 80 or should i change to 81? Pretty bad, till now i still cant experince the ispconfig services~~ so sad ;(
Reply With Quote
  #6  
Old 15th January 2007, 10:36
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,258 Times in 4,122 Posts
Default

Your certificate is corrupted. Please create a new one as described here:

http://www.howtoforge.com/forums/sho...t=firefox+8182
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 15th January 2007, 10:48
weslkers weslkers is offline
Member
 
Join Date: Jan 2007
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Default To till

Cant re create the certificate coz i got this error msg after key in the code:

[root@lancom ~]# openssl genrsa -des3 -passout pass:redhat -out /root/ispconfig/httpd/conf/ssl.key/server/key2 1024
/root/ispconfig/httpd/conf/ssl.key/server/key2: No such file or directory
9314:error:02001002:system library:fopen:No such file or directory:bss_file.c:352:fopen('/root/ispconfig/httpd/conf/ssl.key/server/key2','w')
9314:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:354:

pretty bad~!!!
Reply With Quote
  #8  
Old 15th January 2007, 11:11
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,258 Times in 4,122 Posts
Default

You must enter the commands one ofter another, not all at once. Try to accept the defaults, if you enter anything that the openssl script does not understand, the certificates where not created.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 15th January 2007, 14:48
weslkers weslkers is offline
Member
 
Join Date: Jan 2007
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Default The problem stil cant solve~

Could any1 pls giv me a step by step instruction how to re-create the centificate bcoz i am beginner and not really understanding the coding~ By the way thx to "till" instruction but his instruction make me more confuse~! However, pls help me to solve my problem~@ thx~~
Reply With Quote
  #10  
Old 16th January 2007, 01:19
dhonnoll78 dhonnoll78 is offline
Member
 
Join Date: Dec 2006
Posts: 42
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default Might be a dumb question but it worked for me

It might be a dumb question but when you go to /etc/hosts do you have the ip and host name
192.168.xxx.yyy example.www.example.com

Do you have that line in your hosts file? Without it I couldn´t get mine to work once I added it I have been up and running ever since
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.