Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd January 2007, 10:47
Daisy Daisy is offline
Senior Member
 
Join Date: Dec 2006
Posts: 112
Thanks: 0
Thanked 3 Times in 1 Post
Default allowoverrides / options problem

FC5. Just trying to figure out how to use .htaccess with ISPconfig. Everything I've found in the forums so far hasn't worked.

I added:
Code:
<Directory /var/www/web15/web/>
  AllowOverride All
</Directory>
to the Apache Directives field and checked and verified that it was in /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf so it should be working right? Then all I should have to do is say... add Options +Indexes or whatever to a htaccess file and should work right? I check the error log and it shows "Directory index forbidden by Options directive: /var/www/web15/web/" What am I doing wrong?
Reply With Quote
Sponsored Links
  #2  
Old 2nd January 2007, 12:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,419
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

Normally it shold work like this. Have you tried to remove the slash at the end of the path? If you want to allow this for all websites, you can change the ISPConfig default at the end of your apacahe.conf or apache2.conf file, there is a directory directive for /var/www/*/web
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd January 2007, 14:13
Daisy Daisy is offline
Senior Member
 
Join Date: Dec 2006
Posts: 112
Thanks: 0
Thanked 3 Times in 1 Post
Default

Tried both, neither worked. And WHY does the stupid index.html keep showing up in my web directory no matter how many times I delete it? GRRRRRRRRRRR.

p.s. I assumed you were talking about /etc/httpd/conf/httpd.conf. Is that the right file to be modifying for ispconfig?

Code:
<Directory /var/www/*/web>
    Options +Includes +Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

<Directory /var/www/*/user/*/web>
    Options +Includes +Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
Are there supposed to be two AllowOverrides? I'm not sure that's standard syntax for apache but could be wrong...

Last edited by Daisy; 2nd January 2007 at 14:20.
Reply With Quote
  #4  
Old 3rd January 2007, 09:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,419
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

Quote:
p.s. I assumed you were talking about /etc/httpd/conf/httpd.conf. Is that the right file to be modifying for ispconfig?
Yes, if thats your main apache configuration file.

Quote:
Are there supposed to be two AllowOverrides?
They are for two different directories, one for the websites and the second for the user websites. The syntax is correct for both.

You can try to change:

<Directory /var/www/*/web>
Options +Includes +Indexes
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

to:

<Directory /var/www/*/web>
Options +Includes +Indexes
AllowOverride All
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

and restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 3rd January 2007, 13:28
Daisy Daisy is offline
Senior Member
 
Join Date: Dec 2006
Posts: 112
Thanks: 0
Thanked 3 Times in 1 Post
Default

Tried that. no change. Suggestions?
Reply With Quote
  #6  
Old 3rd January 2007, 13:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,419
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

Are you sure that you access the website in the correct directory and that you access it trough the domain and not trough the IP address? Has this website existed on the server before you installed ISPConfig?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 3rd January 2007, 13:53
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

And did you restart apache?
Reply With Quote
  #8  
Old 3rd January 2007, 17:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

What's in Vhosts_ispconfig.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 16th January 2007, 17:43
Daisy Daisy is offline
Senior Member
 
Join Date: Dec 2006
Posts: 112
Thanks: 0
Thanked 3 Times in 1 Post
Default

Quote:
Originally Posted by till
Are you sure that you access the website in the correct directory and that you access it trough the domain and not trough the IP address? Has this website existed on the server before you installed ISPConfig?
yes. directory is correct. I'm having this problem with every site. I can not use .htaccess on any. not using IP using domain. (IP wouldn't work with virtual hosting.) this site did not exist before. this is a clean install of FC5 with ispconfig using the perfect setup.
Reply With Quote
  #10  
Old 16th January 2007, 17:45
Daisy Daisy is offline
Senior Member
 
Join Date: Dec 2006
Posts: 112
Thanks: 0
Thanked 3 Times in 1 Post
 
Default

Quote:
Originally Posted by martinfst
And did you restart apache?
LOL. Yeah. Wouldn't do much good to have a new config if you didn't load it eh...? (Though I've made that mistake in my past... *smirks*)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 14:15
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Quota Problem with Procmail rafaelenrike Installation/Configuration 1 16th June 2006 02:32
Postfix+MySQL Problem jasutton Installation/Configuration 1 15th June 2006 16:06


All times are GMT +2. The time now is 19:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.